locked
Office 2013 document with Czech spell check lags when save and close on Windows Server 2012R2 RDS session host RRS feed

  • Question

  • On our Win Srv 2012R2 RDS session host server (terminal server) I have bad problem. Office 2013 documents with Czech spell checking lags (1-2 min) when I close and save document. When I change spell checking on English everything works OK. On Windows 8.1 works both spell checking OK.

    I tried to investigate with process explorer, and when winword.exe lags, active thread is wwlib.dll!DllGetClassObject with Stack:

    KERNELBASE.dll!ReadFile+0x3
    MSGR2CZ.DLL!GramGetError+0x3ffeb
    MSGR2CZ.DLL!GramGetError+0x4045f
    MSGR2CZ.DLL!GramGetError+0x47c7f
    MSGR2CZ.DLL!GramGetError+0x10e17
    MSGR2CZ.DLL!GramGetError+0x125c2
    MSGR2CZ.DLL!GramOpenMdt+0x189
    wwlib.dll!wdCommandDispatch+0x251ce8
    wwlib.dll!DllGetLCID+0x31ef72
    wwlib.dll!DllGetClassObject+0x10887a
    wwlib.dll!DllGetClassObject+0x108535
    wwlib.dll!DllGetClassObject+0x107bc6
    wwlib.dll!DllGetClassObject+0x1030c1
    wwlib.dll!DllGetClassObject+0x1077df
    ntdll.dll!RtlInitializeExceptionChain+0x84
    ntdll.dll!RtlInitializeExceptionChain+0x5a

    MSGR2CZ.DLL is Czech language checker.

    Any idea?

    Saturday, February 8, 2014 10:02 PM

All replies

  • Hi,

    As the log, MSGR2CZ.DLL and wwlib.dll were both of the Microsoft libraries,not the third-party libraries. Thus, we need to analysis what happened with the dump file. But, it is beyond what we can do in the forum. I recommend you open a ticket with Microsoft engineer.

    Thanks,

    George Zhao
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please click "tnfsl@microsoft.com"


    Monday, February 10, 2014 6:55 AM
  • Is the issue is occurring after disabling the Add-ins?

    Try to reproduce the issue in Safe Mode.

    Change the default printer to MS XPS Document Writer and reproduce the issue.

    Run appdata (Win + R ; "appdata") -> Microsoft -> Template

    Run WinWord.exe as an Administrator and try to reproduce the issue.

    Rename the "Normal.dotm" to "Normalold.dotm" while doing this please make sure that word application not running.

    Launch Word application, open blank document and close it.

    Now try to reproduce the issue.

    Please let us know about the findings.

    Monday, February 10, 2014 5:50 PM
  • Hi,

    Did the above step helped you resolve your issue.

    Please update if you have any questions on the above issue.

    Regards,

    Thursday, February 20, 2014 3:07 PM
  • Hi,

    I will close this thread as I am unable to get reply from you.

    Please feel free to reply to this post if the issue is not resolved.

    Regards,

    Friday, February 21, 2014 6:19 PM
  • We have same problem. Have you any progress in resolving this problem?
    Tuesday, April 15, 2014 11:25 PM
  • Hi,

    We have same problem. Any news?

    Monday, June 30, 2014 12:09 PM
  • 21.6.2016, we received unofficial patch from MS, that is addressing this issue. Validation tests are passed, fro mtoday, we have this in full production. 

    I asked MS representatives if I can provide new DLL to 3rd parties - if they agree, I will let you know. 

    However, official patch for this issue seems to be close..

    Friday, July 1, 2016 8:44 AM
  • Pasing part of MS representative's reply: 

    The build you have received is not yet a final release, therefore please do not share it.

     

    The final version will be released through Windows update, I don’t know yet the schedule though, I will let you know as soon as I know.

     

    About other customers, you can inform them about the fix… if they are Premier customers, they can get in touch with us through their TAMs, if not, they will have to wait for the public update I am afraid.

    Friday, July 1, 2016 6:20 PM