none
SMS Site Component Manager failed to install this component on this site system.

    Question

  • Hi,

    I'm setting up the SCCM in native mode. All components are in a OK state but the component SMS_MP_CONTROL_MANAGER is in critical. When I look at the alerts there is the following description:

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    SMS Site Component Manager faild to install component SMS_MP_CONTROL_MANAGER on server SCCMTEST.

    The WebDAV server extension is either not installed or not configured properly.
    Solution: Make sure WebDAV is installed and enabled. Make sure there is an authoring rule that allow "All users" read access to "All content". Make sure the WebDAV settings "Allow anonymous property queries" and "Allow property queries with infinite depth" are set to "true" and "Allow Custom Properties" is set to false.
    <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

    All requirements are setup according to the links http://technet.microsoft.com/en-us/library/cc872789.aspx and http://technet.microsoft.com/en-us/library/cc431377.aspx. The WebDAV is enabled, the settings "Allow anonymous property queries" and "Allow property queries with infinite depth" are set to "true" and "Allow Custom Properties" is set to false. I got some messages from the MPSetup.log:

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    <03-24-2009 16:14:41>  [Allow property queries with infinite depth] should be true (false)
    <03-24-2009 16:14:41>  [Allow Custom Properties] should be false (true)
    <03-24-2009 16:14:41>  [Allow anonymous property queries] should be true (false)
    <03-24-2009 16:14:41>  Allow [All users read access to All content] authoring rule should exist (exist)
    <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

    What should I do? Is there any specific setting in the IIS to be setup? Which log file contain more detailed information?

    Thanks in Advance,
    Giancarlo

    Tuesday, March 24, 2009 6:46 AM

Answers

  • Hi Torsten,

    I fixed the problem. The settings were setup OK but for some reason they were not been recognized by the WebDAV component. What I did was open and edit the C:\Windows\System32\inetsrv\config\schema\WEBDAV_schema.xml file. The following parameters were changed:

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    <element name="properties">
          <attribute name="allowAnonymousPropfind" type="bool" defaultValue="true" />
          <attribute name="allowInfinitePropfindDepth" type="bool" defaultValue="true" />
          <attribute name="allowCustomProperties" type="bool" defaultValue="false" />
    <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

    After that, I restarted the service SMS_SITE_COMPONENT_MANAGER and the log shows: "SMS Site Component Manager successfully installed this component on this site system.". I will wait to see if all components change to OK status.
    Wednesday, March 25, 2009 11:34 PM

All replies

  • MPmsi.log should contain a more detailed error description.
    Tuesday, March 24, 2009 7:46 AM
    Moderator
  • Hi Torsten,

    I couldn't find this log file. I searched in all drives but was not found.
    Tuesday, March 24, 2009 11:00 PM
  • Did you also include hidden files and system folders?
    The logfile should be in <dir_where_you_installed_ConfigMgr>\Logs. Is there a mpsetup.log?
    Wednesday, March 25, 2009 7:45 PM
    Moderator
  •  Hi Torsten,

    Yes I did. Below the entries found in mpsetup.log:

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    <03-26-2009 09:09:26> ====================================================================
    <03-26-2009 09:09:26> SMSMP Setup Started....
    <03-26-2009 09:09:26> Parameters: E:\PROGRA~1\MICROS~1\bin\i386\ROLESE~1.EXE /install /siteserver:SCCMTEST SMSMP
    <03-26-2009 09:09:26> Installing Pre Reqs for SMSMP
    <03-26-2009 09:09:26>         ======== Installing Pre Reqs for Role SMSMP ========
    <03-26-2009 09:09:26> Found 1 Pre Reqs for Role SMSMP
    <03-26-2009 09:09:26> Pre Req MSXML60 found.
    <03-26-2009 09:09:26> No versions of MSXML60 are installed.  Would install new MSXML60.
    <03-26-2009 09:09:26> Enabling MSI logging.  msxml6.msi will log to E:\Program Files\Microsoft Configuration Manager\logs\msxml6MSI.log
    <03-26-2009 09:09:26> Installing E:\Program Files\Microsoft Configuration Manager\bin\i386\00000409\msxml6.msi
    <03-26-2009 09:09:27> msxml6.msi exited with return code: 0
    <03-26-2009 09:09:27> msxml6.msi Installation was successful.
    <03-26-2009 09:09:27>         ======== Completed Installion of Pre Reqs for Role SMSMP ========
    <03-26-2009 09:09:27> Installing the SMSMP
    <03-26-2009 09:09:27> Passed OS version check.
    <03-26-2009 09:09:27> IIS Service is installed.
    <03-26-2009 09:09:27> checking WebDAV configuraitons
    <03-26-2009 09:09:28>  WebDAV settings is not setup appropriately
    <03-26-2009 09:09:28>  [Allow property queries with infinite depth] should be true (false)
    <03-26-2009 09:09:28>  [Allow Custom Properties] should be false (true)
    <03-26-2009 09:09:28>  [Allow anonymous property queries] should be true (false)
    <03-26-2009 09:09:28>  Allow [All users read access to All content] authoring rule should exist (exist)
    <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
    Wednesday, March 25, 2009 11:07 PM
  • Hi Torsten,

    I fixed the problem. The settings were setup OK but for some reason they were not been recognized by the WebDAV component. What I did was open and edit the C:\Windows\System32\inetsrv\config\schema\WEBDAV_schema.xml file. The following parameters were changed:

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    <element name="properties">
          <attribute name="allowAnonymousPropfind" type="bool" defaultValue="true" />
          <attribute name="allowInfinitePropfindDepth" type="bool" defaultValue="true" />
          <attribute name="allowCustomProperties" type="bool" defaultValue="false" />
    <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

    After that, I restarted the service SMS_SITE_COMPONENT_MANAGER and the log shows: "SMS Site Component Manager successfully installed this component on this site system.". I will wait to see if all components change to OK status.
    Wednesday, March 25, 2009 11:34 PM
  • Hi Torsten or anyone,

    I'm having same issue with SMS_MP_CONTROL_MANAGER (Component not installed by site component manager), all IIS extension are all ok including WebDav, I have checked all lod file and this is what i got so far
    **************************************
     From MPMSI.Log
    13:10:39] SSL is not required. Skipping prerequisite checks for SSL.
    [13:10:39] Successfully verified WEBDAV Web Service Extension installed and enabled on IIS
    ********************************************
    MPSetup.Log, no reference to WebDav
    **************************************
    compmon.log
    Waiting until the next polling cycle in 5 seconds from now.~  $$<SMS_COMPONENT_MONITOR><Thu Apr 30 13:21:29.875 2009 GMT Daylight Time><thread=488 (0x1E8)>
    Checking components ...~  $$<SMS_COMPONENT_MONITOR><Thu Apr 30 13:21:34.889 2009 GMT Daylight Time><thread=488 (0x1E8)>
    Updated Operations Management registry key values for component SMS_MP_CONTROL_MANAGER; Execution State = 3 and Availability State = 1.~  $$<SMS_COMPONENT_MONITOR><Thu Apr 30 13:21:35.077 2009 GMT Daylight Time><thread=488 (0x1E8)>
    ***********************************************
    Is there anything else i could have checked, I have restarted all the services and all running fine, this only started today

    Please help!

     

    Olu

    Thursday, April 30, 2009 1:31 PM
  • Hello All,

    I think I may have just found a possible cause of the error. The AD has not been extended and it's trying to create a container with site name in AD. I have asked those guys managing the AD to run the AD Shema extension command and will wait till tomorrow to confirm

    Cheers

    Olu
    Thursday, April 30, 2009 3:23 PM
  • Hi Torsten,

    I fixed the problem. The settings were setup OK but for some reason they were not been recognized by the WebDAV component. What I did was open and edit the C:\Windows\System32\inetsrv\config\schema\WEBDAV_schema.xml file. The following parameters were changed:

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    <element name="properties">
          <attribute name="allowAnonymousPropfind" type="bool" defaultValue="true" />
          <attribute name="allowInfinitePropfindDepth" type="bool" defaultValue="true" />
          <attribute name="allowCustomProperties" type="bool" defaultValue="false" />
    <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

    After that, I restarted the service SMS_SITE_COMPONENT_MANAGER and the log shows: "SMS Site Component Manager successfully installed this component on this site system.". I will wait to see if all components change to OK status.

    Thanks for posting this Giancarlo.. You have saved me from going insane.. No matter how many times I changed the config settings to the correct values I couldnt get my MP to install. Editing the schema worked though. Cheers
    Wednesday, May 06, 2009 5:24 AM
  • This same fix just worked for me on a fresh SCCM 2007 R2 SP2 RC installation running on Windows Server 2008 32 Bit.  This should be stickied in the Technet Guides somewhere.
    Wednesday, September 23, 2009 3:43 AM
  • yep, saved me from a whole lot of pain too. Thanks all.
    Monday, November 02, 2009 4:07 PM
  • Thanks Giancarlo. I am running server 08 R2 x64 with sccm r2 sp1. Have been stuck at this for a week until i found this today. The fix works !
    Friday, November 13, 2009 10:09 AM
  • Excellent work Giancarlo,

    I've been on this problem for 2 days! I can also confirm this worked for me running SCCM R2 on 2008 R2 x64

    Many thanks !
    Wednesday, January 13, 2010 2:13 PM
  • Nice find Giancarlo,
    Cheers

    Friday, January 22, 2010 11:54 PM
  • +1
    also helped by the WEBDAV_schema.xml edit.
    Wednesday, February 03, 2010 6:45 PM
  • I'm using Server 2008 R2 and the WebDAV "settings" page in IIS shows the values I have set, but this WEBDAV_schema.xml file does not.  I am not able to edit the file manually however because it is set to read-only.  to change the read-only attribute I must take ownership from "trusted installer".  is this advisable?
    Mike Crowley: MCT, MCSE, MCTS, MCITP: Enterprise Administrator / Messaging Administrator
    Thursday, February 18, 2010 8:34 PM
  • I am having the same problem on a Windows 08 R2 box as well.  I took ownership of the WEBDAV_Schema.xml and made the suggested changes saved them and restarted the system and SCCM still cannot get past this error:

    <03-11-2010 16:36:41> Installing the SMSMP
    <03-11-2010 16:36:41> Passed OS version check.
    <03-11-2010 16:36:41> IIS Service is installed.
    <03-11-2010 16:36:41> checking WebDAV configuraitons
    <03-11-2010 16:36:41> Failed to get WebDAV settings on the machine (0x80070003)


    Any help would be greatly appreciated...
    Thursday, March 11, 2010 9:42 PM
  • I had the same error.  You have to make sure WebDAV is actually Enabled.  It defaults to Disabled.
    Friday, March 26, 2010 5:14 PM
  • Just wanted to say thanks!  Been racking my brian with this one.  Everything Microsoft pointed me to do didn't work.   Something so simple yet it worked!!!!!!!!!

     

    Sunday, March 28, 2010 5:13 PM
  • Wednesday, March 31, 2010 9:04 PM
  • no need to modify manually http://technet.microsoft.com/en-us/library/cc431377.aspx


    It depends ... I never had to edit webdav_schema.xml manually (even on server 2008 R2), but I've seen many users here in the forums where it did not work automatically.

    Wednesday, March 31, 2010 9:16 PM
    Moderator
  • Hi all,

    same problem - MP is failing to install and values in webdav_schema doesn't change, when i configuring iis. Please advise, should i change manually the value of "allowHiddenFiles" to true, if server will be bits enabled distribution point.

     

    Tuesday, May 04, 2010 9:10 AM
  • Yes, you can give that a try.
    Tuesday, May 04, 2010 10:17 AM
    Moderator
  • Thanks Giancarlo. You made one more guy happy by providing this information.
    Wednesday, October 27, 2010 9:46 PM
  • Hi Giancarlo,

    Thanks for your solution. It is working fine for the same issue as you mentioned

    I am not sure whether my understatnding is correct or not.

    Even if we changing WebDAV settings, that changes are not reflected in schema file is due to file permission issue or not.

    Tuesday, November 23, 2010 11:25 AM
  • You are seven different kinds of awesome! Thank you!
    Tuesday, November 30, 2010 10:31 AM
  • I too have been held up by this problem.  Your solution works beautifully.  Thank you for posting this for all to view!
    Wednesday, January 12, 2011 5:54 PM
  • This was exactly what I was looking for. (Editing the XML file, and the minor permissions issue with editing it on a 2008 R2 server.) Thanks!

    Monday, January 17, 2011 8:46 PM
  • Hi Giancarlo,

    I'm facing this problem as mentioned below, but I'm cannot follow your steps because I'm using Windows 2003 R2 & SCCM 2007 SP1.  I have SCCM R2 components but I haven't installed them yet.

    SMS Site Component Manager failed to install this component on this site system.

    Let me know if you need more information.

    Tuesday, February 22, 2011 7:12 AM
  • Better late than never...here is my 2 cents worth...

    I had the same component status error which seems to have been fixed by a suggested solution from a differant error report...unfortunately I cannot remember which seemingly unrelated error report solution I followed but it killed two birds with one stone...

    Open IIS > Web Service Extensions on the site server and set the status of the WebDAV service extension to "Allowed"

    Once I did this the MP install kicked off and self installed successfully at the next 60min retry interval...

    • Proposed as answer by Aaron Fenwick Tuesday, February 21, 2012 4:18 PM
    • Unproposed as answer by Aaron Fenwick Tuesday, February 21, 2012 4:18 PM
    • Proposed as answer by Aaron Fenwick Tuesday, February 21, 2012 5:55 PM
    Wednesday, May 04, 2011 6:45 PM
  • My solution was to add the sccm servers computer account to the local admins group  and enable WebDAV + reboot.

    Then the MP installed fine, then all the clients started installing fine.

    The amount of times I keep forgetting to enable webDAV. Rules were setup fine, just forgot to actually

    turn it on!

    Aaron :-)


    Tuesday, February 21, 2012 4:19 PM
  • Thank you so much Jay. the technet procedures works fine for me. very much appreciated.
    Thursday, May 03, 2012 9:55 AM
  • Hello All,

    After performing the above mentioned solution, still not able to fix the issue?

    Could any one help me on this issue?

    BR

    Madhu


    B Madhu

    Friday, June 22, 2012 12:13 PM
  • Issue has been resolved..

    B Madhu

    Tuesday, July 17, 2012 6:34 AM
  • YES!  Giancarlo's fixed worked great on Server 2012.  I had to finagle the permissions on the file as only TrustedInstaller had full control AND was the owner.  But setting the owner to administrator and temporarily making the permissions changes allowed me to modify the file.  I rebooted and boom, the SMS_SRS_REPORTING_POINT finished installing and now shows up in the "component status" list.

    Spent all day looking for a fix for this and only this worked.

    Thanks!

    Thursday, January 09, 2014 12:25 AM
  • can you please tell me how did you have the permission to edit that file  same issue i am facing and i am not able to update the file that is webdav.xml . please tell me how you have the permission for trustedinstaller
    Thursday, May 14, 2015 12:13 PM