none
Could not parse or process unattend answer file for pass [Specialize] RRS feed

  • Question

  • Hey everyone,

    I'm having a peculiar issue with an image.  I currently use MDT 2010 to manage deploying Windows 7 Enterprise images to our machines.  In creating the problem image, I have done the following:

    1. Installed Win7 Ent. from the DVD

    2. Customized the installation with a few tweaks (this image is the most basic image I've ever made).

    3. Part of the customization involved enabling the built-in admin account.  I then performed most of the changes using that account.

    4.  After customization, I run the MDT sequence for Sysprep and Capture from within the admin account.

    After successfully capturing the image and adding it into our task sequence list I try and deploy the image.  I get as far as "Completing Installation" and I receive the error message above.

    Unattend.xml

    <settings pass="specialize">
    <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">
    <Identification>
    <JoinWorkgroup>WORKGROUP</JoinWorkgroup>
    </Identification>
    </component>
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">
    <ComputerName>m92p-04</ComputerName>
    <RegisteredOrganization>U</RegisteredOrganization>
    <RegisteredOwner>University</RegisteredOwner>
    <DoNotCleanTaskBar>true</DoNotCleanTaskBar>
    </component>
    <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <Home_Page>http://my.u.edu</Home_Page>
    <IEWelcomeMsg>false</IEWelcomeMsg>
    </component>
    <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <RunSynchronous>
    <RunSynchronousCommand wcm:action="add">
    <Description>EnableAdmin</Description>
    <Order>1</Order>
    <Path>cmd /c net user Administrator /active:yes</Path>
    </RunSynchronousCommand>
    <RunSynchronousCommand wcm:action="add">
    <Description>UnfilterAdministratorToken</Description>
    <Order>2</Order>
    <Path>cmd /c reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v FilterAdministratorToken /t REG_DWORD /d 0 /f</Path>
    </RunSynchronousCommand>
    </RunSynchronous>
    </component>
    <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <InputLocale>en-us</InputLocale>
    <SystemLocale>en-us</SystemLocale>
    <UILanguage>en-us</UILanguage>
    <UserLocale>en-us</UserLocale>
    </component>
    <component name="Microsoft-Windows-TapiSetup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <TapiConfigured>0</TapiConfigured>
    <TapiUnattendLocation>
    <AreaCode>""</AreaCode>
    <CountryOrRegion>1</CountryOrRegion>
    <LongDistanceAccess>9</LongDistanceAccess>
    <OutsideAccess>9</OutsideAccess>
    <PulseOrToneDialing>1</PulseOrToneDialing>
    <DisableCallWaiting>""</DisableCallWaiting>
    <InternationalCarrierCode>""</InternationalCarrierCode>
    <LongDistanceCarrierCode>""</LongDistanceCarrierCode>
    <Name>Default</Name>
    </TapiUnattendLocation>
    </component>
    <component name="Microsoft-Windows-SystemRestore-Main" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <DisableSR>1</DisableSR>
    </component>
    </settings>

    Setupact.log (from %systemroot% panther)

    2013-05-16 12:04:34, Info                  CBS    SQM: Failed to start standard sample upload. [HRESULT = 0x80004005 - E_FAIL]
    2013-05-16 12:04:34, Info                  CBS    SQM: Queued 0 file(s) for upload with pattern: C:\Windows\servicing\sqm\*_all.sqm, flags: 0x6
    2013-05-16 12:04:34, Info                  CBS    SQM: Warning: Failed to upload all unsent reports. [HRESULT = 0x80004005 - E_FAIL]
    2013-05-16 12:04:34, Info                  CMI    CBS_Core_Initialize:CbsCorInitialize succeeded
    2013-05-16 12:04:34, Info                  CMI    Callback_CBS_Do_OnlineInstall:Calling startup processing
    2013-05-16 12:04:34, Info                  CBS    Blocked system sleep; prior state: 0x80000003
    2013-05-16 12:04:34, Info                  CBS    Execute state was not set.  Assuming ExecuteStateStart.
    2013-05-16 12:04:34, Info                  CBS    Startup: current ExecuteState is CbsExecuteStateStageDrivers
    2013-05-16 12:04:34, Info                  CBS    Disabling LKG boot option
    2013-05-16 12:04:34, Info                  CBS    Startup: Initializing driver operations queue.
    2013-05-16 12:04:34, Info                  CBS    Startup: Initializing advanced operation queue.
    2013-05-16 12:04:34, Info                  CSI    00000003 CSI Store 3338952 (0x0032f2c8) initialized
    2013-05-16 12:04:34, Info                  CBS    Startup: Running under setup, skipping wait for SC autostart event
    2013-05-16 12:04:34, Info                  CBS    Setting ExecuteState key to: CbsExecuteStateResolvePending
    2013-05-16 12:04:34, Info                  CBS    Startup: Processing advanced operation queue, startupPhase: 0
    2013-05-16 12:04:34, Info                  CSI    00000004 IAdvancedInstallerAwareStore_ResolvePendingTransactions (call 1) (flags = 0000000a, progress = NULL, phase = 0, pdwDisposition = @0x22e0ac
    2013-05-16 12:04:34, Info                  CSI    00000005 Creating NT transaction (seq 1), objectname [6]"(null)"
    2013-05-16 12:04:34, Info                  CSI    00000006 Created NT transaction (seq 1) result 0x00000000, handle @0x684
    2013-05-16 12:04:34, Info                  CSI    00000007@2013/5/16:19:04:34.792 CSI perf trace:
    CSIPERF:TXCOMMIT;606
    2013-05-16 12:04:34, Info                  CBS    Setting ExecuteState key to: CbsExecuteStateComplete
    2013-05-16 12:04:34, Info                  CBS    Clearing HangDetect value
    2013-05-16 12:04:34, Info                  CBS    Saved last global progress. Current: 1, Limit: 1, ExecuteState: CbsExecuteStateComplete
    2013-05-16 12:04:34, Info                  CBS    No pending packages, why was store asked to process pending packages?
    2013-05-16 12:04:34, Info                  CBS    Setting ExecuteState key to: ExecuteStateNone
    2013-05-16 12:04:34, Info                  CBS    Setting RollbackFailed flag to 0
    2013-05-16 12:04:34, Info                  CBS    Clearing HangDetect value
    2013-05-16 12:04:34, Info                  CBS    Saved last global progress. Current: 0, Limit: 1, ExecuteState: ExecuteStateNone
    2013-05-16 12:04:34, Info                  CBS    Startup: Retrying failed packages.
    2013-05-16 12:04:34, Info                  CBS    Startup: Processing complete. [HRESULT = 0x00000000 - S_OK]
    2013-05-16 12:04:34, Info                  CBS    Restored system sleep block state: 0x80000003
    2013-05-16 12:04:34, Info                  CBS    Enabling LKG boot option
    2013-05-16 12:04:34, Info                  CMI    Callback_CBS_Do_OnlineInstall:Calling startup processing succeeded
    2013-05-16 12:04:34, Info                  CMI    CBS_Core_Finalize:Calling cbs core finalize
    2013-05-16 12:04:34, Info                  CMI    CBS_Core_Finalize:Calling cbs core finalize complete
    2013-05-16 12:04:34, Info                  CMI    Callback_CMI_ConfigInstall: CBS startup processing re-run complete.
    2013-05-16 12:04:34, Info       [0x030023] CMI    Callback_CMI_ConfigInstall: Exit.
    2013-05-16 12:04:34, Info                         [setup.exe] OrchestratePostProcessSettings: Post-processing [windowsPE] pass in unattend file [C:\Windows\panther\unattend.xml].
    2013-05-16 12:04:34, Info                         [setup.exe] UnattendSearchExplicitPath: Found unattend file at [C:\Windows\Panther\unattend.xml]; examining for applicability.
    2013-05-16 12:04:34, Info                         [setup.exe] UnattendSearchExplicitPath: Found usable unattend file for pass [specialize] at [C:\Windows\Panther\unattend.xml].
    2013-05-16 12:04:34, Info                  IBS    Callback_Unattend_InitEngine:Using unattend file found at [C:\Windows\Panther\unattend.xml].
    2013-05-16 12:04:34, Info                         [setup.exe] ValidateSMIPass: serialized settings stream; status 0x00000000
    2013-05-16 12:04:35, Info                         [setup.exe] ValidateSMIPass: construct settings context; status 0x00000000
    2013-05-16 12:04:35, Error                        [setup.exe] SMI data results dump: Source = Name: Microsoft-Windows-IE-InternetExplorer, Language: neutral, ProcessorArchitecture: x86, PublicKeyToken: 31bf3856ad364e35, VersionScope: nonSxS, /settings/IEWelcomeMsg
    2013-05-16 12:04:35, Error                        [setup.exe] SMI data results dump: Description = Setting is not defined in this component.
    2013-05-16 12:04:35, Info                         [setup.exe] ValidateSMIPass: load SMI settings; status 0x00000001
    2013-05-16 12:04:35, Error      [0x060432] IBS    The provided unattend file is not valid; hrResult = 0x80220001
    2013-05-16 12:04:35, Error      [0x060565] IBS    Callback_Unattend_InitEngine:The provided unattend file [C:\Windows\Panther\unattend.xml] is not a valid unattended Setup answer file; hr = 0x1, hrSearched = 0x1, hrDeserialized = 0x0, hrImplicitCtx = 0x0, hrValidated = 0x1, hrResult = 0x80220001
    2013-05-16 12:04:35, Info                  IBS    UnattendErrorFromResults: Hit an unattend error; dumping any info we have about the failure...
    2013-05-16 12:04:35, Info                  IBS    UnattendDumpSetting: ------Unattend setting error / warning------
    2013-05-16 12:04:35, Info                  IBS    UnattendDumpSetting: Error code = 0x80220001
    2013-05-16 12:04:35, Info                  IBS    UnattendDumpSetting: Pass = specialize
    2013-05-16 12:04:35, Info                  IBS    UnattendDumpSetting: --------------------------------------------
    2013-05-16 12:04:35, Info                  IBS    UnattendErrorFromResults: Error text = Windows could not parse or process unattend answer file [C:\Windows\Panther\unattend.xml] for pass [specialize]. A component or setting specified in the answer file does not exist.
    2013-05-16 12:04:35, Error      [0x0600c2] IBS    Callback_Unattend_InitEngine:An error occurred while finding/loading the unattend file; hr = 0x1, hrResult = 0x80220001
    2013-05-16 12:04:35, Info                  IBSLIB PublishCriticalError: Publishing blocked message [Windows could not parse or process unattend answer file [C:\Windows\Panther\unattend.xml] for pass [specialize]. A component or setting specified in the answer file does not exist.]
    2013-05-16 12:04:35, Info                         This installation is blocked from completing due to compliance failures or invalid input; this is not an internal error.
    2013-05-16 12:04:35, Info       [0x0a013d] UI     Accepting Cancel. Exiting Page Progress.
    2013-05-16 12:04:35, Info       [0x0a013e] UI     Current and destination pages are the same. Aborting navigation.

    Setupact.log (UnattendGC)

    2013-05-16 12:02:48, Info                         [windeploy.exe] ------------------------------------------------
    2013-05-16 12:02:48, Info                         [windeploy.exe] WinDeploy.exe launched with command-line []...
    2013-05-16 12:02:49, Info                         [windeploy.exe] Setup has not completed, adding pending reboot.
    2013-05-16 12:02:49, Info                         [windeploy.exe] Found generalization state [0x4], setup.exe completion flag [False] --> launching setup.exe.
    2013-05-16 12:02:49, Info                         [windeploy.exe] Launching [C:\Windows\system32\oobe\setup.exe]...

    The Interesting thing is that this Unattend is generated mostly by MDT and is pretty much identical to every other Task Sequence I've created.  I've never run into this issue before with any of our other images.  I would appreciate any guidance you can provide.

    -Gavin

    Thursday, May 16, 2013 5:52 PM

Answers

  • Did you include Internet Explorer 10 in your image, by any chance?  IE 10 seems to have issues with IEWelcomeMsg value existing.  You can delete it by:
    • Modifying the Unattend.xml in \Control\<TS ID>\ directly and remove that line.
    • Modify it in WSIM, find the value for it, right click, disable "write image value".

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    • Marked as answer by FluffyWuffums Thursday, May 16, 2013 8:40 PM
    Thursday, May 16, 2013 6:00 PM
    Answerer

All replies

  • Did you include Internet Explorer 10 in your image, by any chance?  IE 10 seems to have issues with IEWelcomeMsg value existing.  You can delete it by:
    • Modifying the Unattend.xml in \Control\<TS ID>\ directly and remove that line.
    • Modify it in WSIM, find the value for it, right click, disable "write image value".

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    • Marked as answer by FluffyWuffums Thursday, May 16, 2013 8:40 PM
    Thursday, May 16, 2013 6:00 PM
    Answerer
  • I was tearing my hair out in panic all afternoon after I came across this error because we rely heavily on MDT on a day to day basis, and this solved it, thanks!
    Thursday, May 30, 2013 3:23 AM
  • Thanks! That worked! I was hitting my head over this too....
    Friday, June 14, 2013 7:06 PM