locked
Remote Desktop to Windows 8 (in Azure) using a Windows Live Account RRS feed

  • General discussion

  • This took me a while to find this answer so posting it again in case it help anybody and also perhaps somebody has a suggestion of a better way to do it.

    1. I spun up a Windows 8 Pro VM in Azure (using MSDN subscription) which gives me a local account to access it with via RDP. No problems there.
    2. I want to use a Microsoft Account on this VM instead of a local account however, because I want to sync my OneDrive (reason: I have a lot of data in the Cloud via backup programs like Carbonite and CrashPlan  that I want to move to my OneDrive as it has unlimited space now, but don't want to use home or work network for that move as it will take months to move it all about. Cloud-to-Cloud initial data move seemed like it would be quicker hence I am doing it in Azure.)
    3. I can't use OneDrive with the local account no matter what I tried so I had to log in as a Microsoft account.
    4. I tried adding my Microsoft Account to this VM, making it Administrator and then switching the local account to that one but this process failed (even tried different accounts, one without 2-factor auth. enabled: nothing.)
    5. I also tried RDPin in using the MicrosoftAccount\whatever@whatever.com rather than convert or link the local account but that didn't work either. "Your credentials didn't work." Even trying with just the email address didn't work. Nor did using an app password (I have 2-factor enabled of course.)
    6. The only way I was able to log in was to:
    1. Under System properties of the Windows 8 Pro VM, under Remote tab uncheck "Allow connections only from computers running Remote Desktop with Network Level Authentication"
    2. I follered these instructions to create and edit an RDP file on my local pc: http://support.microsoft.com/kb/941641

    Once I connected from my local pc with the modified RDP file to the Windows 8 Pro VM in Azure, I was prompted for the user to log in as by the VM, allowing me to select the Microsoft Account I had previously added instead of the local account which looked the same as if you do it physically at the machine. This had not happened before and once I did, everything was fine after that :-)

    Saturday, November 1, 2014 6:58 PM

All replies

  • Hi,

    Please use the original RDP file in another computer and install the certificate. And then use the new RDP for test


    Karen Hu
    TechNet Community Support

    Wednesday, November 5, 2014 11:05 AM