locked
Enterprise + aspnetwebpages.msi RRS feed

  • Question

  • Hi,

    Installing aspnetwebpages.msi fails at the "updating root web.config" stage and then rolls back on Win 10 Enterprise.  There is no issue on Win 10 Pro.

    I have eliminated all causes listed here: https://support.microsoft.com/en-gb/kb/2531566

    -There is no older version of web pages installed (nor VS2010)

    - allowOverride="true"

    - IISRESET /STOP still fails.  Uninstalling IIS completely still fails.

    - Not read only - the file gets modified during the installation

    Does anyone have any other ideas as to what may be the cause / solution?

    Why does this fail on Ent but not Pro?

    Thanks in advance.

    Scott

    edit: Perhaps a related incident - when installing a data management application, the system check failed on port 80, claiming it was being used by another process.  Checking the port only revealed PID 4 as listening, which I believe is the same on any OS. However, I haven't seen this kind of issue across any OS from 7 to 10 inc. servers.  I still have not discovered which process was to blame.


    • Edited by Scott McC Thursday, January 14, 2016 4:59 PM extra info
    Thursday, January 14, 2016 4:54 PM

All replies

  • Hi Scott,

    About this issue, please ask the forum for ASP.Net for more professional help:

    https://forums.asp.net/

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, January 15, 2016 2:14 AM
  • Given that this is a non-issue on Win 10 Pro, but it is on Win 10 Enterprise, it could be argued it is a Windows issue.  However, I've posted on the ASP.NET forums.

    If anyone could help shine some light on this, I would much appreciate it.


    • Edited by Scott McC Friday, January 15, 2016 2:33 PM crazy small text
    Friday, January 15, 2016 2:33 PM
  • Given that this is a non-issue on Win 10 Pro, but it is on Win 10 Enterprise, it could be argued it is a Windows issue.  However, I've posted on the ASP.NET forums.

    If anyone could help shine some light on this, I would much appreciate it.



    Yes, it installed on Windows 10. However, It's outside of our scope. Too many software based on Windows. we don't know them all well. Please understand that and post it in appropriate forum in order to get the professional support.

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, January 18, 2016 9:03 AM