locked
MOSS 2007 site user prompt while opening site RRS feed

  • Question

  • Hi,

    When i try to open MOSS site, it gives user prompt for login.
    I have added my user to site with XYZ domain and when i open site using XYZ doamin it gives user prompt.
    Please Help...

    Regards,
    Sanjeet
    Saturday, January 9, 2010 12:04 PM

Answers

  • >When i try to open MOSS site, it gives user prompt for login.

    The first step is that the user has access rights. That you have already done.

    However when any user accesses a site he still needs to login to the site; give the username that has been given access to the site) and the password.

    In certain circumstances the user doesn't need to login.

    If the site is anonymous access, there's no need to login.
    If All Authorised Users have been given access rights to the site, the user doesn't need to login if he is a domain member.

    But the most common reason he doesn't need to login is because the login in IE is specifed as being either "Automatic login in the Intranet zone" (the default value) - which only works if IE thinks the site is in the Internet - OR if the security settings for the security zone in which IE thinks the site is in are set to "automatic login using current name and password". Set it to that and it should solve your problem.


    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Saturday, January 9, 2010 1:35 PM

All replies

  • Hi,

    if this a Windows Vista-based computer, please check this http://support.microsoft.com/default.aspx/kb/943280

    Best Regards, Ammar MCT
    Saturday, January 9, 2010 12:27 PM
  • >When i try to open MOSS site, it gives user prompt for login.

    The first step is that the user has access rights. That you have already done.

    However when any user accesses a site he still needs to login to the site; give the username that has been given access to the site) and the password.

    In certain circumstances the user doesn't need to login.

    If the site is anonymous access, there's no need to login.
    If All Authorised Users have been given access rights to the site, the user doesn't need to login if he is a domain member.

    But the most common reason he doesn't need to login is because the login in IE is specifed as being either "Automatic login in the Intranet zone" (the default value) - which only works if IE thinks the site is in the Internet - OR if the security settings for the security zone in which IE thinks the site is in are set to "automatic login using current name and password". Set it to that and it should solve your problem.


    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Saturday, January 9, 2010 1:35 PM
  • Hi All..
    So, As of What I understand, The site and user are both in XYZ domain and when user try to acces it, gfet the login prompt.
    The easiest way to avoid it,(considering User uses XYZ username and password to login to machine):
    Login to the site,then on Internet explorer, click on tools->Internet options ->Security Tab,
    In "Select a zone to view..." box xlixk on "local Intranet" ICON and click on Sites->advanced->click on ADD and OK and OK again on the window.
    Now you are back on the Internet Options.
    Make sure that Intranet zone is selected, click on "Custom Level" button.
    on Next window, scroll to the bottom and Under User Authentication -> logon->select the option "Automatic Logon with current username and password"
    Click OK.
    Close all IE and try to open the site, it should come up fine.
    If this works, You can eitherPush the settings to all machines using login script or the best is AD group policies.

    Thanks!
    I LOVE MS Warm Regards, Kshitiz Posting is provided "AS IS" with no warranties, and confers no rights.
    Sunday, January 10, 2010 8:37 AM
  • > select the option "Automatic Logon with current username and password"

    Read the earlier messages in the thread before you reply.

    I already wrote exactly that in my message that was posted to this thread almost 20 hours before your message (and had already been proposed as an answer).


    Mike Walsh (speaking as a Moderator as well - there is no point in posts that repeat what someone else has already said, instead spend your time answering threads without a useful reply)
    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Sunday, January 10, 2010 11:39 AM
  • Not working on my side,
    I have changed the IE setting as per advised but no luck

    MOSS 2007
    Windows server 2008
    IIS 7
    Sunday, January 10, 2010 1:54 PM
  • Hi Mike,
    I very much respect your Post.
    I just tired to explain what I thought the step by step way to do it.
    Will take care of the same.

    Thanks!
    I LOVE MS..... Warm Regards, Kshitiz Posting is provided "AS IS" with no warranties, and confers no rights.
    Sunday, January 10, 2010 4:11 PM
  • What is the authentication mode you are running the website on?
    Is the Account used to logon to the machine and login to the site is same?
    I LOVE MS..... Warm Regards, Kshitiz Posting is provided "AS IS" with no warranties, and confers no rights.
    Sunday, January 10, 2010 4:11 PM
  • What is the authentication mode you are running the website on?
    Is the Account used to logon to the machine and login to the site is same?
    I LOVE MS..... Warm Regards, Kshitiz Posting is provided "AS IS" with no warranties, and confers no rights.
    My prob solved by putting the site to INTRANET sites (i was on win authentication mode)
    thanks
    Monday, January 11, 2010 6:37 AM