locked
Lync 2013 Dial In Conferencing RRS feed

  • Question

  • I have Lync 2013 Enterprise Edition with six pools. Each pool has at least one number assigned for Dial In Conferencing puposes. The Dial In Conferencing numbers are assigned to a unique region that corresponds to a unique Dial Plan.

    Users aren't enabled for Enterprise Voice. There is a Global Dial Plan, but it isn't associated to a Region for Dial In Conferencing.

    For the most part users get the correct numbers corresponding to their pool. However, sometimes the users get incorrect numbers (those for another pool).

    I don't understand how the users are assigned their default region for Dial In Conferencing. Our six Dial Plans for six different locations are User scope which makes me assume that we would need to explicitly apply the policy to the users (but we don't). Therefore, I would expect the Global Dial Plan to apply, but it isn't associated to a region for Dial In so I would expect that we would never see numbers in an invitation (but we do).

    So, if I have six different locations how do I make sure that the right numbers appear? And why would a different regions' numbers appear?

    Thursday, September 25, 2014 6:49 PM

Answers

  • I'm guessing the logic behind this defaults to use the global dial plan to show numbers if the assigned dial plan doesn't have any assigned numbers.  It kinda makes sense to do it that way, if you think about it.

    I'm going to guess that if you add a number to the "Test Lab" region, you will no longer see the ones associated with "A Different Region"


    Ken Lasko | Lync MVP | UCKen.blogspot.com | LyncOptimizer.com

    • Proposed as answer by Eason Huang Saturday, September 27, 2014 1:35 AM
    • Marked as answer by Eason Huang Monday, October 6, 2014 1:53 AM
    Thursday, September 25, 2014 9:20 PM

All replies

  • To set the correct region and number, you're going to have to set a dial plan to get the right number each time.  If they're not enabled for enterprise voice, you can still set a dial plan.  It may be easiest to do this via the management shell because it won't show up as an option if they're not enabled for Enterprise Voice.

    Try this:

    get-csuser bob | grant-csdialplan -policyname "NorthRegion"

    If setting the dial plan seems to do the trick for you, you could apply the dial plans in bulk by OU or AD group.  Here's a blog post I wrote up that might help with that:

    http://www.lyncfix.com/2014/03/04/bulk-lync-user-addition-via-powershell/


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications


    Thursday, September 25, 2014 7:57 PM
  • Hi Anthony,

    This is true. If I explicitly assign a Dial Plan to the users then they get the correct numbers. What I find odd in this situation is that so many users get the correct numbers without needing to explicitly assign a Dial Plan.

    It seems to be related to the Location Profile assigned to the user. What I noticed is that if I assign a Dial Plan to the user then their Location Profile will read 'City, Country' (same as the Dial Plan). If I set the Dial Plan to Null then they get Default Profile which gives them the USA numbers.

    I wonder if it has anything to do with migrating from OCS 2007 R2 to Lync 2013. In OCS we never assigned Dial Plans we just associated numbers with pools. I would like to do the same now.

    Thanks,

    Thursday, September 25, 2014 8:28 PM
  • Have you attempted to create a pool level dial plan and set the region?

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    Thursday, September 25, 2014 8:31 PM
  • I tried this in my test lab.

    I only have one pool in the lab which has a Global Dial Plan. I associated the Global Dial Plan with a region called A Different Region and created two Dial In conferencing numbers and assigned them that region.

    I created a pool level Dial Plan with a region called Test Lab. There are no Dial In Conferencing numbers associated with Test Lab.

    When I start the Lync client I get a Location Profile that indicates the pool level Dial Plan. However, when I create a Lync Meeting I get the two numbers associated with 'A Different Region'

    So, I did manage to reproduce the behavior. However, I haven't figured out why that happens.

    Thursday, September 25, 2014 9:02 PM
  • I'm guessing the logic behind this defaults to use the global dial plan to show numbers if the assigned dial plan doesn't have any assigned numbers.  It kinda makes sense to do it that way, if you think about it.

    I'm going to guess that if you add a number to the "Test Lab" region, you will no longer see the ones associated with "A Different Region"


    Ken Lasko | Lync MVP | UCKen.blogspot.com | LyncOptimizer.com

    • Proposed as answer by Eason Huang Saturday, September 27, 2014 1:35 AM
    • Marked as answer by Eason Huang Monday, October 6, 2014 1:53 AM
    Thursday, September 25, 2014 9:20 PM
  • Hi Ken,

    It has been a long time since I could focus on this configuration again.

    In my Production environment my Global dial plan is listed first, but it isn't associated with a Dial In Region. Then I have a dial plan for each pool, but it is a User level dial plan. User aren't explicitly granted a Dial Plan because we don't use EV. Each Dial Plan is associated with its own Dial In numbers. This is essentially an untouched config that was migrated from OCS 2007 R2 to Lync 2013.

    With this configuration I would expect that a new user wouldn't get dial-in numbers unless they were explcitly assigned a Dial Plan. However, if I create a new user they get US numbers by default.

    I'm in the process of redesigning the Dial Plans anyway

    Monday, November 17, 2014 7:07 PM
  • If you don't want users to get any dial-in access numbers, its probably a better idea to assign a conferencing policy that doesn't enable dial-in conferencing. That's a surefire way to ensure users don't get the numbers unless you explicitly allow it.


    Ken Lasko | Lync MVP | UCKen.blogspot.com | LyncOptimizer.com

    Monday, November 17, 2014 9:39 PM