locked
exchange 2010 activesync and fileattachments RRS feed

  • Question

  • Trying to download a file attachment around 11 mb to my droid phone and it fails smaller attachments do work. I am connecting t exchange 2010 and have changed all default policys to allow for 20mb files. What am i missing thats not allowing these files to be downloaded? I also have a exchange2003 that has a few mailboxes on it and droid users using active sync to it are able to download these files. 

    Friday, April 29, 2011 4:15 PM

Answers

  • Found the setting. It is located in IIS under active sync site. applications settings

    Default max size was set at 10mb. Once I changed this I was able to download the document.

    • Marked as answer by Alan.Gim Friday, May 6, 2011 9:46 AM
    Friday, April 29, 2011 7:07 PM

All replies

  • Found the setting. It is located in IIS under active sync site. applications settings

    Default max size was set at 10mb. Once I changed this I was able to download the document.

    • Marked as answer by Alan.Gim Friday, May 6, 2011 9:46 AM
    Friday, April 29, 2011 7:07 PM
  • Do you mean the “MaxDocumentDataSize” tag? Yes, “10240000” KB is the default maximum size that can be retrieved via ItemOperations command

    If the limit has been exceeded, the error below will appear

    11. The requested data size is too large

    Thanks for sharing the resolution at here!


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, May 2, 2011 8:56 AM
  • Best way to modify this is in the web.config file in the ClientAccess\sync folder where you installed the exchange bits.

    Modified the following line within the web.config file
    Sets the maximum data size that we will fetch (range or othewise)
    -->
    <add key="MaxDocumentDataSize" value="17825792"></add>

     AND

    <!-- Allow maximum 17 megs of content -->
    <httpRuntime maxRequestLength="17408" />
    <authentication mode="Windows" />


    Than I ran

     

    C:\Windows\System32\inetsrv>appcmd set config "Default Web Site/Microsoft-Server-ActiveSync" -section:requestFiltering -requestLimits.maxAllowedContentLength:17825792

     

    ISSReset

    This did the trick.


    UC KING!

    • Proposed as answer by WADUPHEAD Monday, September 3, 2012 8:06 PM
    Monday, September 3, 2012 8:05 PM
  • DaveLE78, did you change that setting on Exchange 2010 in web.config or directly through IIS Manager GUI? Did it require restart of IIS or it started working immediately. Did you notice some other problems after applying that setting?

    Thanks, MS

    Thursday, May 30, 2013 4:48 AM