none
Temporal Sets using xs:dayTimeDuration RRS feed

  • Question

  • I currently have FIM 2010 R2 installed and I'm trying to create a Temporal Set using xs:dayTimeDuration. The samples I have found on the Internet are using 'PnD' syntax, where n is the number of days.  However for my use case, I need to be more restrictive, like 6 hours. Based on XPath 2.0 syntax linked from FIM 2010 R2 documentation, I would use this:

    (ExpirationTime < op:subtract-dayTimeDuration-from-dateTime(fn:current-dateTime(), xs:dayTimeDuration('PT6H')))

    When I manually run the "FIM_TemporalEventsJob" SQL Job, nothing happens. The UI doesn't support the syntax, so I don't know how to see if the object is part of the set. All I know is that my workflow doesn't execute.  However, if I change the syntax to use 'P1D', everything works as expected...

    My question is: is this a bug or FIM doesn't support the syntax?

     

    Mark Remkiewicz

    Monday, February 17, 2014 10:10 PM

All replies

  • FIM does support this. What are you comparing it against? If you are comparing it against a field that is usually coming is a date with a time of midnight then this could be explained. Try it using 24H if it works then it is as I suggest if not then FIM isn't handling the syntax correctly.

    David Lundell, Get your copy of FIM Best Practices Volume 1 http://blog.ilmbestpractices.com/2010/08/book-is-here-fim-best-practices-volume.html

    Monday, February 17, 2014 10:52 PM
  • Thanks for the quick reply...

    The field I'm using is a custom datetime field which does have the time element (The current UI value is: 2/17/2014 4:00:27 PM EST).

    Using 'PT24H' in the set is translated to 'P1D' in the UI...

    The raw filter is (rcisExpirationDate < op:subtract-dayTimeDuration-from-dateTime(fn:current-dateTime(), xs:dayTimeDuration('PT24H'))).



    Mark Remkiewicz

    Tuesday, February 18, 2014 12:10 AM
  • And forgot to mention... By changing to PT24H works...

    However, when I change it back to PT6H, it does not.


    Mark Remkiewicz

    Tuesday, February 18, 2014 12:18 AM
  • When troubleshooting XPath Filters I like to use Search Scopes because it allows me to put in an XPATH filter in the raw form and see the results. Give that a try. When you get the XPATH working that put it back in the set.

    David Lundell, Get your copy of FIM Best Practices Volume 1 http://blog.ilmbestpractices.com/2010/08/book-is-here-fim-best-practices-volume.html

    Thursday, February 20, 2014 3:57 PM
  • I've used the Search Scopes before... When I tried to use it using the filter above, I got an internal error.  However, I just realized that I pasted the filter using the html encoded operator... After correcting it, it worked in the Search Scope. Before opening a ticket, I will try to use the Search Scope to make sure the filter is working.

    Thanks.


    Mark Remkiewicz

    Thursday, February 20, 2014 9:26 PM