locked
Roaming Profiles with Outlook on two machines - one with the userprofile on C:\ and one on D:\ RRS feed

  • Question

  • Hello,

    while deploying some new virtual machines we encountered a problem with roaming profiles, Outlook 2016 (with Exchange) and different paths to the local user profile:

    On our physical machines the default user path is set on C:\users. The virtual machines (and also some labs) are using D:\. All share one roaming profile. Now we encountered the problem that when an user opens Outlook on the other machines (meaning first on the machine with C:\users, than the machine with D:\) Outtlook couldn't find the OST-path because it search on the other path. So when a user logged on and configured Outlook on a machine where c:\users is the default profile path it expects the OSTs on every machine on c:\users. So it demands the OST also on the other machine in the C:\users ... folder even if there is another default path set.

    So is there a way to set the OST-path dynamic by default (meant %userpath% instead of fixed paths)? We have about 1000 users so a solution for everyone by hand would be tricky ...

    Regards


    Tuesday, May 14, 2019 9:12 AM

All replies

  • Hi,

    According to my research, you may be able to meet your needs via deploying Roaming User Profiles.

    And there is an article for you: Deploying Roaming User Profiles.

    Hope this can be helpful.

    Regards,

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, May 15, 2019 8:42 AM
  • Hello,

    this doesn't help at all. We already have Roaming Profiles and those are a big part of the problem. Our problem, as described above, is that Outlook uses absolute paths for its ost-file-entries. So when using one PC where the user profiles are located on the c-partition and one pc where the user profiles are stored on the d-partition (or another folder) Outlook couldn't find the OST-path.

    For example: We configure Outlook with default user profile C:\users\Mark he writes in the outlook profile that the ost is found under C:\users\mark\appdata\local\microsoft\outlook\myost.ost.

    Now the user locks on another PC loading the roaming profile. Now the default path for the profiles is under D: (C:\users\Mark). But Outlook tries to find the OST under C:\users\Mark. So it runs in an error since the OST is now under D:\users\mark\appdata\local\microsoft\outlook\myost.ost. Outlook uses absolute paths instead of system variables for example. If we could tell outlook to use %LOCALAPPDATA%\microsoft\outlook instead all would be clear.

    Also we couldn't find where Outlook stores the path informations at all. Since when we find where it sets the path we could build a work around. But at all teaching Outlook to use relative paths or setting cache files in the machine settings and not the user settings would be a solution.

    Greetigns

    Wednesday, May 15, 2019 12:15 PM
  • Hi,

    Thanks for your reply.

    In this situation, you can create a GPO to modify the registry to force OST file location - thus allowing you to use %username% as a variable in the path.

    Key: HKEY_CURRENT_USER\Software\Microsoft\Office\<version>\Outlook 
    Value name: ForcePSTPath 
    Value type: REG_EXPAND_SZ 
    Value: path to your storage folder

    Outlook will now use this path by default when creating a new PST file or when connecting to an existing PST.

    Note 1:  Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

    Note 2:  Do not set the path to a network location as this is not supported nor recommended by Microsoft as it could lead to slow performance, data corruption or even data loss.

    Note 3:  Changing this key does not move any existing connected PST files to this path; you’ll have to change that manually.

    Regards,

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, May 17, 2019 7:56 AM
  • Hi,
     
    Please remember to mark the replies as answers if they helped.
    And if you need further assistance on this, please feel free to post back.


    Regards,

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, May 20, 2019 9:07 AM
  • Hello,

    this isn't working at all. We have tried this before. I can use the variable in the registry key in the GPO but when I then look into the registry on the client he uses the absolute path instead of the variable. You can see this in the registry or in the outlook settings under the data file tab (I have created a new profile before to get the ForceOST-Setting). He writes absolute paths there. But for checking we have logged on on the other machine group (where the users are located under d:\users) and the same error occured. Also when we look into the mail profile under data files we see that he uses the absolute path from the first computer.


    Monday, May 20, 2019 3:35 PM
  • Hi,

    Thanks for your reply.

    I'm researching on your issue.

    Once there is any update, I will reply at the first time.

    Thanks for your understanding.

    Regards,

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, May 23, 2019 8:41 AM