locked
How often does data change in the index? RRS feed

  • Question

  •             I have an Excel file that had the wrong “Date modified”.  For some reason it didn’t get changed for a few months even though I had been making regular changes and saving the file routinely since.  I don’t know why that happened, but I must have fixed it because the date is correct now.

                When I do a search for the same file, however, instead of drilling down to the file, the search function finds the file with the old (wrong) date for modification.  If I right-click on the filename and look at properties-details, I see the correct “date last saved”, but still the wrong “date modified”.  If I do the same thing after drilling down through the regular explorer window, the “date modified” is correct.

                This looks like the index used during search was based on properties that were collected during a prior search.  How often are the indexing properties checked as files are changed?  Is there any way I can force a re-index of one file to update the properties?


    Gary Burton
    Wednesday, December 22, 2010 4:20 PM

Answers

  • Hi,

     

    In fact, you can configure local GPOs on individual computers, and the settings will take effect.

     

    The policy describes as following:

     

    If enabled, the search indexer backoff feature will be disabled. Indexing will continue at full speed even when system activity is high.

     

    And as we mentioned above: Windows Search listens for system-wide notifications in the PC (whether for e-mail or other document types), thus keeping the index content fully up-to-date as users are making changes on the PC, Windows Search will wait to update the index contents with the latest change notifications until the next time CPU activity decreases.

     

    As my understanding, Windows Search will update the index content with the latest change even when system activity is high.

     

    You could try to test with your files to check what the result is.

     

    Hope it helps.

     

    Alex Zhao

    TechNet Subscriber Support in forum.

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by techniq1 Wednesday, December 29, 2010 8:07 AM
    Tuesday, December 28, 2010 9:50 AM

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet Forum.

     

    After checking this issue, I would like to confirm if this issue only occurred to the specific Excel file.

     

    Based on my research, the Windows Search index is updated automatically in the background when data is added, deleted, and modified. We could see the following comment in link: Windows Search: Technical FAQ:

     

    Windows Search listens for system-wide notifications in the PC (whether for e-mail or other document types), thus keeping the index content fully up-to-date as users are making changes on the PC. If the smart back off mechanism is engaged, Windows Search will wait to update the index contents with the latest change notifications until the next time CPU activity decreases.

     

    As my understanding, we cannot do this by ourselves.

     

    Currently, you could try to rebuild the index to check the result:

     

    Change advanced indexing options

     

    For more information, please kindly refer to the following article:

     

    Improve Windows searches using the index: frequently asked questions

     

    Hope it helps.

     

    Alex Zhao

    TechNet Subscriber Support in forum.

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, December 24, 2010 9:39 AM
  •     I thought it was automatic, but when the "date modified" didn't change within an hour or so, it looked like it wasn't going to happen.  After forcing the "date modified" to change in my main file, I waited a few hours then reindexed the whole system and it came up right.  

        I never selected the smart backoff, but I could have it selected.  I can't find a setting for it and can't find it in the help file.  Can you help me with that?

        If you happen to have an answer to the following question, please respond.  If not, don't worry about it:  

         One of the hard questions for me to let go of is how come the "date modified" was wrong in the first place.  That was true in the original file also.  I modify the data at least once a week and the modified date was September.  The original file showed the "date saved" date as the "date modified" date.  The only way to know that is to view the file properties, which I was inspired to do when I saw that a search displayed the "date modified" date shown in the properties instead of the date the file was last saved.  That's weird.

        I theorized that "date modified" only applies to the VBA part of the Excel file.  In that case the date shown could be technically correct, so I put a space in the VBA portion then saved it.  Sure enough, when I saved it after changing the VBA text, the two dates tracked.  Not only that, they still track.  Now it works the way I would expect.  Every time I save the file, both dates get changed whether I modify the VBA or not.

        What triggers the updating of "date modified"?  I know I wasn't hallucinating.  Was this an Excel hickup?  Also, why would the explorer window (not the explorer search window) show "date saved" in the "date modified" collumn, whereas the explorer search window apparently shows the real date stored as "date modified"?


    Gary Burton
    Friday, December 24, 2010 11:46 PM
  • Hi,

     

    Thanks for updating.

     

    Regarding your first question, backoff is in Group Policy, you could navigate to the following path to find it:

     

    1.    Click Start, and then Run.

     

    2.    In the Open field, enter gpedit.msc and then press ENTER.

     

    3.    Navigate to Computer Configuration > Administrative Templates > Windows Components > Search > Disable indexer backoff.

     

    According to your description, it seems this issue only occurred to Excel files, I also suggest you post to Excel forum for more help.

     

    Excel IT Pro Discussions Forum

     

    Hope it helps.

     

    Alex Zhao

    TechNet Subscriber Support in forum.

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by techniq1 Monday, December 27, 2010 11:25 PM
    • Unmarked as answer by techniq1 Monday, December 27, 2010 11:33 PM
    Monday, December 27, 2010 10:36 AM
  • It was marked “not configured” and gpedit text said that “disabled” would enable backoff.  I left it the way it was because I am over my head.  I’m not even sure group policy affects a system like mine (networked home user with no passwords).  I’m also not sure that backoff was causing my problem, and I have only seen the problem with one file.  I will save these posts in case it comes up again.

                    Do group policies mean anything on a system like mine?  Should I have enabled it, in order to disable backoff?


    Gary Burton
    Monday, December 27, 2010 11:42 PM
  • Hi,

     

    In fact, you can configure local GPOs on individual computers, and the settings will take effect.

     

    The policy describes as following:

     

    If enabled, the search indexer backoff feature will be disabled. Indexing will continue at full speed even when system activity is high.

     

    And as we mentioned above: Windows Search listens for system-wide notifications in the PC (whether for e-mail or other document types), thus keeping the index content fully up-to-date as users are making changes on the PC, Windows Search will wait to update the index contents with the latest change notifications until the next time CPU activity decreases.

     

    As my understanding, Windows Search will update the index content with the latest change even when system activity is high.

     

    You could try to test with your files to check what the result is.

     

    Hope it helps.

     

    Alex Zhao

    TechNet Subscriber Support in forum.

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by techniq1 Wednesday, December 29, 2010 8:07 AM
    Tuesday, December 28, 2010 9:50 AM
  • Thank you very much.
    Gary Burton
    Wednesday, December 29, 2010 8:07 AM