none
Windows XP Pro SP3 / MS Excel 2003 Macro error RRS feed

  • Question

  • We are running Microsoft Office 2003 on Windows XP Pro SP3 (HP Business Desktop)

    Excel was running fine until recently we started having an error when opening an Excel document with the extension of .xls.

    We get a dialog box now when opening the file saying "Macros are disabled because the security level is set to High and a digitally signed Trusted Certificate is not attached to the macros.  To run the macros, change the security level to a lower setting (not recommended), or request the macro's be signed by the author using a certificate issued by a Certificate Authority." 

    There are then instructions on how to select Macro and Security and how to change this to high.  We noticed that the settings are already set to High on the computer, thus we didn't make any changes as instructed here.

    We then see instructions on how to examine the certificate of trust details and set the "Always trust macros from this publisher." box if you trust the certificate issued by the publisher.
    Click the Enable button to allow the macro to run.
    We don't see where this option is to adjust this?  Where can we find this?  Is it where you open the file or where should we be looking to find the Enable button to allow the macro to run? 

    What else could be the problem?  Are there other things we can try?  We notice that Excel only has this popup box on this specific .xls file and opens others fine.

    This file also does the same popup when opened on another machine running Win XP and Office 2003.  So are there other items we can change in the file iteself to prevent the dialog box from coming up in the future?

    What is recommended to fix this?

    Thanks,
    Dan R
    Wednesday, April 22, 2009 5:18 PM

All replies