locked
IE shortcut on desktop RRS feed

  • Question

  • Another issue in setting up the new computer:  I want a shortcut for Internet Explorer on the public profile's desktop.  It's there - until I set restrictions.  What restriction hides the desktop shortcut?

    Monday, October 29, 2007 7:59 PM

Answers

  • Hi PCPL,

     

    Based on my further test, the following restriction will remove the Desktop tab which contains the Internet Explorer icon configurations:

     

    [Windows Restrictions\General Restrictions\Prevent access to Windows Explorer features: Folder Options, Customize Toolbar, and the My Documents folder]

     

    Please uncheck it to test this issue. As the system may not be secure enough if you have this option unchecked. You can also try the following workaround:

     

    Create a shortcut of Internet Explorer and then copy it to the following folder:

     

    C:\Documents and Settings\All Users\Desktop

     

    This shortcut will appear on all users' Desktop.

     

    Regards,

    Friday, November 2, 2007 6:39 AM

All replies

  • Hi PCPL,

     

    By default, Internet Explorer icon will be hid and there is only one icon (Recycle bin) on the Desktop. This is a by design behavior of Windows XP.

     

    You can perform the following steps to show other Desktop icons such as Internet Explorer: (This is how SteadyState works)

    ----------------------------

    1. Right click on any open area of the Desktop

    2. Click [Properties], select the [Desktop] tab, then click [Customize Desktop] button

    3. Select the [General] tab

    4. Select the check box next to Internet Explorer. Click OK.

     

    There is a group policy related to Internet Explorer Desktop icon which can be used to hide it: (SteadyState will not configure it)

     

    [User Configurations\Administrative Templates\Desktop\"Hide Internet Explorer icon on Desktop"]

     

    Best Regards,

    Wednesday, October 31, 2007 5:40 AM
  • Desktop settings are set to show Internet Explorer on the desktop in all accounts.  I changed the public profile to administrator type long enough to set "Hide Internet Explorer icon on Desktop" as Disabled in group policy. 

     

    The IE shortcut icon is on the desktop - along with other icons I placed there - when the public profile is set as either an administrator or limited account.    When I apply SteadyState restrictions to the account, the IE icon disappears from the desktop, although the other icons remain.  Is there a restriction that could be hiding IE?

     

    Our other public computers have a desktop shortcut to IE.  If this one doesn't, users will think this computer doesn't have Internet access. 

    Thursday, November 1, 2007 3:46 PM
  • Hi PCPL,

     

    Based on my further test, the following restriction will remove the Desktop tab which contains the Internet Explorer icon configurations:

     

    [Windows Restrictions\General Restrictions\Prevent access to Windows Explorer features: Folder Options, Customize Toolbar, and the My Documents folder]

     

    Please uncheck it to test this issue. As the system may not be secure enough if you have this option unchecked. You can also try the following workaround:

     

    Create a shortcut of Internet Explorer and then copy it to the following folder:

     

    C:\Documents and Settings\All Users\Desktop

     

    This shortcut will appear on all users' Desktop.

     

    Regards,

    Friday, November 2, 2007 6:39 AM