locked
Library JPGs and PNGs not showing if Arrange By Type RRS feed

  • Question

  • I've build a new library where I've added some folders with lot's of different content. I love the Arrange By Type option so that I can see all documents in the library arranged by type. So if I want to see all my PDFs, I just have to click of the PDF File and I see all the PDFs. However this doesn't work for JPGs and PNGs. The Arrange By Icons are there and the status bar informs me that I have 800+ PNGs, but if i click on it it goes into an empty folder. Any thoughts on why this is? This also happens for JPGs and BMPs, but not for .ICO. I believe it might have something to do with the thumbnail previews.
    Thursday, May 21, 2009 9:27 AM

All replies

  • Arrange by 'folder', group by (rightclick menu) 'none', sort by (more options) (see 'Type' checkbox) should show all types


    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Thursday, May 21, 2009 1:52 PM
  • I don't think you understood me.

    I know how to get to the files. I just really wanted to use the Arrange By Type feature, but I believe it's broken since it will show an empty folder if I go into the JPG File or PNG File location. But if I choose PSD files, for example, or DOCs, the files are listed perferctly.

    If I could submit a screenshot it would be much more descriptive
    Thursday, May 21, 2009 1:57 PM
  • Valadas,

    I cannot reproduce the error on my machine. So, here's a bunch of questions:

    1. What version of Windows 7? 7100? 32 or 64bit?
    2. Can you post some specifics about your computer (video card, ram, etc).
    3. Just how many files are we talking about? My computer is not great, but not horrible and it takes a bit to load all the pictures in my
        test library.
    4. What view and layout are you using? (Details, large icons, navigation pane, library pane, etc...)
    5. How many locations?

    Let us know...
    Monday, May 25, 2009 5:34 AM
    Answerer
  • 1. Windows 7 Evaluation copy, build 7100
    2. Dell Latitude D630
    3. Total file count 1153.
        PNG File Count 875.
        PSD File Count 96.
    4. Library, arrange by type, large icons
    5. 1 location in the library

    So if I go down the 96 PSD files, I see the 96 PSD files. If I go down the PNG Files, the folder is empty.

    Thanks for the help
    Monday, May 25, 2009 2:00 PM
  • Valadas,

    Just out of curiosity, if you change the view to something other than large icons (details for example) does it still show nothing?
    I see that the D630 with Intel video has shared ram (unless you have the one with the Nvidia card), do you have any idea what the BIOS setting is set to for amount of shared ram?
    How much ram is in the laptop total?
    Monday, May 25, 2009 3:06 PM
    Answerer
  • Same problem here !!

    Damn, I'm glad to see I'm not the only one having this issue. Anyway, to describe the problem better, here are some screen caps:



     


    This are the content of My Documents folder (or any other folder containing any kind of files) viewing them from a Library. When opening this library and ONLY when i arrange and sort them by Type, as you can see it finds JPG files, (5 files), but it says Empty Folder ("Carpeta vacia" in Spanish).

    When you access to these JPG, you get indeed an empty folder.

     


    But the files are there, if you view the documents by Folder, by Author... or if you simply go to the real folder they are contained in, you can see them perfectly.

    I've tried to change the icon size as dwolters say, and the problem stays the same.

    Btw, this problem only happens to me with JPG and MP3 files, as far as I know.
    Friday, December 18, 2009 4:19 PM
  • I wonder whether they might show up if you were to enable the view of file extensions (the stuff past the dot in the filename, from which file "type" is derived).

    Try this:

    1.  From an Explorer window, to see the menu headings, choose Organize -> Layout then check Menu Bar.

    2.  Choose Tools -> Folder Options...

    3.  Click the View tab.

    4.  UNcheck Hide extensions for known file types.

    5.  Now try viewing the Library, and sorting by File Type.


    Have you tried clearing your thumbnail cache?
    http://www.addictivetips.com/windows-tips/clear-delete-the-thumbnail-cache-in-windows-7/


    Another possibility is that an application you have installed on your system has taken responsibility for providing thumbnail views for those particular file types.  Have you installed any photo editors or viewers?


    -Noel
    • Proposed as answer by Noel Carboni Saturday, December 19, 2009 12:28 AM
    Saturday, December 19, 2009 12:19 AM
  • I have the same issue.  I just confirmed that the issue still exists after showing file extensions and clearing my thumbnail cache.

    The files are there.  For example, if I back out one level to where it shows all the stacks, and then type ext:.png into the search box, it lists out all PNG files.

    So annoying!  Also to my knowledge there is no 3rd party apps on the PC.  The only change I've done from stock is to install Windows Live Essentials.  I tried setting the default photo viewer away from Live Photos and back to Windows Photo Viewer, but that had no effect either.

    It seems that all image file type stacks return empty when opened.  GIF and BMP stacks do the same thing to me.

    Should I open an official support case with Microsoft for this issue?


    Sunday, January 10, 2010 1:42 AM
  • Sounds like a bona fide bug.

    I can't for the life of me understand what Microsoft was thinking with Libraries.  A pure add-on (some might say hack), no integration at all!

    More Explorer magic is not a good direction!

    -Noel
    Sunday, January 10, 2010 3:21 AM
  • Oh I wouldn't go that far, I do love libraries.  I think they're pretty much the natural evolution of storage paradigms.  I nearly feel like they're the power behind Picard's ship's LCARS ;-)

    I wish other OS's I used had libraries, especially at work where I'd appreciate aggregating my network and local projects and storage into a single view.
    Sunday, January 10, 2010 4:06 AM
  • Hi,

     

    This problem may already been solved, but i had the same problem and found out that 'organize by type' depends on the windows search indexing options.

    Check if all locations in your library are also included in 'Indexing options'  (control panel).

    Friday, August 13, 2010 5:53 AM
  • I just noticed the same problem. It seems that "Arrange By Type" will NEVER include library locations that are network shares on another machine (even though this machine has Windows Search installed and is indexing the files).

    Curiously, "Arrange by <anything else>" does seem to work.

    Tuesday, January 25, 2011 2:07 PM
  • So has this problem been resolved?

    How can we fix this?

    Sunday, January 15, 2012 3:04 PM
  • Recreating the library worked for me, which lead me to believe something was incorrect in the library XML schema file.  To do that, just right-click and delete the Pictures library.  Then right-click the Libraries heading and choose restore default libraries.
    Shawn Keene
    Sunday, January 15, 2012 5:22 PM
  • Not true, it works fine by default.  Here's my Windows 7 machine set to Arrange By Month (picture).

    As I said, I resolved it by recreating the library.  It only took a few clicks and worked instantly.


    Shawn Keene
    Sunday, January 15, 2012 8:33 PM
  • Hmm nope, it still works fine for me.  Ever since I recreated the library about 2 and a half years ago. I've never had to do it again.

    Picture:  http://skeene.net/answers/ArrangeByMonthFolder.png

     

    What triggers your bug to happen again?  Is it some other software?


    Shawn Keene
    Sunday, January 15, 2012 10:55 PM
  • This was a standard account.  However my admin account has no such issue either.

    It certainly wasn't predicated by an update, as I had this issue several years ago when Windows 7 was first released.  After resolving it, I've applied years of updates, patches, and service packs, and it has never been a problem.

     

    The issue stems from the XML file that controls how the library organizes results.  If you open this folder on your computer, you'll see what appear to be your libraries.  In fact, however, you can drag-drop one of these files into Notepad to see the exact XML syntax.  This determines not only the locations in the library, but how they are sorted, indexed, and viewed.  This is where your problem is.

    %appdata%\microsoft\windows\Libraries

     

    Something on your computer is modifying that XML data and causing your arrangement to be invalidated.


    Shawn Keene
    Monday, January 16, 2012 1:32 AM
  • I have a similar issue.  Was yours resolved?

    My issue is impacting several people.  We use folder redirection to house the My Documents folders on a file server.  All Win 7 Enterprise clients with Server 2008 R2 file server.
    Users can click on the Documents library to see all of their files arranged by folder, however if the affected users arrange by any other choice, their folder says it is empty and no data can be accessed.  This can be repeated in every folder they have under Documents.  It impacts all file types.  Need a fix as I cannot recreate their libraries.  Any help is greatly appreciated.


    James

    Thursday, March 29, 2012 5:23 PM
  • I have the same Problem.

    If I choose "Arrange by Date" in the Picture Libary it doesn't show all Pictures which are in the File. It's the same when I ""Arrange by Month", the File just shows 188 Pictures, but there are many more in this File!  

    Only if I click "Arrange by File" it shows all Pictures and not just some.

    Any help?



    • Edited by Marlonzzz Thursday, May 23, 2013 3:59 PM
    Thursday, May 23, 2013 3:47 PM
  • I was able to repair my issue by blowing away and redoing the index on affected computers.  In the past, I had stayed away form indexing the offline files that were created form my folder redirection implementation because it slowed network saves.  However after Windows 7 Service Pack 1 was released, that problem went away and I was able to index the offline files.  I realized that enabling the index in some cases, and rebuilding the index in other cases solved this view issue.  I hope this helps.

    James

    • Proposed as answer by Marlonzzz Thursday, May 23, 2013 10:13 PM
    Thursday, May 23, 2013 4:44 PM
  • Thank you! Danke! The Problem is solved!
    Thursday, May 23, 2013 10:14 PM