locked
Can't comment on BLOG posts RRS feed

  • Question

  • On all the BLOGs we set up on our SP2013 site, users are unable to leave comments on blog posts.  

    When i look at the HTML i see that the outer CommentContainer div exists but the input box and submit button within it don't exist.

    This is all that exists.

    <div id="{26E57373-F1F4-41FE-8877-D78B5AFBC113}-{C46202C2-C47B-42A4-9F54-6A676E74DD34}-CommentContainer">  </div>

    On working blogs i've seen, the following should exist within it,..

    <div><textarea ms-fullWidth ms-helperText" id="{26E57373-F1F4-41FE-8877-D78B5AFBC113}-{C46202C2-C47B-42A4-9F54-6A676E74DD34}-CommentTextBox" style="height: 30px; min-height: 30px;">Add a comment</textarea></div>
    <div><div><button disabled="" ms-floatRight" id="{26E57373-F1F4-41FE-8877-D78B5AFBC113}-{C46202C2-C47B-42A4-9F54-6A676E74DD34}-CommentSubmit">Post</button></div></div></div>

    Permissions are set up correctly as well.

    Does anyone have any tips on what is happening?  We've hit a brick wall trouble-shooting it.

    thanks


    Wednesday, November 25, 2015 5:48 PM

Answers

  • Hi ccpoulain,

    From your description, user can't comment on BLOG posts.

    For your issue, make sure the user have at least contribute permission on "comments" list in the blog site.

    Best Regards,

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, November 30, 2015 8:33 AM

All replies