locked
WSUS 2016 Reports truncating output RRS feed

  • Question

  • Hi,

    I've just installed WSUS on Windows Server 2016 to replace an old WSUS 3.0 server, and all of the detailed reports are badly formatted, with a lot of the information apparently truncated. These reports are split into five; Description, Approval Summary, Status Summary, Computer Detailed Status Report and Report Options.

    On our old WSUS 3.0 server, these sections are displayed, with a vertical scrollbar, with the Description, Approval Summary and Status Summary following on from each other, with Computer Detailed Status Report on a separate set of pages and finally Report Options on its own page at the end. All parts are readable.

    On the new server, these four sections are displayed with no vertical scrollbar, with the first page split vertically into two parts. The top part shows the Description and possibly the Approval Summary (which is hidden), the bottom part shows the Status Summary. On the next page, the Computer Detailed Status Report is shown (truncated), followed by a blank page, then the Report Options. 

    We've reinstalled WSUS several times, and played about with the report layout and choices, and nothing seems to correct the problem. Can anyone suggest a solution to this? 

    (It seems that, until my account has been verified somehow, I can't post images to show such a report.)

    Wednesday, May 3, 2017 3:32 PM

Answers

  • Hi Anne,

    Thanks for getting back to me. I did take a look at that thread after your response, but then got put onto another task.

    The WSUS server did have both components installed; the "Microsoft® System CLR Types for Microsoft® SQL Server® 2012" x64 package (v11.0.2100.60) and "Microsoft Report Viewer 2012 Runtime" package (v11.0.2100.60).

    To compare behaviours, I built a new WSUS server from scratch, and downloaded and installed the two packages (CLR Types from https://www.microsoft.com/en-gb/download/details.aspx?id=29065#SQLSYSCLR and Report Viewer from https://www.microsoft.com/en-us/download/confirmation.aspx?id=35747), which did not experience the same problem.

    Comparing the two servers, I found that I had installed a newer version of the "Microsoft Report Viewer 2012 Runtime" package (v11.1.3452.0), so I updated the report viewer on the original server, which resolved the issue.


    • Marked as answer by Asckey Pak Tuesday, May 23, 2017 10:53 AM
    • Edited by Asckey Pak Tuesday, May 23, 2017 11:00 AM
    Tuesday, May 23, 2017 10:53 AM

All replies