none
Set with filter Expirationtime comparison current-datetime does not list members: regional settings? RRS feed

  • Question

  • Hi all;

    I've created a criteria-based set that has to filter for users that have an "expiration Time" "prior to" "today".
    xpath filter: /Person[ExpirationTime < fn:current-dateTime()]

    I've got one user where I've set a date expired to a week ago.

    When I click view members it does not return any results. When I change the logic to "expiration Time" "after" "today".  to see how this logic works, it doesn't return any results either.

    I'm working in Belgium, regional settings are d/MM/yyyy H:mm (in 24h format).
    My browser language is also set to nl-BE, where FIM actually uses this in the PORTAL field too:

    Today in Belgium is 16/09/2014 16:45. But My set returns 0 members.

    I've read some articles that FIM needs the format in yyyy/MM/dd format (for import)

    Is it correct that FIM Portal doesn't handle this XPATH current-dateTime() function correctly for foreign regional settings?

    I've tried to set it current-dateTime("d/MM/yyyy") or other variants, but that gives an error when I'm trying to save.

    Kind regards,
    David



    Tuesday, September 16, 2014 3:01 PM

Answers

  • Found the issue. (OMG so lame :$ )

    The "employee end date" is not the FIM attribute "expiration time (ExpirationTime)".
    The "employee end date" is the FIM attribute "employee end date (EmployeeEndDate)".

    I've done the change, with Belgian time format, my set is OK now.

    But this was not a waste
     => I've now got fully language compatible FIM Portal :)

    Wednesday, September 17, 2014 10:59 AM

All replies

  • Hi David,

    Make sure your SQL Agent is running. Also try to run Jobs that is related to maintain Set membership. Remember that your SQL Agent is responsible to calculate mebership of Sets so it has to be enabled and set to "Automatic".

    FIM Portal current-dateTime is taken from FIM Portal's settings (you can specify time zone there).


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    Tuesday, September 16, 2014 6:38 PM
  • Hi,

    I've checked, the "SQL Server Agent (MSSQLSERVER)" is running, and set to automatic.

    I've changed the Local default to "dutch (Belgium)" in the Site settings (it was English (US)):

    I've launched iisreset to restart the website.

    I've looked at the set, no members. I've validated if the users its date format was OK (and Belgian/European style) => it was.

    I've played in the set with the different options (I'm translating as these are in Dutch):

     - Prior to 1 day 
     - Prior to 1 day from today
     - Prior to "Tuesday 16 September 2014 0:00:00" (from a calendar control)
     - Prior to today

    None of these returned any user records :(


    Tuesday, September 16, 2014 7:18 PM
  • Found the issue. (OMG so lame :$ )

    The "employee end date" is not the FIM attribute "expiration time (ExpirationTime)".
    The "employee end date" is the FIM attribute "employee end date (EmployeeEndDate)".

    I've done the change, with Belgian time format, my set is OK now.

    But this was not a waste
     => I've now got fully language compatible FIM Portal :)

    Wednesday, September 17, 2014 10:59 AM