Still updating and restarting automatically after disabling auto updates RRS feed

  • Question

  • I have disabled automatic windows download through policy editor:

    Computer Configuration > Administrative Templates > Windows Components > Windows Update > Configure Automatic Updates (Enabled, 2 - Notify for download and notify for install)

    And disabling automatic restart after windows update (policy editor as well):

    Computer Configuration > Administrative Templates > Windows Components > Windows Update > No auto-restart with logged on users for scheduled automatic updates installations (Enabled)

    But last night my pc still restarted by itself. Log from event viewer:

    The process C:\WINDOWS\system32\svchost.exe (SANA) has initiated the restart of computer SANA on behalf of user NT AUTHORITY\SYSTEM for the following reason: Operating System: Service pack (Planned)
     Reason Code: 0x80020010
     Shutdown Type: restart

    Is there a way to really prevent windows from restarting itself? It's really annoying having to reopen all documents and figuring out if I forgot to save anything.

    Tuesday, September 29, 2015 5:14 AM


  • Hi Edho Arief,

    We may shedule a restart to install updates.

    Choose how updates are installed


    Policy settings seems to be not working as expected, please run the gpupdate /force to check the result.

    Further, regarding Windows Update management under Windows 10, please check:

    How to Prevent Windows 10 From Automatically Downloading Updates

    Please note: Since this website is not hosted by Microsoft, the information may change without notice. Microsoft does not guarantee the accuracy of this ifnormation.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Michael_LS Monday, October 12, 2015 12:26 AM
    • Marked as answer by Deason Wu Tuesday, October 13, 2015 1:30 AM
    Wednesday, September 30, 2015 5:03 AM