locked
XP Mini-Setup: Can't Change Administrator Password RRS feed

  • Question

  • Hello,

    We have a Windows XP SP2 base WIM file that is used as a common base for all of our images. I have a task sequence that looks like the following:

    • Partition Disk 0
    • Apply Operating System
      • Installs XP from WIM file
    • Apply Windows Settings
      • Contains product key, username, Organization, and sets "Enable the account and specify the local administrator password" (however, the password field is blank)
    • Apply Device Drivers
      • Install only the best matched compatible drivers
      • Consider drivers from all categories
    • Setup Windows and ConfigMgr
    During Windows XP mini-setup, I'm getting a message that says "Setup was unable to change the password for user account Administrator. Please enter the desired password again."

    I found some information online, that pointed me to %WINDIR%\setuperr.log on the client. I pulled up the file in Notepad using the [Shift] + [F10] sequence during mini-setup, while the error was still visible, and I have the following message in the file:

    "Warning:
    Setup was unable to change the password for user account Administrator using the encrypted password apecified because of the following error:
    SetLocalUserEncryptedPassword(Administrator) returned error 86 (56)."

    And yes, just for the sake of clarification, the word "specified" is improperly spelled as "apecified."

    Can someone shed some light on what the problem is? We are using the same WIM image with MDT to build systems currently, and it does not have any issues. Something seems to be awry with the ConfigMgr deployment process though. I'm just guessing the problem lies somewhere in the "Apply Windows Settings" task sequence item?

    Are there any work-arounds to this issue?

    Thanks,

    Trevor Sullivan
    Systems Engineer
    OfficeMax Corporation


    Monday, September 29, 2008 12:49 PM

Answers

  • Well, XP unattended setup don't allow you to set a blank password, and yet the OS Deployment in SCCM requires it to be blank in order to set it in mini-setup...

     

    The solution is to set the password in unattend.txt to somehting (non-blank) and then add an action the sets the admin password to blank in the TS that creates your reference image... add i just before the sysprep action

     

    Command line: net user administrator ""

     

    Sunday, October 19, 2008 10:19 PM

All replies

  • Hello,

    I'd appreciate some input on this issue.

    Thanks,

    Trevor Sullivan
    Systems Engineer
    OfficeMax Corporation
    Wednesday, October 15, 2008 12:42 PM
  • Does the Administrator account on your captured image have a password?  I believe the password must be blank in order for sysprep to change it.

     

    Brian

    Wednesday, October 15, 2008 6:06 PM
  • Check sysprep.inf for the following:


    Code Snippet

    [GuiUnattended]
    AdminPassword=yourpassword

    EncryptedAdminPassword=NO

     

     

    Make sure AdminPassword is set to your real plaintext admin password and EncryptedAdminPassword is set to No.  Sysprep.inf should get deleted after the minisetup, so there really isn't any reason to try to encrypt it unless you are worried about technicans breaking out via Shift-F10 (like you did) to grab the password.

    Friday, October 17, 2008 7:29 PM
  • Well, XP unattended setup don't allow you to set a blank password, and yet the OS Deployment in SCCM requires it to be blank in order to set it in mini-setup...

     

    The solution is to set the password in unattend.txt to somehting (non-blank) and then add an action the sets the admin password to blank in the TS that creates your reference image... add i just before the sysprep action

     

    Command line: net user administrator ""

     

    Sunday, October 19, 2008 10:19 PM
  • If you go into Local Security Settings -> Local Policies -> Security Options and disable the "Accounts: Limit local account use of blank passwords to console logon only" you will be able to use blank passwords with Administrator.  You might also need to disable password complexity in Local Security Settings -> Account Policies -> Password Policy as well.

    • Proposed as answer by Computer Gump Wednesday, March 3, 2010 8:50 PM
    Wednesday, March 3, 2010 8:49 PM