locked
Web Standard Slicer Not Working RRS feed

  • Question

  • I'm having an issue getting the slice or combine command to work on the data layout of proclarity web standard.  When I select a new background dimension and click slice, the slice icon appears next to the selected dimension and the the apply button flashes.  When I hit the apply button, the web page refreshes to the exact view I had before selecting the new dimension.  (The slice icon has disappeared from the selected dimension.) 

     

    I'm wondering if this is a permission issue.  We've set up kerberos between the PAS server and SSAS server to get the ability to make standard work at all. 

     

    The only way I can get a slicer in standard is if the page is built with a slicer in professional.  Further, I can't make changes to the hierarchy (slicer choices) in standard.

     

    I'm using 6.3 with the latest hotfix. 

     

    Any help would be great!

     

    Bill Spencer

    Tuesday, July 8, 2008 2:09 PM

Answers

All replies

  • Hi Bill,

    This sounds like a classic example of IIS not being able to pass the volume of data that is being requested by the application.  Depending on how many members are in the dimension you're slicing, I would expect to see this due to the restrictions that are in place in IIS 6 by default.  Check out this post on our blog, try setting the "ASPMaxRequestEntityAllowed" to a higher value, reset IIS, then see if you can slice the dimension: http://blogs.technet.com/proclarity/archive/2008/05/20/proclarity-web-standard-behavior-my-views-don-t-show-up-after-being-saved.aspx

     

    Please let us know if it resolves your issue.

     

    Thanks,

     

    Bob

     

    Tuesday, July 8, 2008 3:53 PM
  • Bob,

     

    Thanks so much for the quick response.  I tried with 1gb as the article recommends and didn't have success.  I raised the aspmaxrequestentityallowed to 2gb and that solved the issue with standard!  However, it seems to have created an issue with professional (which was working fine.)  I am now unable to open the pages in professional.  If I try to launch professional from standard, I just get a white screen.  If I try to access the book / page directly through professional, it returns an unspecified error.  I then tried to lowering back to the default.  I still can't get professional to work again.  Very strange.

     

    Any more help would be fantastic!

     

    Thanks so much,

     

    Bill Spencer

    Wednesday, July 9, 2008 4:40 PM
  • That is interesting Bill.   If at all possible, I would be interested to see if you're able to recreate the view in the Professional client, republish and have it work in both clients.  I can't see how an IIS setting would cause this issue for Professional, particularly causing the view to not open or to hang the Professional client.  Are there any errors in the event log on the server or on the machine where the Pro is attempting to open?

     

    Thanks,

     

    Bob

     

    Wednesday, July 9, 2008 5:20 PM
  • Bob,

     

    I tried rebuilding but I get the same result.  I checked the app and proclarity logs on the server and didn't see any errors. 

     

    When I do launch professional, I get an information window that says, "unspecified error" with an ok button.  This is, fortunately, in my dev environment.  I don't want to try to deploy the iis fix to production if it has the possibility of knocking out professional in my production environment.  Any additional advice would be great. 

     

    Thanks so much!

     

    Bill Spencer

     

    Wednesday, July 9, 2008 11:02 PM
  • Hi Bill,

    Does this issue only occur with this one view?  Everything else is working fine?  Which version of the Pro and PAS are you running? 6.3.2215 is the latest hot fix level for both products and can be found here: http://www.microsoft.com/DOWNLOADS/results.aspx?pocId=&freetext=proclarity%206.3.2215&DisplayLang=en

     

    Let's make sure you're at the same release on client and server.  Is there any difference?

     

    Thanks,

     

    Bob

    Thursday, July 10, 2008 4:32 PM
  • Bob,

     

    Thanks so much.  That took care of it.  I wasn't aware that another hotfix had been issued.

     

    Bill Spencer

    Thursday, July 10, 2008 6:34 PM
  • That's great news Bill.  Thanks for letting me know!

     

    -Bob

     

    Thursday, July 10, 2008 6:36 PM