none
Restrict Internet Access but allow WindowsLive Messenger RRS feed

  • Question

  • Hi there,

     

    I'm using SteadyState on my kids' pc at home. I'd like to restrict Internet access as a whole, but allow WindowsLive Messenger. By default, WindowsLive Messenger is blocked as soon as I enable Internet access restrictions. I've allowed the following sites: *.microsoft.com;*.msn.com, but it does not help.

    Thanks in advance.

     

    Cheers  /jerome

    Wednesday, October 3, 2007 8:05 PM

Answers

  • Hi Jerome,

     

    When you set the “Prevent Internet access (except Web Sites below)” option, the system will set the proxy server in IE to a non-exist one (NoInternetAccess) and add web sites allowed to the “Exceptions”. The “Use the same proxy server for all protocols” option is checked. In this way, all web site access except for those allowed sites are blocked. As Windows Live Message uses IE proxy settings, it should be an expected issue that Internet cannot be accessed from Windows Live Massager either.

     

    I suggest using Content Advisor to block accessing websites:

    --------------------------------

    1. Open IE, click Tools -> Internet Options.

    2. Select the Contents tab. Click the Enable button to enable Content Advisor.

    3. Select the Approved Sites tab, input the website you would like to block(or allow). Click Never (or Always). If you would like to block all, no need to configure this tab.

    4. Select the General tab, make sure “Users can see websites that have no rating”  is unchecked.

    5. Click OK. Create a password for Content Advisor.

     

    From now on, password will be required if you want to access websites. For more information about Content Advisor, please refer:

     

    HOW TO: Use the Internet Explorer 6 Content Advisor to Control Access to Web Sites in Internet Explorer

    http://support.microsoft.com/kb/310401

     

    In addition, Content Advisor settings can also be deployed via group policy [User Configuration\Windows Settings\Internet Explorer Maintenance\Security\Security Zones and Content Ratings].

     

    Best Regards,

    Thursday, October 4, 2007 7:17 AM

All replies

  • Hi Jerome,

     

    When you set the “Prevent Internet access (except Web Sites below)” option, the system will set the proxy server in IE to a non-exist one (NoInternetAccess) and add web sites allowed to the “Exceptions”. The “Use the same proxy server for all protocols” option is checked. In this way, all web site access except for those allowed sites are blocked. As Windows Live Message uses IE proxy settings, it should be an expected issue that Internet cannot be accessed from Windows Live Massager either.

     

    I suggest using Content Advisor to block accessing websites:

    --------------------------------

    1. Open IE, click Tools -> Internet Options.

    2. Select the Contents tab. Click the Enable button to enable Content Advisor.

    3. Select the Approved Sites tab, input the website you would like to block(or allow). Click Never (or Always). If you would like to block all, no need to configure this tab.

    4. Select the General tab, make sure “Users can see websites that have no rating”  is unchecked.

    5. Click OK. Create a password for Content Advisor.

     

    From now on, password will be required if you want to access websites. For more information about Content Advisor, please refer:

     

    HOW TO: Use the Internet Explorer 6 Content Advisor to Control Access to Web Sites in Internet Explorer

    http://support.microsoft.com/kb/310401

     

    In addition, Content Advisor settings can also be deployed via group policy [User Configuration\Windows Settings\Internet Explorer Maintenance\Security\Security Zones and Content Ratings].

     

    Best Regards,

    Thursday, October 4, 2007 7:17 AM
  • I used SteadtState and disabled access to IE for all the other accounts on the system.
    After I have uninstalled SteasyState, user still cannot access IE, but Windows Live Messenger cannot connect.

    How do I reset the access to IE for all the other users? I assumed uninstalling SteadyState would have cleared all the settings. Is there a utility to restore all the settings to the state before I used steady state?

    Cheers

    Thursday, February 14, 2008 9:10 PM
  •  

    Hi,

     

    As most SteadyState restrictions are saved to registry, uninstall will not remove restrictions. I would suggest reinstalling SteadyState, uncheck all options, test the result before removing SteadyState. If you also have other options enabled, it will be time consuming to make registry changes one by one without SteadyState.

     

    Regards,

    Friday, February 15, 2008 5:15 AM