locked
ROBOCOPY cannot read or recreate C:\Windows and subdirs (Win7 x64 Ultimate) RRS feed

  • Question

  • Trying to make an identical backup copy of C: (not so easy when by default Robocopy does not copy security attributes or folder creation times correctly).

    1. Taking a snapshot with Vshadow and exposing it as C:\z

    2. Copying C:\z to F: with

    Robocopy C:\z F: /e /b /efsraw /copyall /dcopy:t /mir /secfix /timfix /r:1 /w:1 /v /x /np /xd $Recycle.Bin System Volume Information *Documents and Settings* *Application Data*

    (actually these options are stored in a job.rcj file, just listing them here for completeness' sake)

    -->> Robocopy giving Error 5 with certain folders in Program Files, Program Files (x86) and ProgramData and finally pretty much anything under C:\Windows is unreadable or unrecreatable.

    What gives? This is a plain vanilla Windows 7 x64 Ultimate, plain vanilla in the sense that it has just been reinstalled (not upgraded/repaired). Even running the copy as builtin Administrator account doesn't help. Have tried /ZB too.

    Now it perhaps could be circumvented by giving rights for Backup Operators into all of C: and subfolders but that does compromise security?

    So, how to do it? Or is Robocopy unable of creating an 100% identical copy? What i am looking for is creating a 100% identical copy on file level as an online backup so that in case of hard drive failure, backup drive can be substituted with minimal loss of data and time.

     

    Wednesday, July 13, 2011 12:31 PM

All replies

  • Did you try running RoboCopy as admin?. Try to launch command prompt as admin and try.


    C# Fan! ananda84(at)gmail(dot)com
    Wednesday, July 13, 2011 12:50 PM
  • "Even running the copy as builtin Administrator account doesn't help. Have tried /ZB too.", says the original post.

    Thursday, July 14, 2011 7:56 AM
  • Hi,

     

    About robocopy error 5, I suggest:

    1. Check if the destination disk is full.
    2. Try the /COPY:DT option. By default, Robocopy copies using the option /COPY:DAT. This copies the Data, Attributes and Timestamps. /COPY:DT ignores the Attributes.

    These links describe error 5 may helpful to you:

     

    http://www.luisrocha.net/2008/12/robocopy-error-error-5-0x00000005.html

    http://www.pcreview.co.uk/forums/robocopy-error-error-5-copying-ntfs-security-destination-directory-t2852628.html

     

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Hope that helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, July 15, 2011 5:49 AM
  • 1. Disk is totally empty, freshly partitioned and formatted

    2. It's not an 100% identical copy anymore if attributes are not copied, so the first link's advice is out. About second link's information, I am member of Administrators, and checked Local Security Policy that Administrators have right to "Back up files and directories".

    So this far this is unsolved.

    Please note that this is about making a 100% identical copy so dropping anything from DATSOU is out of the question, as well as changing file/dir creation times etc.

    (Yes i am aware that a 100% identical copy can be made easily by sector based copying programs, but this thread is all about doing the same on file level.)

     

    Friday, July 15, 2011 6:52 AM