locked
Installing packages on MRO fails RRS feed

  • Question

  • I've never had any issues installing packages on R, but I always have issues installing packages on MRO. For example, I attempted to install tidyverse. I received a lot of errors, some of which are listed below:

    ERROR: compilation failed for package ‘colorspace’

    ERROR: compilation failed for package ‘backports’

    ERROR: compilation failed for package ‘mnormt’

    Those are just a few of the errors that I get when attempting to install tidyverse. In the past, my solution has been to give up and continue using regular R, but I'd like to try to take advantage of MRO's multithreading.

    Again, using the simple install.packages("tidyverse") command works in R. What do I have to do differently in MRO?

    Sunday, July 15, 2018 7:19 PM

All replies

  • Were those errors the only ones you saw? What happens if you try to install with the following syntax:

    install.packages("tidyverse", dependencies=TRUE)

    Niels


    http://www.nielsberglund.com | @nielsberglund

    Monday, July 16, 2018 2:39 AM
  • Unfortunately, including dependencies=TRUE does not work. I've included my entire terminal output below:

    Warning in system(cmd) : error in running command
    ERROR: compilation failed for package ‘colorspace’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/colorspace’
    Warning in install.packages :
      installation of package ‘colorspace’ had non-zero exit status
    * installing *source* package ‘mnormt’ ...
    ** package ‘mnormt’ successfully unpacked and MD5 sums checked
    ** libs
    sh: 1: make: not found
    Warning in system(cmd) : error in running command
    ERROR: compilation failed for package ‘mnormt’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/mnormt’
    Warning in install.packages :
      installation of package ‘mnormt’ had non-zero exit status
    * installing *source* package ‘fansi’ ...
    ** package ‘fansi’ successfully unpacked and MD5 sums checked
    ** libs
    sh: 1: make: not found
    Warning in system(cmd) : error in running command
    ERROR: compilation failed for package ‘fansi’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/fansi’
    Warning in install.packages :
      installation of package ‘fansi’ had non-zero exit status
    * installing *source* package ‘utf8’ ...
    ** package ‘utf8’ successfully unpacked and MD5 sums checked
    ** libs
    sh: 1: make: not found
    Warning in system(cmd) : error in running command
    ERROR: compilation failed for package ‘utf8’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/utf8’
    Warning in install.packages :
      installation of package ‘utf8’ had non-zero exit status
    * installing *source* package ‘backports’ ...
    ** package ‘backports’ successfully unpacked and MD5 sums checked
    ** libs
    sh: 1: make: not found
    Warning in system(cmd) : error in running command
    ERROR: compilation failed for package ‘backports’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/backports’
    Warning in install.packages :
      installation of package ‘backports’ had non-zero exit status
    * installing *source* package ‘xfun’ ...
    ** package ‘xfun’ successfully unpacked and MD5 sums checked
    ** R
    ** inst
    ** byte-compile and prepare package for lazy loading
    ** help
    *** installing help indices
    ** building package indices
    ** installing vignettes
    ** testing if installed package can be loaded
    * DONE (xfun)
    * installing *source* package ‘glue’ ...
    ** package ‘glue’ successfully unpacked and MD5 sums checked
    ** libs
    sh: 1: make: not found
    Warning in system(cmd) : error in running command
    ERROR: compilation failed for package ‘glue’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/glue’
    Warning in install.packages :
      installation of package ‘glue’ had non-zero exit status
    * installing *source* package ‘Rcpp’ ...
    ** package ‘Rcpp’ successfully unpacked and MD5 sums checked
    ** libs
    sh: 1: make: not found
    Warning in system(cmd) : error in running command
    ERROR: compilation failed for package ‘Rcpp’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/Rcpp’
    Warning in install.packages :
      installation of package ‘Rcpp’ had non-zero exit status
    * installing *source* package ‘digest’ ...
    ** package ‘digest’ successfully unpacked and MD5 sums checked
    ** libs
    sh: 1: make: not found
    Warning in system(cmd) : error in running command
    ERROR: compilation failed for package ‘digest’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/digest’
    Warning in install.packages :
      installation of package ‘digest’ had non-zero exit status
    * installing *source* package ‘lazyeval’ ...
    ** package ‘lazyeval’ successfully unpacked and MD5 sums checked
    ** libs
    sh: 1: make: not found
    Warning in system(cmd) : error in running command
    ERROR: compilation failed for package ‘lazyeval’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/lazyeval’
    Warning in install.packages :
      installation of package ‘lazyeval’ had non-zero exit status
    * installing *source* package ‘mime’ ...
    ** package ‘mime’ successfully unpacked and MD5 sums checked
    ** libs
    sh: 1: make: not found
    Warning in system(cmd) : error in running command
    ERROR: compilation failed for package ‘mime’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/mime’
    Warning in install.packages :
      installation of package ‘mime’ had non-zero exit status
    * installing *source* package ‘openssl’ ...
    ** package ‘openssl’ successfully unpacked and MD5 sums checked
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    Using PKG_CFLAGS=
      ------------------------- ANTICONF ERROR ---------------------------
      Configuration failed because openssl was not found. Try installing:
      * deb: libssl-dev (Debian, Ubuntu, etc)
    * rpm: openssl-devel (Fedora, CentOS, RHEL)
    * csw: libssl_dev (Solaris)
    * brew: openssl@1.1 (Mac OSX)
    If openssl is already installed, check that 'pkg-config' is in your
    PATH and PKG_CONFIG_PATH contains a openssl.pc file. If pkg-config
    is unavailable you can set INCLUDE_DIR and LIB_DIR manually via:
      R CMD INSTALL --configure-vars='INCLUDE_DIR=... LIB_DIR=...'
    --------------------------------------------------------------------
      ERROR: configuration failed for package ‘openssl’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/openssl’
    Warning in install.packages :
      installation of package ‘openssl’ had non-zero exit status
    * installing *source* package ‘clipr’ ...
    ** package ‘clipr’ successfully unpacked and MD5 sums checked
    ** R
    ** inst
    ** byte-compile and prepare package for lazy loading
    ** help
    *** installing help indices
    ** building package indices
    ** testing if installed package can be loaded
    * DONE (clipr)
    * installing *source* package ‘stringi’ ...
    ** package ‘stringi’ successfully unpacked and MD5 sums checked
    checking for R_HOME... /opt/microsoft/ropen/3.5.0/lib64/R
    checking for R... /opt/microsoft/ropen/3.5.0/lib64/R/bin/R
    checking for endianness... little
    checking for R >= 3.1.0 for C++11 use... yes
    checking for R < 3.4.0 for CXX1X flag use... no
    checking for cat... /bin/cat
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    /opt/microsoft/ropen/3.5.0/lib64/R/bin/config: 1: eval: make: not found
    checking for local ICUDT_DIR... icu61/data
    checking for gcc... no
    checking for cc... no
    checking for cl.exe... no
    configure: error: in `/tmp/RtmpO4zIl6/R.INSTALL1f4a655950bf/stringi':
    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details
    ERROR: configuration failed for package ‘stringi’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/stringi’
    Warning in install.packages :
      installation of package ‘stringi’ had non-zero exit status
    * installing *source* package ‘yaml’ ...
    ** package ‘yaml’ successfully unpacked and MD5 sums checked
    ** libs
    sh: 1: make: not found
    Warning in system(cmd) : error in running command
    ERROR: compilation failed for package ‘yaml’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/yaml’
    Warning in install.packages :
      installation of package ‘yaml’ had non-zero exit status
    * installing *source* package ‘base64enc’ ...
    ** package ‘base64enc’ successfully unpacked and MD5 sums checked
    ** libs
    sh: 1: make: not found
    Warning in system(cmd) : error in running command
    ERROR: compilation failed for package ‘base64enc’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/base64enc’
    Warning in install.packages :
      installation of package ‘base64enc’ had non-zero exit status
    * installing *source* package ‘rlang’ ...
    ** package ‘rlang’ successfully unpacked and MD5 sums checked
    ** libs
    sh: 1: make: not found
    Warning in system(cmd) : error in running command
    ERROR: compilation failed for package ‘rlang’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/rlang’
    Warning in install.packages :
      installation of package ‘rlang’ had non-zero exit status
    ERROR: dependencies ‘digest’, ‘rlang’ are not available for package ‘testthat’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/testthat’
    Warning in install.packages :
      installation of package ‘testthat’ had non-zero exit status
    ERROR: dependency ‘colorspace’ is not available for package ‘munsell’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/munsell’
    Warning in install.packages :
      installation of package ‘munsell’ had non-zero exit status
    ERROR: dependency ‘Rcpp’ is not available for package ‘plyr’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/plyr’
    Warning in install.packages :
      installation of package ‘plyr’ had non-zero exit status
    ERROR: dependency ‘mnormt’ is not available for package ‘psych’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/psych’
    Warning in install.packages :
      installation of package ‘psych’ had non-zero exit status
    ERROR: dependency ‘Rcpp’ is not available for package ‘bindrcpp’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/bindrcpp’
    Warning in install.packages :
      installation of package ‘bindrcpp’ had non-zero exit status
    ERROR: dependencies ‘fansi’, ‘rlang’, ‘utf8’ are not available for package ‘pillar’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/pillar’
    Warning in install.packages :
      installation of package ‘pillar’ had non-zero exit status
    ERROR: dependency ‘mime’ is not available for package ‘markdown’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/markdown’
    Warning in install.packages :
      installation of package ‘markdown’ had non-zero exit status
    ERROR: dependencies ‘digest’, ‘Rcpp’ are not available for package ‘htmltools’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/htmltools’
    Warning in install.packages :
      installation of package ‘htmltools’ had non-zero exit status
    ERROR: dependency ‘backports’ is not available for package ‘rprojroot’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/rprojroot’
    Warning in install.packages :
      installation of package ‘rprojroot’ had non-zero exit status
    * installing *source* package ‘tinytex’ ...
    ** package ‘tinytex’ successfully unpacked and MD5 sums checked
    ** R
    ** byte-compile and prepare package for lazy loading
    ** help
    *** installing help indices
    ** building package indices
    ** testing if installed package can be loaded
    * DONE (tinytex)
    ERROR: dependency ‘rlang’ is not available for package ‘hms’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/hms’
    Warning in install.packages :
      installation of package ‘hms’ had non-zero exit status
    ERROR: dependencies ‘mime’, ‘openssl’ are not available for package ‘httr’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/httr’
    Warning in install.packages :
      installation of package ‘httr’ had non-zero exit status
    ERROR: dependencies ‘glue’, ‘stringi’ are not available for package ‘stringr’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/stringr’
    Warning in install.packages :
      installation of package ‘stringr’ had non-zero exit status
    ERROR: dependency ‘Rcpp’ is not available for package ‘xml2’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/xml2’
    Warning in install.packages :
      installation of package ‘xml2’ had non-zero exit status
    ERROR: dependency ‘testthat’ is not available for package ‘processx’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/processx’
    Warning in install.packages :
      installation of package ‘processx’ had non-zero exit status
    ERROR: dependencies ‘plyr’, ‘Rcpp’, ‘stringr’ are not available for package ‘reshape2’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/reshape2’
    Warning in install.packages :
      installation of package ‘reshape2’ had non-zero exit status
    ERROR: dependencies ‘plyr’, ‘munsell’, ‘Rcpp’ are not available for package ‘scales’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/scales’
    Warning in install.packages :
      installation of package ‘scales’ had non-zero exit status
    ERROR: dependency ‘stringr’ is not available for package ‘selectr’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/selectr’
    Warning in install.packages :
      installation of package ‘selectr’ had non-zero exit status
    ERROR: dependency ‘stringr’ is not available for package ‘evaluate’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/evaluate’
    Warning in install.packages :
      installation of package ‘evaluate’ had non-zero exit status
    ERROR: dependencies ‘stringr’, ‘Rcpp’ are not available for package ‘lubridate’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/lubridate’
    Warning in install.packages :
      installation of package ‘lubridate’ had non-zero exit status
    ERROR: dependencies ‘pillar’, ‘rlang’ are not available for package ‘tibble’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/tibble’
    Warning in install.packages :
      installation of package ‘tibble’ had non-zero exit status
    ERROR: dependency ‘tibble’ is not available for package ‘cellranger’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/cellranger’
    Warning in install.packages :
      installation of package ‘cellranger’ had non-zero exit status
    ERROR: dependency ‘processx’ is not available for package ‘callr’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/callr’
    Warning in install.packages :
      installation of package ‘callr’ had non-zero exit status
    ERROR: dependencies ‘rlang’, ‘tibble’ are not available for package ‘forcats’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/forcats’
    Warning in install.packages :
      installation of package ‘forcats’ had non-zero exit status
    ERROR: dependencies ‘digest’, ‘lazyeval’, ‘plyr’, ‘reshape2’, ‘rlang’, ‘scales’, ‘tibble’ are not available for package ‘ggplot2’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/ggplot2’
    Warning in install.packages :
      installation of package ‘ggplot2’ had non-zero exit status
    ERROR: dependencies ‘rlang’, ‘tibble’ are not available for package ‘purrr’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/purrr’
    Warning in install.packages :
      installation of package ‘purrr’ had non-zero exit status
    ERROR: dependencies ‘Rcpp’, ‘tibble’, ‘hms’ are not available for package ‘readr’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/readr’
    Warning in install.packages :
      installation of package ‘readr’ had non-zero exit status
    ERROR: dependencies ‘xml2’, ‘httr’, ‘selectr’ are not available for package ‘rvest’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/rvest’
    Warning in install.packages :
      installation of package ‘rvest’ had non-zero exit status
    ERROR: dependencies ‘Rcpp’, ‘tibble’, ‘hms’ are not available for package ‘feather’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/feather’
    Warning in install.packages :
      installation of package ‘feather’ had non-zero exit status
    ERROR: dependencies ‘evaluate’, ‘markdown’, ‘stringr’, ‘yaml’ are not available for package ‘knitr’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/knitr’
    Warning in install.packages :
      installation of package ‘knitr’ had non-zero exit status
    ERROR: dependencies ‘glue’, ‘purrr’, ‘rlang’, ‘Rcpp’ are not available for package ‘tidyselect’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/tidyselect’
    Warning in install.packages :
      installation of package ‘tidyselect’ had non-zero exit status
    ERROR: dependencies ‘forcats’, ‘hms’, ‘Rcpp’, ‘readr’, ‘tibble’ are not available for package ‘haven’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/haven’
    Warning in install.packages :
      installation of package ‘haven’ had non-zero exit status
    ERROR: dependencies ‘cellranger’, ‘Rcpp’, ‘tibble’ are not available for package ‘readxl’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/readxl’
    Warning in install.packages :
      installation of package ‘readxl’ had non-zero exit status
    ERROR: dependencies ‘knitr’, ‘yaml’, ‘htmltools’, ‘evaluate’, ‘base64enc’, ‘rprojroot’, ‘mime’, ‘stringr’ are not available for package ‘rmarkdown’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/rmarkdown’
    Warning in install.packages :
      installation of package ‘rmarkdown’ had non-zero exit status
    ERROR: dependencies ‘bindrcpp’, ‘glue’, ‘Rcpp’, ‘rlang’, ‘tibble’, ‘tidyselect’ are not available for package ‘dplyr’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/dplyr’
    Warning in install.packages :
      installation of package ‘dplyr’ had non-zero exit status
    ERROR: dependencies ‘callr’, ‘rlang’, ‘rmarkdown’ are not available for package ‘reprex’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/reprex’
    Warning in install.packages :
      installation of package ‘reprex’ had non-zero exit status
    ERROR: dependencies ‘dplyr’, ‘glue’, ‘purrr’, ‘rlang’, ‘tibble’, ‘tidyselect’ are not available for package ‘dbplyr’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/dbplyr’
    Warning in install.packages :
      installation of package ‘dbplyr’ had non-zero exit status
    ERROR: dependencies ‘dplyr’, ‘glue’, ‘purrr’, ‘Rcpp’, ‘rlang’, ‘stringi’, ‘tibble’, ‘tidyselect’ are not available for package ‘tidyr’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/tidyr’
    Warning in install.packages :
      installation of package ‘tidyr’ had non-zero exit status
    ERROR: dependencies ‘dplyr’, ‘plyr’, ‘psych’, ‘reshape2’, ‘stringr’, ‘tidyr’ are not available for package ‘broom’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/broom’
    Warning in install.packages :
      installation of package ‘broom’ had non-zero exit status
    ERROR: dependencies ‘broom’, ‘dplyr’, ‘purrr’, ‘tibble’, ‘tidyr’, ‘rlang’ are not available for package ‘modelr’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/modelr’
    Warning in install.packages :
      installation of package ‘modelr’ had non-zero exit status
    ERROR: dependencies ‘broom’, ‘dplyr’, ‘dbplyr’, ‘forcats’, ‘ggplot2’, ‘haven’, ‘hms’, ‘httr’, ‘lubridate’, ‘modelr’, ‘purrr’, ‘readr’, ‘readxl’, ‘reprex’, ‘rlang’, ‘rvest’, ‘stringr’, ‘tibble’, ‘tidyr’, ‘xml2’ are not available for package ‘tidyverse’
    * removing ‘/home/myFilePath/R/x86_64-pc-linux-gnu-library/3.5/tidyverse’
    Warning in install.packages :
      installation of package ‘tidyverse’ had non-zero exit status

    The downloaded source packages are in
    ‘/tmp/RtmpDGk37A/downloaded_packages’

    Monday, July 16, 2018 12:59 PM
  • Hi!

    From the error messages, it looks like it tries to compile packages and cannot find the make tool. Try and install Rtools on the box where you have the R engine and then try again.

    Niels



    http://www.nielsberglund.com | @nielsberglund

    Monday, July 16, 2018 1:28 PM