locked
USB Disk LED not turned off if Using Vista or Later RRS feed

  • General discussion

  • Sorry for my english.

    I found a differences between "safety remove hardware" in vista (or later) and xp. If i'm using xp and plug something like usb disk / external card reader, the LED indicator is on and it's working correctly until I use "safety remove hardware" to unplug my usb disk and the information showed that "USB Mass Storage Device can now be safely removed from the system" and the LED in my USB Disk is turned off.....

    But not like in vista (or later), after i'm using "safety remove hardware" to unplug my USB Disk and the information showed that ".....USB device can now safely removed....." the LED Indicator didn't turned off though it's said that it is safely to remove the USB disk from the port.

    If the LED turned on it's indicate that electricity is still to go in to the USB disk...and if LED turned off it's indicate that electricity isn't still to go in to the USB disk...

    My question is : is it really "SAFETY" to remove something from the USB Port though the electricity is still to go in...?? (and I've disabled writing cache in the USB disk for quick removal <doesn't need Safety Remove Hardware>)
    Tuesday, June 2, 2009 1:27 AM

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet Forum.

     

    Based on my research, this feature is by design in Windows Vista. The port to which the device is attached is not suspend in Windows Vista when a device is soft removed.

     

    For more information, please visit the following Microsoft article.

     

    "Safely Remove Hardware" does not remove power to a USB device in Windows Vista

    http://support.microsoft.com/kb/971899

     

    Hope this helps. Thanks.

    Wednesday, June 3, 2009 2:55 AM
    Moderator