locked
Additional Mailbox in Outlook RRS feed

  • Question

  • I have this weird issue where I have an additional mailbox in my Outlook 2013 client.  I originally gave myself full access to the users mailbox and then it should up in Outlook automatically as it's supposed to but I've now removed myself from full access but the mailbox doesn't disappear and I can actually open it and browse it's contents.

    I do not have Full Access, Send-As, Send on Behalf, or Delegated permissions and it's not been added manually in the additional mailboxes on my account so I have no idea why it's still connected to my Outlook profile and why I can browse its contents.

    I would love some additional settings to look at or anything else that would explain why this mailbox is still here.

    Thanks!

    Thursday, July 31, 2014 10:23 PM

Answers

  • Hi,

    If your shared mailbox is not added manually by using Advanced tab in Account settings > More settings, instead, it is automatically added in your Outlook profile, it should be related to automapping feature in Exchange server. Generally, if the full access permission is removed, the shared mailbox should be automatically removed from Outlook client.

    Since the shared mailbox can’t be accessed in OWA, it indicates the full access permission has been removed. Please do the following steps to check the automapping feature:

    1. Open Active Directory Users and Computers.

    2. In Users, right-click the shared mailbox > Properties.

    3. In Attribute Editor tab, pick up msExchDelegateListLink attribute.

    4. Make sure the value is empty and shows <not set>. If your account is listed there, please remove it.

    Then check whether the shared mailbox is listed in your Outlook client or not.

    Regards,


    Winnie Liang
    TechNet Community Support

    • Proposed as answer by Darren Blanchard Monday, August 4, 2014 11:44 AM
    • Marked as answer by grumpkin13 Monday, August 4, 2014 11:48 PM
    Monday, August 4, 2014 7:40 AM
    Moderator

All replies

  • Check from OWA and see whether you can open the mailbox.

    If you can from OWA, I would advise you to restart the Exchange store service. Exchange should update it without a restart.

    If you can't do it in OWA and can in Outlook, it looks like a local cache. Thrash the profile and create a new one & test.


    TheUCGuy.Net

    Friday, August 1, 2014 2:18 PM
  • Ok, I think we may be getting somewhere.  I tried in OWA and was not able to access the mailbox so I took your advice and deleted my Outlook profile.  That didn't remove the mailbox from Outlook but I can no longer access it through Outlook, I get the typical "Cannot display the folder"

    Any other suggestions of how to get rid of this mailbox?  It's really annoying seeing it there

    Friday, August 1, 2014 3:01 PM
  • Hi,

    If your shared mailbox is not added manually by using Advanced tab in Account settings > More settings, instead, it is automatically added in your Outlook profile, it should be related to automapping feature in Exchange server. Generally, if the full access permission is removed, the shared mailbox should be automatically removed from Outlook client.

    Since the shared mailbox can’t be accessed in OWA, it indicates the full access permission has been removed. Please do the following steps to check the automapping feature:

    1. Open Active Directory Users and Computers.

    2. In Users, right-click the shared mailbox > Properties.

    3. In Attribute Editor tab, pick up msExchDelegateListLink attribute.

    4. Make sure the value is empty and shows <not set>. If your account is listed there, please remove it.

    Then check whether the shared mailbox is listed in your Outlook client or not.

    Regards,


    Winnie Liang
    TechNet Community Support

    • Proposed as answer by Darren Blanchard Monday, August 4, 2014 11:44 AM
    • Marked as answer by grumpkin13 Monday, August 4, 2014 11:48 PM
    Monday, August 4, 2014 7:40 AM
    Moderator
  • That was it.  I guess my account wasn't properly removed from that attribute when I removed full access.

    Thanks!

    Monday, August 4, 2014 11:49 PM