none
MDT 2013 Fails to Format or Partition disk on Surface Pro 3 RRS feed

  • Question

  • I have been trying to image a Surface Pro 3 using MDT 2013 and have been unable to get past the Format and Partition portion of the deployment.  At first I would get an error that it was unable to format or partition the drive and then after that it just reboots after trying for so long.  I am able to image any other device with the same task sequence and have no issue just having an issue with the Surface Pro 3.  Any help would be great.

    Thanks in advance.

    I am getting the error FAILURE (5210)

    ZTI Error - Unhandled error returned by ZTIDISKPART: Object required (424)

    • Edited by cklein425 Wednesday, January 7, 2015 6:52 PM
    Wednesday, January 7, 2015 4:38 PM

Answers

  • That's a problem. WinPE must be able to *see* the drive, if WinPE can't see the drive, then the MDT scripts won't work either. Could be a driver issue.

    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Saturday, January 31, 2015 5:58 AM
    Moderator

All replies

  • Did you modify the partition configuration any, or are you using the default single partition configuration? If you modified, try going back to the origional configuraiton.
    If you are still having problems, please copy your bdd.log file to a public site like OneDrive and share the link here.

    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Wednesday, January 7, 2015 9:40 PM
    Moderator
  • I'm having the same issue. Prior to starting the task sequence diskpart list disk shows 1 256GB drive present from within WinPE.  After starting the TS and failing at ztidiskpart, diskpart list disk shows no drives present.  It is as if the drive disappears from WinPE and ztidiskpart fails with object required.  This was working previously.
    Friday, January 30, 2015 10:52 PM
  • That's a problem. WinPE must be able to *see* the drive, if WinPE can't see the drive, then the MDT scripts won't work either. Could be a driver issue.

    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Saturday, January 31, 2015 5:58 AM
    Moderator
  • Tend to agree with Keith.

    Have you downloaded and injected the Surface Pro 3 Driver Pack?

    http://www.microsoft.com/en-us/download/details.aspx?id=38826

    Saturday, January 31, 2015 2:22 PM
  • I finally figured out what my issue was.  I rebuilt my entire Deployment Share, Imported all the Surface Pro 3 drivers and continued to have the same issue.  I found that the Hard Drive had failed.  We have had 3 SP3 units have failing HD's.  It appears the Samsung drives are the ones failing.

    Monday, February 2, 2015 2:32 PM
  • Yes, using the January 2015 driver pack.  I'm starting to think it is bad ssd drives except it happens on 50% of our Surface Pro 3's.  From within WinPE I can run diskpart and create a primary partition on the drive but when trying to format the partition it never gets past 0% and then eventually fails.  After that doing diskpart list disk shows "There are no fixed disks to show" even though it listed a disk prior to running the format command.
    Tuesday, February 3, 2015 6:58 PM
  • Specifically, what WinPE version are you using? Make sure you are using the latest Windows 8.1 ADK version from MSFT. (as a start)

    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Thursday, February 5, 2015 6:45 PM
    Moderator
  • Hi there,

    I am having the same issue that you described. the only difference being mine just stays at formatting disk and never fails. I have to manually kill the process(after waiting for 90 minutes on formatting disk).

    Just wondering if you ever got to the bottom of it. Or was it hardware related issue?

    Cheers

    Tarun

    Tuesday, March 3, 2015 8:12 AM
  • Tarun,

    Another thing we have done is setup a Selection Profile just for the Surface Pro 3.  Then when updating the MDT Deployment share make sure you choose that Selection Profile under the Windows PE tab in the properties of the Deployment share.  Also choose "Include all Drivers from the selection profile"  This will create a new Litetouch file for just the Surface.  We added that to our WDS server and PXE boot the Surface with that Litetouch and that helped resolve some of the issues as well.

    Hope that helps.

    Chris

    Wednesday, March 4, 2015 4:26 PM
  • I have been having the exact same issue with 50% of my surfaces, MDT Deployment would fail on Format Partition Task Sequence.

    Running Disk Util manually and formatting the disk would also net a failure, and the disk would no longer be visible.

    What I found that fixed the issue was to Delete all secure keys from firmware, to do this follow these steps

    1. boot into the firmware (see below link on how to boot to firmware)
    2. once booted to firmware, select Delete all secure keys, see below.
    3. Hold down Power to hard power off,
    4. Resume imaging process as needed.

    http://winsupersite.com/mobile-devices/surface-pro-3-tip-access-firmware


    • Proposed as answer by CarterCronk Wednesday, April 22, 2015 1:00 AM
    • Edited by CarterCronk Wednesday, April 22, 2015 1:16 AM
    Wednesday, April 22, 2015 12:59 AM
  • We've just started having the same issue.

    Have previously imaged 40+ Surfaces Pro 3's and now all of a sudden it's failing for two we just purchased.

    Is anyone else having problems all of a sudden? perhaps these are running new firmware or hardware so the correct driver isn't being injected? I can see the disk in WinPE before i start the task sequence but afterwards the drives aren't visible anymore.

    Wednesday, April 29, 2015 3:57 AM
  • Make sure you are using the *latest* version of the ADK.

    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Wednesday, April 29, 2015 5:51 AM
    Moderator
  • We have version 1.0 of the ADK for Windows 8.1 I can't find any newer versions than this? We have been successfully deploying windows 8.1 to Surface Pro 3's for over 6 months until today.

    I'm trying a full server rebuild but that's time consuming. 

    Sorry haven't given you much to work with, just checked the BDD.log and its failing right after the partitioning finishes. Then when i went so save the bdd.log to a thumb drive I saw in explorer a V: Drive with no size but called Local Disk and a Boot (X:) drive which was 500mb.

    You can view the bdd.log here https://ricohaus.sharefile.com/d-s19ede1af11648139



    • Edited by andosss Wednesday, April 29, 2015 7:14 AM
    Wednesday, April 29, 2015 6:25 AM
  • So where are we with this issue?  Is it indeed hardware failures or an issue with MDT 2013?

    -BrianG (http://supportishere.com)

    Wednesday, April 29, 2015 3:56 PM
  • For us it was hardware failure.  Microsoft told us that there was a bad batch that went out and they replaced the units we had that where bad.

    Hope that helps,

    Wednesday, April 29, 2015 4:17 PM
  • I think our problem is also hardware failure although without re-imaging a working surface pro 3 I can't be sure.

    I tried what imfusio suggested in this thread.

    https://social.technet.microsoft.com/Forums/en-US/d31384bc-4e96-4a5b-a400-637bd6006d81/failure-5456-unable-to-determine-destination-disk-partition-and-or-drive-surface-pro-3?forum=mdt

    Unfortunately the deployment failed with the same ZTI Error - Unhandled error returned by ZTIDISKPART: Object required (424)

    I then rebooted into WinPE and ran diskpart, I could see the two volumes (EFI and OSDisk). I then tried to format the OS disk volume using diskpart. I got a paramater is incorrect error and the disk was no longer visible with a 'list disk' command. So it's like the format is putting the disk offline. I'm going to try restore one of these surfaces, apply all firmware updates then re-image. If that doesn't work I'm out of ideas.

    Thursday, April 30, 2015 2:22 AM
  • Just a final post on this so others know where I gave up.

    - Completely rebuilt MDT still didn't work.

    - Tried to re-image a 128gb Surface Pro 3 and it worked perfectly.

    - In diskpart (after a failed image rebooted into fresh WinPE) I can see MDT created the four partitions but the volume configuration is incorrect. Vol 0 (C: Drive) is RAW and there is nothing under Info (should be boot), Vol 1 and 2 (recovery and system) are ntfs and fat32 respectively but both are Hidden instead of System.

    Found this recent post and the described problem is identical, soon as MDT starts partitioning the disk it goes offline in MDT. So MDT then can't setup the volumes and begin the OS install. I believe this can't be driver related as MDT sees the disk in WinPE to create the partitions and volumes but then loses access.

    4/4 from this batch have same behaviour which makes it hard to believe it's hardware fault but think it's time to send them back to MS in any case.

    ***EDIT - We just get a fresh batch of devices in, first one i picked out of the box is imaging along happily (its a 256gb model same as the faulty ones).
    • Edited by andosss Monday, May 4, 2015 7:26 AM
    Monday, May 4, 2015 7:04 AM
  • We have seen the same issues on some of the Surface Pro 3.
    However, some of them works if we deploy using SCCM which is test phase. But a few of these didn't work in SCCM or in MDT

    Monday, November 23, 2015 1:03 PM
  • "Could be a driver issue" doesn't really count as an answer and, while certainly something that WOULD cause the described failure, I don't think that this reply should be marked as an answer.

    Monday, August 8, 2016 4:22 PM
  • I've just received a replacement Surface Pro 3 from Microsoft for one that was screen damaged and the replacement has this issue as described.    Specifically, we use SCCM with MDT 2013, and during the Format and Partition Disk step, the partitioning happens and the format starts, then fails and at that point the disk is not seen.  ("DISKPART LIST DISK" only shows the boot media.)  After rebooting to media and running DISKPART again, the disk is visible and apparently properly formatted.

    We were able to figure out what was going on by booting to media and then using the command prompt to experiment.  We used DISKPART to create and format partitions of various sizes and determined that we can create and format partitions up to about 190GB.  Any larger than that and the format fails and the disk disappears until reboot.  After reboot, the disk is present and by all appearances properly formatted.

    Oddly enough, we ARE able to restore the Surface Pro 3 with the full disk partitioned and formatted, using the Surface Recovery Image (which we downloaded here).

    I'd be sure this was a bad disk if it weren't for the fact that the Surface Recovery Image can succeed.  Maybe it uses a different disk partition/format mechanism than DISKPART does and there's a firmware compatibility issue?  

    Either way, the Surface Pro 3 we were replacing didn't have this issue (same task sequence and same partition layout) so we referred it to Microsoft with the expectation they're going to replace the unit for  a bad SSD.  As near as we can tell, there's no issue with the SSD other than the failure for formatting partitions > 190GB, so if you've got this issue and don't wanna hassle with it, you can try and just break up your partitions and see if that helps? Mind you, if it IS an SSD issue, there's no reason to think that the size limit on partitions would be the same 190GB, but I'd be very interested for anyone else with this issue who to relate their experiences and observations.


    • Proposed as answer by CPT-squirrel Tuesday, November 15, 2016 6:28 PM
    Monday, August 8, 2016 9:30 PM
  • Oh - addendum:

    Once Windows is installed there doesn't appear to be any problem with extending the volume to take up all the unpartitioned space.  No idea if it will start firing errors when we put that much data on it though.  Is there such a thing as a sector check for SSDs?

    Tuesday, August 9, 2016 12:09 AM
  • My experience with this issue is as follows. If I boot the new tablet and allow the OOBE to finish and then start my image through MDT2013, it deploys correctly. If I allow the firmware update to install, after the OOBE finishes and it installs the new firmware, it will not deploy through MDT2013. It fails after creating Partition 3 and I receive an error 7706, that states it cannot find the disk partition it is looking for.

    I also have successfully reloaded the factory restore image and it works fine.  It has to be an issue with the firmware upgrade, but I am not sure what the issue is. 

    Tuesday, August 9, 2016 1:53 PM
  • Same issue here using WDS deploying windows 8.1 on a Dell latitude E7450 with a 256gb SSD.

    Deployment is failing with error 7706 Drive C not found.

    Only workaround is to set up the primary Windows partition to less than 200 Gb. (tested with 100 and 190 GB)

    If using percentage or more than 200 gb. Deployment failed with error drive not found. And drive disappear from DISKPART.

    • Proposed as answer by CPT-squirrel Tuesday, November 15, 2016 6:27 PM
    Wednesday, October 5, 2016 12:46 AM