none
Windows 10 Enterprise build 9926 no success using GPOPack wsf RRS feed

  • Question

  • Trying to create a golden image for others to use to test. Have tried to modify the SCM 3.0 GPOPack.wsf and the latter released Win81-WS2012R2-IE11-Baselines-FINAL.zip to no avail.  Anyone have any luck modifying it if so what is the script change line(s) needed?

    Thanks!


    Tuesday, March 31, 2015 11:04 AM

All replies

  • I'm having the same issue. Haven't seen any discussions on this topic (maybe I'm not looking in the right place).

    I've tried pretty much the same technique you've used with similar results (none). I've have also tried it on several of the build versions to no avail.

    Has anyone used the GPOPack.wsf to modify the local GOP on Win 10 or has that been deprecated? If so, how is the local gpo applied to a non-domain system?

    Thanks in advance for any information, ideas or solutions.

    Tuesday, July 7, 2015 5:23 PM
  • I was able to get this working based off what I saw in another posting (sorry I can't find that post now, but my thanks to that  poster).

    Here's the line I added.

     ElseIf(Left(strOpVer,4) = "10.0") and (strProductType = "1") then strOS = "Win10.0"

    Notice that the strOPVer is the Key. Previously I was using a 3 where the 4 is. Changing the 3 to a 4 allowed the process to work correctly.

    Friday, July 24, 2015 2:44 PM
  • Is that in ZTIApplyGPOPack.wsf or GPOPack.wsf ?
    Thursday, March 10, 2016 7:15 PM
  • No need to hack LocalGPO.wsf. Support for Windows 10 local GPO is now provided in LGPO.exe, included at the TechNet link below. Download the zip file. There is a PDF inside with instructions.

    See: http://blogs.technet.com/b/secguide/archive/2016/01/22/security-baseline-for-windows-10-v1511-quot-threshold-2-quot-final.aspx

    Unpack the zip file and look in the Local_Script\Tools folder.

    Cheers!

    Friday, April 1, 2016 8:51 PM
  • Sorry but when using SCM to export your own GPOPacks the GPOPack.wsf does not work since windows 10 is not recognized with the script.

    SCM needs to be updated so the GPOPacks.wsf that it generates will work windows windows 10. Right now its useless

    Monday, June 20, 2016 5:15 PM
  • I was able to tweak the GPOPack.wsf script to make it work for Windows 10.

    As an easy way to know what line to look for, I just did a search of the string: strOS = "Win7"

    1. In Sub ChkOSVersion

    Add another line like this:

            ElseIf(Left(strOpVer,2) = "10") and (strProductType = "1") then 
      strOS = "Win10"

    2. In  Sub ConfigureMLGPO

    I replaced strOS = "WS08" with "Win10"

            If (strOS = "Win7") or (strOS = "Vista") or (strOS = "WS08R2") or (strOS = "Win10") Then

    Check for any other references to an OS version

    Monday, September 26, 2016 8:03 PM
  • Nice thanks for this
    Monday, September 26, 2016 8:10 PM