none
Backing up a guest VM at Host level causes 'replica is inconsistent' RRS feed

  • Question

  • I have a Hyper V cluster with guest VMs. 

    All systems are joined to the same domain.  All systems are Windows server 2012 r2.

    With an agent installed on the guest VM, I can successfully backup the VM including BMR and system state.

    However, when I try to backup at the host level, which is a requirement for us, it fails.  I have hit a wall in the troubleshooting.  Can I get ideas of where to look next?

    The hyper v vss writer looks good.  Integration services are good.  Agents are good, with windows server backup feature installed.

    Thursday, November 17, 2016 4:36 PM

Answers

  • Found the issue.

    file server vss agent was not installed on the scale out file servers where Hyper V keeps its VM storage.

    • Marked as answer by Aserak Saturday, November 19, 2016 11:25 PM
    Saturday, November 19, 2016 11:25 PM

All replies

  • Did you set up proper disk allocation for the protection group? DPM does not always successfully calculate that and may give you a wrong estimate. And don't rely on DPM to automatically grow the volume as needed, make the calculations and set the size(s) correctly yourself.
    Thursday, November 17, 2016 4:43 PM
  • Following your thought, I set up a new protection group.  The space required is 127GB.  So I allocated 300GB and also left it set to autogrow.  Still getting the replica is inconsistent error.
    Thursday, November 17, 2016 5:13 PM
  • How did you come up with the 127GB requirement?

    Please post the entire Error Description form the DPM console. Any relevant entries in the logs on the host(s)?

    Thursday, November 17, 2016 6:08 PM
  • In previous troubleshooting of this VM the c: was changed from dynamic to fixed at 127GB.  In creating the Protection group it mentioned that size as well. 

    The \Online\testdpmVM only states Replica is inconsistent.

    Since a recovery point has yet to be created for the first time, none exist.  The console shows :

    Disk allocation shows 'Replica volume: 300gb allocated, 125.10 MB used | Recovery point volume 30 GB allocated, 0 KB used.

    I am currently seeing no errors around dpm, vss, or backups in the event log on the host.

    Thursday, November 17, 2016 7:54 PM
  • Hi,

    Can you share the error details in the failed initial replica job ?

    Can you install the latest DPM 2012 R2 update rollup - KB3162908 -Update Rollup 11 for System Center 2012 R2 Data Protection Manager.

    If you in-ckeck the integration services - Backup (volume checkpoint) - then run a consistency check, does that transfer data or still fail ?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, November 17, 2016 10:13 PM
    Moderator
  • Hi Mike J

    It took me a bit to get the rollup 11 installed and agents updated.

    I have done that, made sure the Scale out file server is updated as well and tried again.

    With and without the integration services - Backup (volume checkpoint) checked I still get the issue.

    I have my vssadmin shadowstorage to 30gb on the VM, not that I think that will matter.

    32 GB of shadowstorage on the Host.   I am not seeing any errors in the event logs for any of the systems involved.  I am kind of at a loss here.

    Saturday, November 19, 2016 4:55 AM
  • I saw an error for initial replica creation about not having required privileges. It referenced VM file location on the remote share.   Am checking that, and ensuring file server vss agent service is installed.
    Saturday, November 19, 2016 6:59 AM
  • Found the issue.

    file server vss agent was not installed on the scale out file servers where Hyper V keeps its VM storage.

    • Marked as answer by Aserak Saturday, November 19, 2016 11:25 PM
    Saturday, November 19, 2016 11:25 PM
  • HI

    Glad you found the missing step.

    For others interested, this is step 4. in the article: Set up protection for virtual machines with SMB storage

    4. Enable the File Server VSS Agent service on each SMB server—Add it in Add roles and features > Select server roles > File and Storage Services > File Services > File Service > File Server VSS Agent Service.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, November 21, 2016 11:49 PM
    Moderator