locked
Lenovo Driver Group RRS feed

  • Question

  • I have been trying to figure ths out for a few days now. I have drivergroups set up and working with my Dell machines but can not get them working with lenovo. I found some guides and tried them with no success Right now i have it set up 

    windows 7 x86

         xdell

        xLENOVO

            xThinkCentre M93p

    I modified the ztigather as well and nothing. Any help is appreaciated.

    Wednesday, March 26, 2014 3:07 PM

Answers

  • Lenovo uses particular numbers to identify a machine. So you need to make an translation between model number and model description or use the correct number.

    Execute the following command from an command prompt on each model to see which number the Lenovo model represents: wmic computersystem get model

    Modify your cs.ini and MDT out-of-box driver structure to match those numbers, or create selection profiles and target the "inject_drivers" step for each particular model by using task sequence variables or WQL condition to that particular driver group by the selection profile you have created, which goes like this: SELECT * FROM Win32_computersystem where MODEL = "%<lenovo modelnumber>%" or Task Sequence Variable Model equals <lenovo modelnumber>

    Good luck!


    If this post is helpful please click "Mark for answer", thanks! Kind regards


    Wednesday, March 26, 2014 7:06 PM

All replies

  • Lenovo uses particular numbers to identify a machine. So you need to make an translation between model number and model description or use the correct number.

    Execute the following command from an command prompt on each model to see which number the Lenovo model represents: wmic computersystem get model

    Modify your cs.ini and MDT out-of-box driver structure to match those numbers, or create selection profiles and target the "inject_drivers" step for each particular model by using task sequence variables or WQL condition to that particular driver group by the selection profile you have created, which goes like this: SELECT * FROM Win32_computersystem where MODEL = "%<lenovo modelnumber>%" or Task Sequence Variable Model equals <lenovo modelnumber>

    Good luck!


    If this post is helpful please click "Mark for answer", thanks! Kind regards


    Wednesday, March 26, 2014 7:06 PM
  • why not "ThinInstaller" .. :) google it on windows-noob..

    is much more flexible and accurate (there are drivers that require full gui installation) and other utilities.


    Wednesday, March 26, 2014 8:47 PM
  • Yes I tried this I have my folder structure set this way and In the DriverGroups001 variable i have it set to windows 7 x86/%make%/%model%, and still nothing.
    Wednesday, March 26, 2014 9:25 PM