none
SBS2011 Does network wizard assume that network mask is 24-bit?? RRS feed

  • Question

  • My software is just installed and trying to conf it.

     

    I have IP and my default gateway in the same network but not in C-class and hense Connect to the Internet wizard does not accept my IP. My IP for server is yyy.yyy.250.107 and default gateway is yyy.yyy.251.254 and my mask is 255.255.254.0. Wizard asks only for server IP and router IP (Default Gateway) and prompts that IP should be in the same class C network. Without that wizard to go trough, many other wizard dont even start.

     

    When I installed the OS it did ask for server IP and router IP also and didn't accept those IP's in that point either so I went with automate and it gave me 192.168.xxx.xxx IP's if I remember correctly.

     

    In Windows Small Business Server 2011 Console (management console) in Network/Connectivity indicates that my Internet connection is not connected even though I do have a working internet connection. I have changed my IP's manually from network adapter settings and I have internet connection but I cannot run some wizards if Connect to the Internet wizard hasn't gone trough and it wont go trough because I have 23 bit mask.

     

    Wizards that wont start if Connect to the Internet wizard hasn't run:

     

    Set up your Internet address

    Configure a Smart Host for Internet e-mail

    Add a trusted certificate

    These are the ones that I have attempted

     

    I also ran Fix my network wizard and here are the results:

     

    Network is not a Class-C subnet mask

    Could not configure the router

    DHCP is not configured correctly (in my network DHCP is not used)

    The DNS server is not listening to the IP address of the primary network adapter

    A DNS resource record is missing

    Reverse DNS zone is missing or invalid

    The Internet domain name is not configured

    Exchange SMTP connectors are invalid

     

    I have not done anything else to OS than change IP address from the network adapter settings after installation. My guess is that from that list above, the one thing that is bugging my SBS is that my IP's are not 24-bit masked but can it really be true that they have to be like so in order to SBS to connect to Internet correctly????

     

    Is there any way to go around this? I would like to get this wizard to go trough so that everything is like it should be but changing the IP's might be to much because I dont administer them my self. My IP's have been given to me.

     

    Those IP's are not public but are private IP's and my platform is virtual.

     

    Thank you for any help!

     

    Junkelo

    Friday, February 11, 2011 2:09 PM

Answers

  • AFAIK the wizards are coded to run with a /24 mask, so if your router is not contactable in the /24 equivalent, the only thing you could do i guess would be to find a valid available address in the 250 range, use a /24 mask there, and then switch back as suggested above.

    However that is a real load of extra hassle if you ask me.

    Is there no way to assign the router a second IP in a /24 network?

    The problem with doing the above (switching addresses) may not be just the hassle, but may also affect te DHCP scope, and all manner of things under the surface.


    Robert Pearman SBS MVP (2010)
    • Marked as answer by Junkelo Saturday, February 12, 2011 10:40 AM
    Friday, February 11, 2011 8:57 PM
    Moderator

All replies

  • Can you explain a bit more about the configuration you need to achieve?  I assume from the comment that "the IP's were given to me" that you are constrained to work within someone elses parameters, but can you tell us more about the circumstances.  there are some answers, one of which is that SBS is the wrong product, but we can't know without knowing more.

    So far we understand:

    You want to run SBS as a VM, but not what the hypervisor is or why you want/need to be virtual.

    You want to use an IP range the SBS does not expect.

    But we don't know why or what the goal is.

     


    Larry Struckmeyer

    Please post the resolution to your issue so that everyone can benefit

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, February 11, 2011 2:55 PM
    Moderator
  • My goal simply is to run Connect to the Internet wizard with those IP's that I have. My mask is 23-bit (255.255.254.0) and not 24-bit C-class mask (255.255.255.0). Does it really have to be 24-bit mask in order to successfully run the Connect to the Internet wizard? Wizard says that the server IP and router IP needs to be in the same C-class (24-bit, 255.255.255.0) subnetwork. My IP's are in the same subnetwork but not in the C-class subnetwork.

     

    Why I want that?

    I want it so that my Windows Small Business Server 2011 Console (management console) would indicate that I have connection to the internet, Connect to the Internet wizard has gone trough succesfully and then I can run those other wizards.

     

    I would like to manage some things with wizards but some wizards dont even start unless Connect to the Internet wizard has gone trough and it wont go trough succesfully because I have 23-bit mask and that wizards seems to expect 24-bit mask to be used (wizard itself dont ask my subnetwork mask, only server IP and router IP)

     

    Did this clarify my goals? Fact that my SBS is on virtual server I believe is irrelevant at this point. There is a fysical heavy server that holds virtual PC's and other virtual servers and my SBS is one of those virtual servers. Not runned by hyper-V. My SBS at the moment is for evaluation purposes. My company is about to adopt SBS 2011 and I need to test it first and countered first problem right at the start.

     

    Junkelo

    Friday, February 11, 2011 3:09 PM
  • I have done testing for this same condition (having a /23 mask) and it does work within a SBS2011 network, with some exceptions. 1) You will need to run your wizards initially with a /24 mask or they will fail. You may change your /24 to /23 manually on the adapter when the wizards complete (by the way, I have NOT done this testing with a SBS2011 VM, only on physical hardware). 2) If you need to run the wizards at any time, you will need to change the mask again.

    After this testing, I decided that if I wanted more device address space or to isolate devices such as IP phones to their own sub net, that the best solution is to use a router for this purpose. SBS 2011 (and the previous versions) assume less IT support for the network and make some network settings standard to assure better and easier setup.

    For migration scenarios from earlier versions of SBS to SBS 2011, you will need to set a /24 address space for the migration.


    Best Regards, Mark
    Friday, February 11, 2011 3:31 PM
  • Do you mean that in order to succesfully run the Connect to the Internet wizard I have to give some other IP for either the router IP or my server IP (so that the router and server IP's are in the same 24-bit subnetwork) and change them manually to the originals after running all necessary wizards? I can not just manually change the mask to 24-bit because then my IP's would be in different subnets and I would have the same problem. If I give some trivia IP's for either for router IP or server IP (in that wizard for those IP's to be in same 24-bit subnet), I dont actually have connection to internet because the IP's are not correct. For me to connect to internet I need to use those IP's that was given to me. Default gateway needs to be yyy.yyy.251.254 and my servers IP needs to be yyy.yyy.250.107 with subnet mask 255.255.254.0 for my server to really connect to the internet (and those IP's manually placed my server does connect to the internet but Connect to the Internet wizard dont work with those IP's).

    What about the Set up your Internet address wizard? Dont it need internet connection? If my IP's are not correct (against to my router backbone network) my server do not have access to internet (really have access and not just so that Connect to the Internet wizard thinks that I have).



    Junkelo
    Friday, February 11, 2011 4:20 PM
  • AFAIK the wizards are coded to run with a /24 mask, so if your router is not contactable in the /24 equivalent, the only thing you could do i guess would be to find a valid available address in the 250 range, use a /24 mask there, and then switch back as suggested above.

    However that is a real load of extra hassle if you ask me.

    Is there no way to assign the router a second IP in a /24 network?

    The problem with doing the above (switching addresses) may not be just the hassle, but may also affect te DHCP scope, and all manner of things under the surface.


    Robert Pearman SBS MVP (2010)
    • Marked as answer by Junkelo Saturday, February 12, 2011 10:40 AM
    Friday, February 11, 2011 8:57 PM
    Moderator
  • ""The problem with doing the above (switching addresses) may not be just the hassle, but may also affect te DHCP scope, and all manner of things under the surface.""

     

    This is exactly that I was affraid. Is this really so that I cannot use 23-bit mask if I would like to? Why?? What the F#¤%¤%&#¤? This is something that future SBS version developers maybe should think of, at least on my opinion! If I use Small Business Server, it doesnt mean that I know nothing about nothing and I may, just may, want to choose these kind of things my self?!?!

     

    I guess that, if no one has any other practical suggestion, I just have to pray for my network admins to give me IP's in the same C-class network.

     

    I have to say that this was one problem that I did not think that I would encounter with Microsoft Server software!! This is very, very odd.

     

     

    Junkelo

    Friday, February 11, 2011 10:05 PM
  • Use the /24 then go back and edit it.
     
    The wizards assume a /24 scope address.  Welcome to SBS where Microsoft
    builds it not for you, but for mass small business needs who wil just
    plunk down a 192.168.0.x address.
     
    Saturday, February 12, 2011 3:30 AM
    Moderator
  • I think that Microsoft could give users the choice to enter their own mask but there isn't one so I just have to live with it.

     

    I think that best thing here is just try to get those IP's in the same C-class.

     

    Thank you all for your answers!!

    Saturday, February 12, 2011 10:40 AM