locked
Unable to access mapped network drive, DFS RRS feed

  • Question

  • TL;DR: Unable to map a network drive on one particular computer, except if circumventing DFS.

    OK - So I have exhausted all my options in this matter, so all suggestions are welcome. 
    Keep in mind the file system is DFS.

    1. User has been set up the same as our other users in Active Directory.
    2. Most network drives are connected via GPO. They are mapped via\\company.local\common\

    3. The users' home folder is connected via setting in AD -> Profile -> Home folder -> 
    Connect X: To \\company.local\homedir\username
    4. When the user logs on, all network drives defined in GPO are mapped OK, but the X: which is defined via "Home folder" in AD, is not connected. When trying to map it manually, we get "Access denied".
    5. If the user tries the complete path via Explorer: \\company.local\homedir\username - Error 0x80004005 Unspecified error occurs. We have googled this particular code but found nothing that applies to us.
    6. If the user tries the complete path to the folder on the actual file server, circumventing DFS, the home folder is mapped OK.

    Strange thing is: This only happens on this particular computer. If users logs on to another computer, in the same domain, receiving the same GPO etc. The X: is mapped fine via \\company.local\homedir\username
    Also if another user logs on to the problematic computer they also cannot access their X: on \\company.local\homedir\username

    So we tried updating the WLAN/LAN drivers to no avail. Might there be any settings on the network adapters that might cause this?


    Kthxbai

    Wednesday, February 5, 2014 2:45 PM

All replies

  • Hi,

    Whether the root server(s) is different as folder target server(s)?

    Please check the following policy of each root server and the client:

    Local Policies > Security Options > Network Security: LAN Manager authentication level.

    Also check the registry key on all servers to make sure the policy applied correctly:

    http://technet.microsoft.com/en-us/library/cc960646.aspx


    If you have any feedback on our support, please send to tnfsl@microsoft.com.

    Thursday, February 6, 2014 9:24 AM
  • OK - Thanks.

    Server:

    - Policy: "Not Defined".
    - Registry: Confirmed not defined in registry.

    Computer:

    - Policy: "Send NTLMv2 response only. Refuse LM"
    - Registry: lmcompatibilitylevel 4 (only NTLMv2 authentication)

    As I understand, if it is not defined on a MS Server 2008 R2 , the setting is "Send NTLMv2 response only"

    Correct?
    • Edited by Stoltenberg Thursday, February 6, 2014 10:45 AM
    Thursday, February 6, 2014 10:44 AM
  • Any more input on this? I think the network adapter or some settings locally on the computer is the culprit here, because this works fine on other computers in the same domain, receiving the same instructions from group policy.


    Kthxbai

    Monday, February 10, 2014 1:33 PM
  • If other computer has the same policy ("Send NTLMv2 response only. Refuse LM"), it should not be the cause.

    I agree that all clients should have the same Group Policy but sometimes the group policy may not be applied correctly on a client which causes issues. Thus you can try a "gpupdate /force" and see if issue persists. 

    Also you can test to access \\company.local to see if it will success. Try \\rootserver as well if it is different as DFS folder target. 

    As the issue only occurs on a specific client, maybe we can have a try with re-join domain.


    If you have any feedback on our support, please send to tnfsl@microsoft.com.

    Wednesday, February 12, 2014 8:41 AM
  • How are things going? Please let us know if there is any progress.

    If you have any feedback on our support, please send to tnfsl@microsoft.com.

    Friday, February 14, 2014 6:06 AM
  • We have tried as suggested. Other folders on same DFS and same servers are accessible.

    The DFS-mappings defined via GPO is mapped correctly, and user is able to access them. The home folder-mapping, defined in user object in ActiveDirectory, is not mapped, and is not accessible.

    We have proved it is a computer related error because it also happens to other users who log on to this particular computer. 
    The next thing to try is re-join the domain. User not available for this yet.


    Kthxbai



    • Edited by Stoltenberg Monday, February 17, 2014 8:20 AM
    Monday, February 17, 2014 8:19 AM
  • Thank you for the update. Please feel free to let us know if issue still exists after re-join domain. 

    If you have any feedback on our support, please send to tnfsl@microsoft.com.

    Thursday, February 27, 2014 7:52 AM