none
Unable To Manage RDSConnectionBroker server using Remote PowerShell RRS feed

  • Question

  • Hi,

    i'm trying to access the RDS connection broker services through Remote PowerShell.

    On a high end:

    1. Configured the Remote PowerShell over Https on the Connection Broker server.

    2. used a valid SSL certificate.

    3. Able to connect to connection broker server and execute the get-process and other PS Cmdlets.

    4. Tried executing the Import-module RemoteDesktop; Get-RDSessionCollection -ConnectionBroker xxx.xxx.com. But getting the below error. 

    PS C:\WINDOWS\system32> Invoke-Command -Session $s -ScriptBlock {Import-Module RemoteDesktop; get-rdsessioncollection -connectionbroker "xxxx.xxx.com"}
    A Remote Desktop Services deployment does not exist on xxxx.xxx.com. This operation can be performed after creating 
    a deployment. For information about creating a deployment, run "Get-Help New-RDVirtualDesktopDeployment" or "Get-Help 
    New-RDSessionDeployment".
        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Get-RDSessionCollection
        + PSComputerName        : xxxxxxxxx.com

    Does any one worked on this before, please help in finding the solution and point i need to cover to resolve this.

    Thanks in advance.

    Tuesday, January 24, 2017 8:55 AM

Answers

All replies

  • Hi Shivag,

    Just to be sure: When you log in on the machine via RDP (or directly connect/open a console), running this works?

    Possibly, this cmdlet requires network authentication. What authentication did you use when creating your session? You may want to try CredSSP authentication.

    Cheers,
    Fred


    There's no place like 127.0.0.1

    • Proposed as answer by jrv Tuesday, January 24, 2017 11:53 AM
    Tuesday, January 24, 2017 9:38 AM
  • Fred has a good suggestion.  I believe the connection broker service acts like a firewall for authentication and prevents the whole server from being used remotely to access a third server (second hop) which would dictate using CredSSP or a constrained endpoint.

    \_(ツ)_/

    Tuesday, January 24, 2017 11:52 AM
  • Hi Fred,

    Thanks for looking into this, I'm able to connect to the Server Console using PowerShell Enter-PSSession with defualt authentication. Able to connect to connection broker server. for testing purpose i have deployed a quick RDS Setup on single server. So my Connection broker , GateWay, WebAccess and Session Host resides in single machine.

    I haven't tried enabling CredSSP. Do i need to explicitly add any permissions for RDS cmdlets to work remotely? 

    Regards

    Shiva

    Tuesday, January 24, 2017 5:53 PM
  • Post in RDS forum for help with getting this configured.

    \_(ツ)_/

    Tuesday, January 24, 2017 5:54 PM
  • Hi Shiva,

    hm ... if it all works just fine with Enter-PSSession, but not with New-PSSession, then I'm ... confused. Both should work just the same. Please post the two lines you used to establish the connection (That is, the lines with "Enter-PSSession" and "New-PSSession").

    Cheers,
    Fred


    There's no place like 127.0.0.1

    Wednesday, January 25, 2017 8:16 AM