none
SharePoint 2013 WOPI office webapps not opening Full Word document but only preview

    Question

  • hi All,

    We are noticing a weird behavior with SP 2013 office webapps (WOPI) whenever we click on any word document it only opens the PREVIEW page (as you would see when you hover around a document) instead of actually opening the FULL word document in the browser. It only opens the preview window of that document in the WOPI where it should open the actual document. Any place where the Config could be checked?

    Thanks


    Ana

    Monday, March 13, 2017 7:47 PM

All replies

  • Try unbinding OWA from your farm and then rebinding.
    Monday, March 13, 2017 7:58 PM
  • I'm not sure I follow the question.  When you preview a document (say from a search preview) it shows you the first page, but there are controls on the preview window that you can use to scroll through the document page by page.  Opening the full document works the same way.  You are given the document a page at a time, but you can scroll through the document in that view to any page.  So could you clarify what you mean by open the Full document?  WOPI does indeed open the document one page at a time, but its always done that by design.

    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Monday, March 13, 2017 7:58 PM
  • Hi Dan,

    Logon to the SharePoint application server that hosts Central Administration and open the SharePoint 2013 Management Shell (PowerShell), running it as an administrator. Next, enter the following PowerShell command:

    To check if other SPWOP binding is already configured between the server by using the below PowerShell script.

    Get-SPWOPIBinding

    Returns a list of bindings that were created by using New-SPWOPIBinding on the current SharePoint farm where this cmdlet is run.

    Remove the existing binding and Bind the office web app server again.

    Remove-SPWOPISuppressionSetting cmdlet.

    To create the binding between Office Web Apps Server and SharePoint 2013 by using New-SPWOPIBinding. This sets up communication between the server that runs SharePoint 2013 and the server that runs Office Web Apps Server. 

    1. Logon to the SharePoint application server that hosts Central Administration and open the SharePoint 2013 Management Shell (PowerShell), running it as an administrator. Next, enter the following PowerShell command:

    New-SPWOPIBinding -ServerNameserverName.pasa.pas.local

    Note: To make the fix for external users who access the SharePoint site from other location like Farmington Hill means the user who have different proxy server setting apart from Local Peach tree city, we need to change it like below.

    Set-SPWOPIZone -Zone "external-https"

    Dev/UAT Server

    New-SPWOPIBinding -ServerNameservername.pasa.pas.local

    Note: To make the fix for external users who access the SharePoint site from other location like Farmington Hill means the user who have different proxy server setting apart from Local Peach tree city, we need to change it like below.

    Set-SPWOPIZone -Zone "external-https"

    Julay

    --------------EXAMPLE 1-----------------

    New-SPWOPIBinding -ServerName "ptcprdsfbowa01.domain.pas.local "

    This example creates bindings for all the applications and file name extensions that the WOPI application supports on the current SharePoint farm where this cmdlet is run.

    --------------EXAMPLE 2-----------------

    New-SPWOPIBinding -ServerName "serverName.domain.pas.local " -Application "Excel"

    This example associates Excel with all the actions that the WOPI application supports for Excel on the current SharePoint farm where this cmdlet is run.

    1. View the WOPI zone of SharePoint 2013 by using Get-SPWOPIZone. This step highlights the fact that the two servers are using different WOPI zones: SharePoint 2013 is using internal-https, and Office Web Apps Server is using internal-http. The zone needs to match for Office Web Apps to work correctly. 
    2. Run the following PowerShell command to enabled OAuth over HTTP.

    $config = (get-spsecuritytokenserviceconfig) $config.allowoauthoverhttp = $true $config.update()

    1. Run the following PowerShell command to change the WOPI zone to external-https.

    Set-SPWOPIZone –zone “external-https”

    Finally, verify that Office Web Apps is working by navigating to a SharePoint 2013 document library and verify that you can open a document as a web page.


    KRISHANA KUMAR

    SharePoint Architect

    Mosstechnet-kk.com

     

    Please click "Mark As Answer" if this post solves your problem or "Vote As Helpful" if it was useful


    Monday, March 13, 2017 8:15 PM
  • Thank you for your response Paul, when you hover over any Doc lib within SP 2013 it shows a preview and then when you click on the document it opens up the document in browser and I Agree it displays single page but then you can scroll and next page can render, but in my case it is just displaying that STATIC preview and no scroll options (for a 40 page document which I have verified it has 40 pages). So basically whatever I see upon search preview same I see even after clicking on actual document and thats what is confusing to me. May be as Krishna suggested may be I have to remove the bindings and rebind it. Although not sure if it would be the right thing to do.

    Ana

    Tuesday, March 14, 2017 1:21 AM
  • Ketaan - it's very easy to unbind and rebind and takes just a few minutes - use the commands Krishana provided.  You have to do it anyway whenever you patch OWA.  One suggestion, after rebinding, 1) flush all caches (including app fabric and browser) and then 2) perform full crawl.
    Tuesday, March 14, 2017 4:08 AM