none
nslookup timed out

    Question

  • Hello All,

    I have created two virtual domain controllers on vmware environment with one virtual nic attached to each server. both servers are pinging each other with ip as well as fqdn. The problem is; when I try to ping Domain name through nslookup, it gives me two times "request timed out" and then resolve the domain name. I don't know how to solve the times out issue

    ---

    Tuesday, April 18, 2017 4:50 PM

All replies

  • Hi

     First check name server's from DNS menu,then check the dns health with "dcdiag /test:dns"...


    This posting is provided AS IS with no warranties or guarantees,and confers no rights. Best regards Burak Uğur

    Tuesday, April 18, 2017 5:48 PM
  • Thanks Burak for reply. Name servers are properly shown and pinging each other. I will run dcdiag and post the result. I have faced the similar issue before but that was due to some forwarders which name was not resolving but this time there is no forwarder defined and it is a fresh windows and AD installation.
    Tuesday, April 18, 2017 8:22 PM
  • You need to check DNS object for both machine and also should check DNS server ip address is correct or not.

    Regards,
    Sandeep Poonia
    Please verify the answer if it helps you.

    Wednesday, April 19, 2017 5:18 AM
  • Hi Sawag,

    Please try the following solution.

    1) Check firewall settings on both DC's, better turn off.

    2) Make sure there is a corresponding PTR record in reverse lookup zone in DNS 

    Solution worked for me when I tried.

    Read this thread for more details.

    https://social.technet.microsoft.com/Forums/sharepoint/en-US/f8da7378-db99-4e25-a8f9-c6103dd809d4/nslookup-dns-request-timed-out-timeout-was-2-seconds-cant-find-server-name-for-address?forum=winserverDS

    Thank you,

    Karim



    Wednesday, April 19, 2017 6:09 AM
  • Please check Primary DNS on NIC. If it is configured to loopback IP address 127.0.0.1 then change Primary DNS IP to local DNS server IP.

    Also check PTR record, If PTR record doesn't exists please add PTR record for Host record.


    Sugandh



    Wednesday, April 19, 2017 6:35 AM
  • thanks Every one. The issue is resolved after running DNS test "dcdiag /test:dns". This test gave me some wrong root hints configured in DNS. Once removed them, the issue is resolved.
    Wednesday, April 19, 2017 8:55 AM
  • Hi,
    Appreciate for the share, could you please help to mark it as answer? It will be greatly helpful to others who have the same question.

    Best Regards,

    Wendy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, April 19, 2017 1:52 PM
    Moderator