locked
SSMS not functioning RRS feed

  • Question

  • SSMS has been working flawlessly on my system for years, but as of yesterday it is no longer working.

    SSMS opens properly connecting to the server, all databases listed. If I right click on a table I can Select Top 1000 rows and the results display. but if I right click on:

    Design - The design page opens blank with the hourglass but nothing else except at the top of the screen it says SSMS is not responding. Let it sit there for hours but ultimately have to close the program.

    Edit Top  - Nothing at all happens except at the top of the screen it says SSMS is not responding.

    Create new table - New table page opens but as soon as you try to enter a column name ssms stops working with the same not responding line.

    I have reinstalled SSMS version 18.8  3 times and am running the Developer version of SQL Server 2019. When this issue started I was running SQL Server 2017 but tried updating to 2019 to see if that would resolve the issue.

    Thursday, December 24, 2020 11:45 AM

All replies

  • I am having the exact same issue.

    I downgraded all the way to 17.9 from the latest version 18.8.

    However, 17.9 doesn't work with my version 18 stuff.

    So, I went to version 18 and still have the same issue.

    Simply open a database, new or old--doesn't matter, and right click tables. Then, create new table; immediately after that SSMS just gets a Not Responding. 

    I have been using SSMS without issue up until last week..

    Saturday, December 26, 2020 2:52 PM
  • I'm seeing this exact same behavior as well.  I noticed it on Thursday as well.  I had 18.4 installed when it first appeared.  I've since upgraded to 18.8 with no change.  I'm running SSMS on Windows 10 locally with a VPN to  a SQL Server 2017 instance on a virtual machine on Azure.  I have working copies of SSMS 18.8 on the server itself and on a test VM housed on Azure but can't get it working from my local computer.  Similarly to Ordnance1 and Christian, I've had SSMS working flawlessly for years with this same configuration.

    Saturday, December 26, 2020 9:25 PM
  • I am having the same issue, have tried reinstalling SSMS 18.8 and a few different versions but cannot get it to work
    Tuesday, January 5, 2021 6:57 PM