Error 0x4C401C0C-0x80070057 on app-v 5 client


  • HI,

    I successfully sequence an application call Audacity 2 on a windows 8 sequencer.

    Publish the application without any problem.

    I get error event:19104 and 1008 on my app-v 5 client:

    Package {4ffed9b0-daf0-46ec-9995-b7c006f7ere} version {49fecc80-da64-4f84-bc19-835c4eafweef} failed configuration in folder 'C:\ProgramData\App-V\4FFED9B0-DAF0-46EC-9995-B7C006F7ERE\49FECC80-DA64-4F84-BC19-835C4EAFWEEF' with error 0x4C401C0C-0x80070057.

    I cannot see the package under C:\programdata\app-v


    Monday, January 28, 2013 9:02 AM


All replies

  • Hello,

    See this newly announced hotfix;

    You can call Micorsoft and request it, or you can await until its publicaly available

    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, January 28, 2013 9:04 AM
  • I have the same errors, have you found a way to fix your problem?

    That hotfix isn't available to public yet apparently... is there a way to request it?

    Thursday, February 21, 2013 5:50 PM
  • You can call Micorsoft and request it, or you can await until its publicaly available

    Nicke Källén | The Knack| Twitter: @Znackattack

    Friday, February 22, 2013 6:52 AM
  • Great work! znack you're still awesome! :)

    PS: Hotfix is now live on for anyone who comes across this thread.

    Edit: Looks like I cheered to soon... but my problem is slightly diffrent then the one in the first post: I also sequenced Audacity 2.0.3 with app-v 5 seqeuncer, but on Win7 SP1 x86. And i can sequence it AND publish it without any errors, but i never saw it on the client nor does the log show any error codes... i only get the same error code as filoupe when i manually run the generated msi file from the App-V package (on a Windows 7 and Windows 8 App-V 5 client).
    It's still nowhere on the client after applying the hotfix. Other packages like Artweaver or Office Word Viewer 2003 run as expected on any client.
    Any suggestions why i don't see any errors (not in the eventlog of the client or server), no folder in the ProgramData, just nothing anywhere --- only this error code when running the msi: Error in event log when trying to install msi from app-v 5 package

    Friday, April 19, 2013 12:11 PM
  • Hey Guys,

    I do also have same error with one of my package Mindjet Mindmanager....with app-v 5 client. I am turning nuts with this problem..Exactly same problem as Stephan Zeller has.. Help to find any fix to the problem



    Friday, April 19, 2013 4:06 PM
  • Hello,

    The error code means access denied. Enable more logs to identify where the failure comes from;

    Nicke Källén | The Knack| Twitter: @Znackattack

    Friday, April 19, 2013 6:30 PM
  • Hi Znack,

    I have enabled the detailed logs as per this link. This is very helpful for debugging app-v packages

    This error is found in streaming manger Debug logs. It doesnt give me any idea about this error

    Task- None                        -"Failed to retrieve package source root opt out setting from machine policy for package version {c60ecc73-b746-4602-8ee6-fd5535739c22} with status 4490208696731238406."

    Task- Package location provider - "Failed to parse uri provider guid, result = The configuration registry key is invalid.."




    Monday, April 22, 2013 6:18 AM
  • Thanks for this tip znack, very helpful one. I activated this logs and now i've got an error number which i can't find anywhere online at microsoft or by searching with google:

    i compared the xml-files for userconfiguration and deployment configuration with other virtualised apps and couldn't find a difference regarding source root or something, i can't find any diffrence in the sql db of the server regarding any paths or something... there's also an error which says Failed to parse uri provider guid, result= the key of the configurationregistration is incorrect (or something like that, sorry, the sentence is originally in german in my event logs)... compared a lot of values and entries in the db and configuration files (even in the .appv-package) and can't find any differences (of course except diffrent id's for the diffrent packages, but thats logical) which could cause the problem...

    Seems to be a strange problem... i also tried to delete and add the package again. I even sequenced the hole package again from scratch.

    Any help is much appreciated!

    Monday, April 22, 2013 12:13 PM
  • Hello,

    Without knowing your environment, there is little help to offer based on the very vague description above. The error code means access denied and considering that the component Streaming is involved - it most likely relates to retrieving the source-files.

    package source root is a setting per client and is set either via PowerShell or Group Policy.

    Then again - I have no idea what how you have setup your environment

    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, April 22, 2013 12:23 PM
  • Hi, sorry i forgot that... Server is 2012 Standard with SQL 2012 and the clients are Win 7 x64 enterprise and Win 8 x64 enterprise.

    The package source root wasn't set to anything with group policy, i now set it to %programdata%\App-V but it didn't solved the problem.

    Strange thing about the streaming is, that the other packages are streamed fine and they're in the same parent directories and have the same permissions and are sequenced on the same machine and everything should be the same (except for the sequenced software in the package of course).

    I now downloaded MDOP 2013 and updated the Sever to 5.0 SP1, but when i try to update the client (with the exe) it states an unknown error... also the .msi files beneath the appv_client_setup.exe are missing in this iso?!? I don't get it anymore...

    Tuesday, April 23, 2013 6:31 AM
  • I've seen this error in our environment on probably 10 out of 200 packages with have sequenced with App-V 5.0.  e.g.

    Failed to parse uri provider guid, result = The configuration registry key is invalid..

    Failed to retrieve package source root opt out setting from machine policy for package version {10e22e4e-8605-45a3-bf79-fb6e1e4db620} with status 4490208696731238406.

    No solution yet...

    Thursday, May 2, 2013 10:27 AM
  • This hotfix won't install on a SP1 client, but the problem persists. Any help would be appreciated.
    Thursday, May 9, 2013 3:50 PM
  • Hi,

    same error here.

    In my case it was a missing read permission on the App-V content share.



    Wednesday, July 24, 2013 8:29 AM