none
I have a macro that modifies the MS Project Options. Works for MSP 2007 but Issue with MSP 2010 and 2013 RRS feed

  • Question

  • Has any encountered this? I have a macro that sets various Tools > Options settings and it works just fine on MSP 2007. On MSP 2010 or 2013 it runs fine, but then I get an issue where I cannot save the file. Even trying File > Save or File > Save As or saving to different versions, I still can't seem to save the file. My only recourse is then to just select all tasks and copy and paste into a new file and then I can save that new file. I've run into this File > Save issue numerous times and have all service packs installed. 

    Thanks for any suggestions.

    Luis

    Wednesday, July 22, 2015 4:09 PM

All replies

  • Hi Luis,

    What options are you changing? Since Project 2010 and up use a different file format than previous versions, there are subtle issues that must be handled differently. I've run into this myself (i.e. a major fix to my DynamicToStatic macro) and I've recently worked with another user who had incompatibility issues with macros that worked fine with older versions but faulted when run with Project 2010.

    Let's see if we can break this down and figure out how to make yours work. For example, have you tried isolating it to a particular option or type of option?

    John

    Wednesday, July 22, 2015 5:14 PM
  • Thanks for that prompt reply, John. I did exactly what you suggest and I did find a couple of culprits that were deprecated in 2010 or 2013. I had already broken my code into multiple subroutines, so I tried running each and saving after and it did not cause that save issue. I will do the same with another complex routine that I run and see if I can catch the culprit. Thanks again. 
    Wednesday, July 22, 2015 6:09 PM
  • Luis,

    You're welcome and thanks for the feedback. If you can zero in on the specifics, please post what you found in case anyone else has a similar issue.

    John

    Wednesday, July 22, 2015 7:46 PM