none
Outlook cache problems - 550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found

    Question

  • Hi,

    after export and disable mailbox on source (old) exchange 2007 server, I import pst file to new Exchange 2013 server.

    But users at outlook - use response or auto substitution, and get massage after sending mail to the migrated user.

    IMCEAEX-_O=TECHNO_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+28FYDIBOHF23SPDLT+29_CN=RECIPIENTS_CN=TESTUSER3@domain.local
    #550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##

    and if thay inpute full email address - massage send with no errors.

    It like, outlook use cache. I try disable disable caching mode of outlook - but without success.

    How I can fix it, the best solution?

    Tuesday, September 13, 2016 3:08 PM

Answers

  • Hi,

    after export and disable mailbox on source (old) exchange 2007 server, I import pst file to new Exchange 2013 server.

    But users at outlook - use response or auto substitution, and get massage after sending mail to the migrated user.

    IMCEAEX-_O=TECHNO_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+28FYDIBOHF23SPDLT+29_CN=RECIPIENTS_CN=TESTUSER3@domain.local
    #550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##

    and if thay inpute full email address - massage send with no errors.

    It like, outlook use cache. I try disable disable caching mode of outlook - but without success.

    How I can fix it, the best solution?

    Because of the method you used to move mailboxes this is expected behavior.  Replies and emails sent via the Outlook Auto Complete cache will reference the users X400 Address, that was removed when you disabled the mailbox on the 2007 side of things.  

    Maybe if you can get the old x400 addresses you can try and restamp them on the new mailboxes.  

    Why did you do a pst export as opposed to a normal mailbox migration that would have preserved that attribute?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread

    Tuesday, September 13, 2016 3:33 PM
  • Try this one of the mailbox that has issue.

    Locate the LegacyExchangeDN on one of the old mailbox AD attribute and add the value as X500 address to the new mailbox. Try to send to send email.


    Please remember to mark the replies as answers if they help.



    • Edited by Al Laurente Wednesday, September 14, 2016 9:46 AM
    • Marked as answer by Denis.Pasternak Wednesday, September 14, 2016 5:06 PM
    Wednesday, September 14, 2016 9:45 AM
  • Hi,

    Does the issue occur on OWA?

    If you can send emails fine on owa, the issue may be related to the nickname file side on outlook.

    We can refer to the following KB to resolve the issue:

    https://support.microsoft.com/en-us/kb/2784785  

    Regards,



    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Denis.Pasternak Wednesday, September 14, 2016 5:05 PM
    Wednesday, September 14, 2016 5:44 AM
    Moderator

All replies

  • Hi,

    after export and disable mailbox on source (old) exchange 2007 server, I import pst file to new Exchange 2013 server.

    But users at outlook - use response or auto substitution, and get massage after sending mail to the migrated user.

    IMCEAEX-_O=TECHNO_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+28FYDIBOHF23SPDLT+29_CN=RECIPIENTS_CN=TESTUSER3@domain.local
    #550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##

    and if thay inpute full email address - massage send with no errors.

    It like, outlook use cache. I try disable disable caching mode of outlook - but without success.

    How I can fix it, the best solution?

    Because of the method you used to move mailboxes this is expected behavior.  Replies and emails sent via the Outlook Auto Complete cache will reference the users X400 Address, that was removed when you disabled the mailbox on the 2007 side of things.  

    Maybe if you can get the old x400 addresses you can try and restamp them on the new mailboxes.  

    Why did you do a pst export as opposed to a normal mailbox migration that would have preserved that attribute?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread

    Tuesday, September 13, 2016 3:33 PM
  • Why did you do a pst export as opposed to a normal mailbox migration that would have preserved that attribute?

    There two domains A and B, at domain A (exchange 2007), at domain B (Exchange 2013) and users account that are used currently by users. Users connect to old exchange and old accounts only for mail.

    In this situation , what other way to move mailboxes or mailboxes data?


    I would be grateful if you help


    Tuesday, September 13, 2016 3:59 PM
  • Hi,

    after export and disable mailbox on source (old) exchange 2007 server, I import pst file to new Exchange 2013 server.

    But users at outlook - use response or auto substitution, and get massage after sending mail to the migrated user.

    IMCEAEX-_O=TECHNO_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+28FYDIBOHF23SPDLT+29_CN=RECIPIENTS_CN=TESTUSER3@domain.local
    #550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##

    and if thay inpute full email address - massage send with no errors.

    It like, outlook use cache. I try disable disable caching mode of outlook - but without success.

    How I can fix it, the best solution?

    Because of the method you used to move mailboxes this is expected behavior.  Replies and emails sent via the Outlook Auto Complete cache will reference the users X400 Address, that was removed when you disabled the mailbox on the 2007 side of things.  

    Maybe if you can get the old x400 addresses you can try and restamp them on the new mailboxes.  

    Why did you do a pst export as opposed to a normal mailbox migration that would have preserved that attribute?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread

    I can remove X400 address? For migration time on old Exchange?

    $Recipients = Get-Mailbox -ResultSize Unlimited | Where {$_.EmailAddresses -like "X400:*"}
    foreach ($Recipient in $Recipients)
    {
    [array]$AllEmailAddresses = $Recipient.EmailAddresses
    [array]$NoX400Addresses = $Recipient.EmailAddresses | Where {$_ -notlike "X400:*"} 
    Set-Mailbox -Identity $Recipient.Identity -EmailAddresses $NoX400Addresses 
    }

    Tuesday, September 13, 2016 6:48 PM
  • Hi,

    Does the issue occur on OWA?

    If you can send emails fine on owa, the issue may be related to the nickname file side on outlook.

    We can refer to the following KB to resolve the issue:

    https://support.microsoft.com/en-us/kb/2784785  

    Regards,



    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Denis.Pasternak Wednesday, September 14, 2016 5:05 PM
    Wednesday, September 14, 2016 5:44 AM
    Moderator
  • Hi,

    Does the issue occur on OWA?

    If you can send emails fine on owa, the issue may be related to the nickname file side on outlook.

    We can refer to the following KB to resolve the issue:

    https://support.microsoft.com/en-us/kb/2784785  

    Regards,



    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    That's what I mean :) 
    Is there a way to prevent this?
    the problem manifested when send answer massege, how i can also fix it?
    Wednesday, September 14, 2016 5:49 AM
  • How about if click the X icon when autocomplete appears and select the name of address book? I assumed this issue only occur when the user sent the email to the mailbox previously. 

    Otherwise you can get the X400 address of those old mailbox and add it to their new mailbox.


    Please remember to mark the replies as answers if they help.

    Wednesday, September 14, 2016 7:14 AM
  • How about if click the X icon when autocomplete appears and select the name of address book? I assumed this issue only occur when the user sent the email to the mailbox previously. 

    Otherwise you can get the X400 address of those old mailbox and add it to their new mailbox.


    Please remember to mark the replies as answers if they help.

    Hm, I can not see X400 address - only SMTP at old user mailbox.

    And Get-Mailbox -ResultSize Unlimited | Where {$_.EmailAddresses -like "X400:*"}, resulte is null - no user at old exchange

    Wednesday, September 14, 2016 9:22 AM
  • Try this one of the mailbox that has issue.

    Locate the LegacyExchangeDN on one of the old mailbox AD attribute and add the value as X500 address to the new mailbox. Try to send to send email.


    Please remember to mark the replies as answers if they help.



    • Edited by Al Laurente Wednesday, September 14, 2016 9:46 AM
    • Marked as answer by Denis.Pasternak Wednesday, September 14, 2016 5:06 PM
    Wednesday, September 14, 2016 9:45 AM
  • Try this one of the mailbox that has issue.

    Locate the LegacyExchangeDN on one of the old mailbox AD attribute and add the value as X500 address to the new mailbox. Try to send to send email.


    Please remember to mark the replies as answers if they help.



    Unfortunately, there is no error , then send the message. But do not come to destination mailbox )
    Wednesday, September 14, 2016 11:33 AM