locked
Can't add network directories as Trusted Locations anymore?! RRS feed

  • Question

  • We have a bunch of network shares on which there are lots of Excel files, many of which contain macros necessary for functionality.  By default these locations are not trusted and the macros (and even editing a file) are blocked.  Fine.  Security reasons, I understand.  However, in previous versions of Office (2007 and back) I was able to add these locations as Trusted Locations.  In 2010, I cannot.  I have the "Allow Trusted Locations on my network" box checked, yet I am still unable to add them.  I continually get a message stating that "That path you have entered cannot be added as a Trusted Location for security reasons.  Choose another location or a specific folder."  I've tried selecting specific folders on the shares but that does not work either.  I've also tried adding the locations in the registry under HKCU\Software\Microsoft\Office\14.0\Excel\Security\Trusted Locations\ but that also does not work.

    Any ideas?  I really need to be able to add these shares as Trusted Locations, because there are a lot of files that are used on a daily basis, and users are going to get irritated quickly if they have to click "Enable content" several times just to make a small change in a file...


    Click Start, click Run..., type "cmd" and hit enter, type "work /now"
    Thursday, December 29, 2011 3:29 PM

All replies

  • There was a similar issue in Office 2007 when a root drive like X:\ was used as trusted location. (http://support.microsoft.com/kb/981041)

    How do your trusted locations look like? How do you map network drives? Does it happen when you use \\server\share\path or \\ip_address\share\path or \\fqdn.domain.tld\share\path?

    Some general hints: http://technet.microsoft.com/en-us/library/cc179039.aspx

    Did you try to assign the locations with Group Policies?

    • Proposed as answer by Eoin Ryan Wednesday, February 3, 2016 11:58 AM
    Friday, December 30, 2011 9:54 AM
  • On Windows XP the network drives are mapped using batch scripts at logon through Active Directory.  In Windows 7 the scripts do not consistently map drives.  I posted on the issue here, but it basically boils down to Windows 7 not recognizing cname aliases.  So, for Windows 7 I modified the script to use IP addresses (which do consistently work) and placed a copy in the Startup folder to map the drives.

    Usually I just click the Browse button, find the drive (for example, M:\) and select it, and it adds the drive to my Trusted Locations.  When it shows up in the list of Trusted Locations it does not appear as M:\ but as \\server\share.

    When I try the above technique in Office 2010, I get the error mentioned in my first post.  I tried adding the Trusted Locations through the registry as M:\ and as \\server_IP\share and neither one worked.  When I looked at the list of Trusted Locations, the one I added was grayed out and I could not even select it.  Opening spreadsheets from the location still blocked macros.  I did not try adding the location as \\server\share since the drive mapping script does not work using that format.


    Click Start, click Run..., type "cmd" and hit enter, type "work /now"
    Friday, December 30, 2011 2:29 PM
  • Anybody ever find a solution?
    Click Start, click Run..., type "cmd" and hit enter, type "work /now"
    Friday, January 20, 2012 8:15 PM
  • Really?  Nobody has any other advice to offer?
    Click Start, click Run..., type "cmd" and hit enter, type "work /now"
    Monday, January 30, 2012 5:14 PM
  • Bumping won't solve it ;) Maybe you should insert a coin somewhere ...

    One possible cause could be that your M: is identified as "Internet Zone". Try adding your server in different ways as Trusted Sites (in Internet Explorer):

    file://server
    http://server

    with server = netbios name, ip address and fqdn

    • Proposed as answer by Vic-T Monday, February 26, 2018 3:32 PM
    • Unproposed as answer by Vic-T Monday, February 26, 2018 3:32 PM
    Tuesday, January 31, 2012 7:18 AM
  • No luck.  Adding the server to the Trusted Sites didn't allow me to add them to the Trusted Locations in Office.  Great work, MS, on f-ing up yet more things that used to work perfectly fine...

    Click Start, click Run..., type "cmd" and hit enter, type "work /now"

    Monday, March 5, 2012 5:58 PM
  • I had the same problem and considering all my work is in Excel files stored in our network shared drive it was getting pretty frustrating. This is how I solved it for Excel 2010.

    1. Go to Excel Options > Trust Center > Trust Center Settings
    2. Go to 'Protected View' on the left hand side tab.
    3. Uncheck the box which says 'Enable Protected View for files originating from the Internet'

     Please note that the above method has an obvious security risk but if you are wise enough you should be fine.

    Wednesday, July 24, 2013 12:49 AM
  • Did you try adding server as \\servername.domain.com?  Using the IP address did not work, but using the entire name such as "\\server01.bacon.com" worked for me.
    Tuesday, October 15, 2013 9:34 PM
  • This is an old thread, but could you confirm if you were trying to add the UNC path to the network share or the path based on the mapped drive letter?

    In my experience, the UNC path works.

    Wednesday, February 3, 2016 11:58 AM
  • I got it to work by selecting the 2 check boxes in Trusted Locations and Trusted Documents tabs that allow trusted location on the network. Instead of using \\ipaddres\sharepath or mapped drive like F:\ which didn't work for me i used \\servername\sharepath  like \\myserver\documents and it worked.

    I'm using office 2016. 

    Monday, March 7, 2016 7:08 PM
  • Hi,
    This is an old question, but I've faced the same problem and found a solution for Office 2013.

    Steps:
    1. Setup:
    Excel > File menu > Options > Trust Center > Trust Center Settings > Trusted Locations.

    2. Check box "Allow Trusted Locations on my network (not recommended)"

    3. Go to "Add new location" and fullfill as below:
    \\server_name\desired_folder\

    4. Check box "Subfolders of this location are also trusted".

    Thanks


    • Proposed as answer by Fabr83 Wednesday, August 10, 2016 2:15 PM
    Wednesday, August 10, 2016 2:15 PM
  • July 9, 2018

    I tried everything as stated. All failed until this final step which worked. I'm surprised because domain names no longer work to access remote directories.

    Anyhow, THANKS!

    Monday, July 9, 2018 8:15 PM
  • Which Step?
    Thursday, September 20, 2018 3:14 PM
  • I'm not an expert at this, am an architect who doesn't have an IT department and have to try to solve issues myself and have the same problem. Suddenly, in Win 10, my NAS is not seen as a trusted location anymore and I'm warned, every time I try to open a file on it with Word, Access or Excel, that it is not a trusted location. It used to work before & I'm not sure if this started after a recent Office or Windows update. I went through the steps below that Fabr83 kindly provided above, but no joy:

      Steps:
      1. Setup:
      Excel > File menu > Options > Trust Center > Trust Center Settings > Trusted Locations.
      2. Check box "Allow Trusted Locations on my network (not recommended)"
      3. Go to "Add new location" and fullfill as below:
      \\server_name\desired_folder\
      4. Check box "Subfolders of this location are also trusted"

    And was able to add my NAS by its name but, I still get the "Protected View" warning every time I try to open a file, telling me it's from the internet, which it is not. I've tried a few variations, from setting just the server name down to a specific folder, like "\\NAS0DDD53\" to "\\NAS0DDD53\agrQNAP\" to "\\NAS0DDD53\QNAP\data\" as trusted locations but nothing works. I have to enable editing every time I access a document. I've searched online and, other than finding many people with the same problem, nothing much helpful other than this thread which still doesn't work for me. So, if anyone has some help for a non-expert like me, that would be great. Thanks.


    • Edited by pachanza Tuesday, November 13, 2018 9:58 PM
    Tuesday, November 13, 2018 9:38 PM
  • Did you try including the entire server name such as NAS0DDD53.mycompany.com?  If you don't have the whole name, pinging NAS0DDD53 from a command prompt window should give you the whole name.

    Tuesday, November 13, 2018 9:54 PM
  • The above method it is working on windows 10 . I just need to define on my windows hosts , server_name  (

    C:\Windows\System32\Drivers\etc\hosts   ) and map this to desired IP , before adding this to trusted location !    
     


    Monday, July 8, 2019 9:38 AM