none
DPM 2010 Agent 3.0.7707.0 ignore bootexecute in registry (from chkdsk /f c:) RRS feed

  • Question

  • On a DPM 2010 protected Windows 2008 Standard SP2 x64 Server, after install the DPM 2010 Agent 3.0.7707.0 (from March 2011), it is not possible make a CHKDK /f C: or D: .... . The Server ignore the bootexecute in registry and start normaly without a check disk process. Is this a bug?

    Tuesday, June 7, 2011 12:21 AM

All replies

  • Hi

    Are there any errors during the reboot when autochk is suppose to run.

    You should really set the dirty but using the following from an administrative command prompt.

       fsutil.exe dirty set c:

    Then check the dirty bit is set:  fsutil.exe dirty query c:   (or chkntfs c:)

    Once the dirty bit is set, autochk should run and reset the dirty bit - so you can check to see if it was reset using chkntfs c: after you log back in.


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, June 7, 2011 12:48 AM
    Moderator
  • Hi Mike, thank you for your feedback. The only way for me to run chkdsk /f in Bootmodus, I deactivate the DmpFilter (DpmFilter.sys) in the registry. Start = 4. After this, the chkdsk run normally. I think, this is a bug in DPM 2010, the DPM 2007 has this problem not.

     

    Best regards, Marco

    Saturday, June 11, 2011 8:22 AM
  • Hi,

    I will check into this, we moved from a volume filter driver in DPM 2007 to a file system filter driver in DPM 2010.


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Saturday, June 11, 2011 4:15 PM
    Moderator