locked
(Solved) Windows 10 Download Speeds VERY SLOW RRS feed

  • Question

  • Solved: I tried changing every setting with netsh no avail, tcp heuristics, auto-tuning etc.; After disabling hidden protocols on my adapters, my speed jumped from 2 megabytes to 25 megabytes on a single thread download, 40 on multithread. Before disabling these protocols I could get 30+ but only by multi-threading downloads and, oddly, speedtest.net. Inbuilt  Windows 10 1809  throttling disabled, now I can grab a single file & update the way my personal computer is designed for here is how:

    Download microsofts nvspbind.exe, to disable hidden protocols:
    in a poweshell window I run:

    .\nvspbind.exe /d * ms_server
    .\nvspbind.exe /d * ms_rdma_ndk
    .\nvspbind.exe /d * ms_implat
    .\nvspbind.exe /d * ms_netbios
    .\nvspbind.exe /d * ms_lldp
    .\nvspbind.exe /d * ms_tcpip6
    .\nvspbind.exe /d * ms_pppoe
    .\nvspbind.exe /d * ms_lltdio
    .\nvspbind.exe /d * ms_server
    .\nvspbind.exe /d * ms_netbt
    .\nvspbind.exe /d * ms_msclient
    .\nvspbind.exe /d * ms_ndiswan
    .\nvspbind.exe /d * ms_pacer
    .\nvspbind.exe /d * ms_ndiscap

    /d = disable, * = ALL windows adapters, unused ms_protocols
     
    This results, in my setup, just one adapter for example:

    {688F89F1-A446-489E-B0A5-D9762E0C7213}
    "pci\ven_1969&dev_1026"
    "Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller"
    "LAN":
        Local Area Connection
       disabled: ms_rdma_ndk      (Microsoft RDMA - NDK) (previously hidden and enabled)
       enabled:  ms_tcpip         (Internet Protocol Version 4 (TCP/IPv4))
       disabled: ms_implat        (Microsoft Network Adapter Multiplexor Protocol) (previously hidden and enabled)
       disabled: ms_netbios       (NetBIOS Interface)
       disabled: ms_lldp          (Microsoft LLDP Protocol Driver)
       disabled: ms_ndiscap       (Microsoft NDIS Capture)
       disabled: ms_tcpip6        (Internet Protocol Version 6 (TCP/IPv6))
       disabled: ms_rspndr        (Link-Layer Topology Discovery Responder)
       disabled: ms_pppoe         (Point to Point Protocol Over Ethernet) (hidden and previously enabled)
       disabled: ms_ndisuio       (NDIS Usermode I/O Protocol)
       disabled: ms_lltdio        (Link-Layer Topology Discovery Mapper I/O Driver)
       disabled: ms_server        (File and Printer Sharing for Microsoft Networks)
       disabled: ms_wfplwf_upper  (WFP 802.3 MAC Layer LightWeight Filter) (not sure)
       disabled: ms_netbt         (WINS Client(TCP/IP) Protocol)
       disabled: ms_msclient      (Client for Microsoft Networks)
       enabled:  oracle_vboxnetlwf (VirtualBox NDIS6 Bridged Networking Driver)
       disabled: ms_wfplwf_lower  (WFP Native MAC Layer LightWeight Filter)
       disabled: ms_pacer         (QoS Packet Scheduler)

    Customize this to your preference.



    • Edited by tutudids Sunday, February 3, 2019 11:37 AM tweaked
    Sunday, February 3, 2019 8:34 AM

Answers

  • I solved it, moving to first post.
    • Marked as answer by tutudids Sunday, February 3, 2019 8:34 AM
    Sunday, February 3, 2019 8:34 AM

All replies

  • I solved it, moving to first post.
    • Marked as answer by tutudids Sunday, February 3, 2019 8:34 AM
    Sunday, February 3, 2019 8:34 AM
  • Hi,

    Thank you for sharing solutions!

    If you have other questions, please feel free to contact us.

    Best 


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 4, 2019 1:45 AM