locked
Exch 2k7 - Deleted user on AD - cannot show mailbox as disconnected on E.M.C RRS feed

  • Question

  • Hi,

    one customer, delete one user account on AD, then the Mailbox disappeared on Exchange (E.M.C), even after one hour the mailbox is still not displayed in 'Disconnected Mailbox'.

    • How much time we need wait?
    • There is some service to restart to force E.M.C to detect the disconnected mailbox?

    The command below do not show results.

    Get-MailboxStatistics -Server <server> | where { $_.DisconnectDate -ne $null } | select DisplayName,DisconnectDate

    After read that article http://technet.microsoft.com/en-us/magazine/dd547067.aspx, the curious is: "Note that deleted mailboxes aren’t necessarily marked as such immediately. It may take 15 minutes to an hour before the mailbox is marked as deleted and listed accordingly."


    tks, Renato P

    Tuesday, January 15, 2013 7:21 PM

Answers

All replies

  • Run clean-mailboxdatabase and see if you can see it after that.

    • Marked as answer by jr3151006 Tuesday, January 15, 2013 8:10 PM
    Tuesday, January 15, 2013 7:55 PM
  • Hi Andy,

    you are right, after run the cmdlet the mailbox is visible. Tks a Lot!!!

    Just to complement that post, here is the usefull links:

    http://technet.microsoft.com/en-us/library/bb124076(v=exchg.80).aspx


    tks, Renato P


    Tuesday, January 15, 2013 8:09 PM
  • Run the below command to clean all databases for a exchange server to see Disconnected mailboxes.

    Get-MailboxDatabase -Server "Server Name" | Clean-MailboxDatabase


    Thanks Prem P Rana MCSA Messaging 2003 MCSE 2003 Server MCTS MCITP Exchange 2007, 2010 Gurgaon, India

    Saturday, January 19, 2013 2:09 PM