none
VPN error 788:The L2TP connection attempt failed because the security layer could not negotiate compatible parameters with the remote computer RRS feed

  • Question

  • I am trying to connect to a Windows 8.1 PC via a VPN. I am using IPSEC and have what I believe to be the correct services running on the PC. I have also set up my router to port forward ports 500, 50, 51, 1701, 4500(tried for various reasons). Lastly, I have set up a connection on the client PC(also windows 8.1) using Layer 2 tunneling and a PSK. After all of this I am getting the following error: The L2TP connection attempt failed because the security layer could not negotiate compatible parameters with the remote computer

    Any Ideas?

    Saturday, January 11, 2014 5:01 AM

Answers

  • Thank you for your response. As it turns out, my router did not support the appropriate protocols to setup a VPN. To remedy this issue, I flashed my router with the latest dd-wrt firmware and then setup my VPN. Everything works like a charm!
    • Marked as answer by ToTheCloud Thursday, January 30, 2014 12:20 AM
    Thursday, January 30, 2014 12:19 AM

All replies

  • Hi,

    According to your description,please check VPN setting for your client PC.

    Ensure your vpn configuration is right.

    Then,check that Windows services on your device are configured as described below.

    1.Press Win+R,type"services.msc",press Enter.

    2.In the "Services" window,scroll down the list to "IKE and AuthIP IPsec Keying Modules".

    3.Ensure the "Startup type" is set to be "Automatic" and the "Service status" is "Started".

    4.Now back in the "Services" window, double click on "IPsec Policy Agent".
    Repeat the same process as for the "IKE and AuthIP IPsec Keying Modules", ensuring the "Startup type" is set to be "Automatic" and the "Service status" is "Started".

    Meanwhile,let’s temporarily disable Windows firewall and security software.

    Regards,


    Kelvin hsu
    TechNet Community Support

    Tuesday, January 14, 2014 2:38 AM
    Moderator
  • Thank you for your response. As it turns out, my router did not support the appropriate protocols to setup a VPN. To remedy this issue, I flashed my router with the latest dd-wrt firmware and then setup my VPN. Everything works like a charm!
    • Marked as answer by ToTheCloud Thursday, January 30, 2014 12:20 AM
    Thursday, January 30, 2014 12:19 AM
  • Thanks it quite worked.
    Monday, November 21, 2016 4:20 AM