locked
Sharepoint online Provider hosted app in On premises/Azure vm/Aws vm | Context token null RRS feed

  • Question

  • We have a requirement where our web project needs to be hosted in either On premises windows server/Azure vm/Aws vm and we need to create a provider hosted app.

    Used VS 2013 and office tools to create an app for sharepoint, debugging it works fine and site title is displayed in the page that gets created by default. But once we publish the Website to any of the above said locations, and then package the app and upload it to the Apps for sharepoint under App catalog, then when we try to click on it, We get a window asking permissions and when we click 'Trust', the redirect is successful. But the context token is missing.

    Tried searching for this issue, could not find many implementations where the website is deployed in a VM instead many examples are available for Azure website only. Few suggested to make sure the ClientId is same in SPOnline for the app via AppRegNew.aspx and for the AppManifest.xml as well as the Web.config for the web project. It is all one and the same. I have also tried creating more than 10 apps similarly and everything runs into the same issue. What are we missing here.

    Thursday, March 26, 2015 11:50 AM

All replies

  • May be you are missing some deployment step like assigning proper URL or port numbers. some time i have also face similar problem , In my case i was missing port number while mentioning domain number.

    kindly share some more detail  then I will help you.

    Kaps pune

    Saturday, April 4, 2015 7:05 PM