none
Logged On As Admin - Can Not Change Time RRS feed

  • Question

  • As the title states, I can not change the system time logged on as admin.  I get an error about how my account does not have the proper privilege to do so.  I am an admin and so is my account, lol.

    Wednesday, August 22, 2007 1:22 PM

Answers

  • Hi SpurtSpanker,

     

    Please let me know the exact error message first. Have you configured any restrictions for the Admin account from SteadyState?

     

    By default, Administrators have the right to change system time. Please check if your account is really an administrator account:

    ---------------------

    1. Click Start, and then click Run.

    2. In the Open box, type “control userpasswords2” without quotations and then click OK.

    3. Please check if the your user account belongs to the Administrators group. If not, this can be an expected issue as restricted user have no privilege to change system time.

     

    If your user account was not in the Administrators group and you would like to add it. Please select your user account and then click the Properties button. Click the Group Membership tab. Select Others and then Administrators. Click OK.

     

     

    If your user account is already an Administrators group member. Please check if the user account have the privilege to set system time:

    ---------------------

    1. Download and install Windows XP Support Tools from the following website:

     

    http://www.microsoft.com/downloads/details.aspx?familyid=49ae8576-9bb9-4126-9761-ba8011fabf38&displaylang=en

     

    2. Click Start and then Run. Type in CMD and press Enter.

    3. Type in “whoami /all” without quotations and press Enter.

    4. Check if the following line exists:

     

    (O) SeSystemtimePrevilege  = Change the system time

     

    If the above right is missing, you can logon as the local administrator and run the following command to grant the privilege.

     

    ntrights -u <Computer Name>\<user name> +r SeSystemTimePrivilege

     

     

    If the ntrights command cannot be recognized, we need to install Windows Server 2003 Resource Kit Tools (which include ntrights.exe) first:

     

    http://www.microsoft.com/downloads/details.aspx?FamilyID=9d467a69-57ff-4ae7-96ee-b18c4790cffd&DisplayLang=en

     

     

    As this issue is not related to SteadyState, this inquiry would best be posted to Windows XP public newsgroup:

     

    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx?dg=microsoft.public.windowsxp.general

     

    The reason why we recommend posting appropriately is that you will get the most qualified pool of respondents, and other customers who read the newsgroups regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding.

     

    Best Regards,

    Friday, August 24, 2007 6:20 AM
  • Hi all,

    It looks like SteadyState requires you to deselect the Remove Control Panel icon checkbox in the Start Menu Restrictions area of the Windows Restrictions tab for this to work. If this checkbox is selected you will not have access to the Date and Time Properties control panel.

    We are deploying an application into a medical environment w/o a domain in which the time setting of the PC's is critical. As there is no time server, we need to give users the ability to reset the clock when the system time drifts.

    Thanks,

    Bob
    Friday, August 24, 2007 8:31 PM

All replies

  • Hi SpurtSpanker,

     

    Please let me know the exact error message first. Have you configured any restrictions for the Admin account from SteadyState?

     

    By default, Administrators have the right to change system time. Please check if your account is really an administrator account:

    ---------------------

    1. Click Start, and then click Run.

    2. In the Open box, type “control userpasswords2” without quotations and then click OK.

    3. Please check if the your user account belongs to the Administrators group. If not, this can be an expected issue as restricted user have no privilege to change system time.

     

    If your user account was not in the Administrators group and you would like to add it. Please select your user account and then click the Properties button. Click the Group Membership tab. Select Others and then Administrators. Click OK.

     

     

    If your user account is already an Administrators group member. Please check if the user account have the privilege to set system time:

    ---------------------

    1. Download and install Windows XP Support Tools from the following website:

     

    http://www.microsoft.com/downloads/details.aspx?familyid=49ae8576-9bb9-4126-9761-ba8011fabf38&displaylang=en

     

    2. Click Start and then Run. Type in CMD and press Enter.

    3. Type in “whoami /all” without quotations and press Enter.

    4. Check if the following line exists:

     

    (O) SeSystemtimePrevilege  = Change the system time

     

    If the above right is missing, you can logon as the local administrator and run the following command to grant the privilege.

     

    ntrights -u <Computer Name>\<user name> +r SeSystemTimePrivilege

     

     

    If the ntrights command cannot be recognized, we need to install Windows Server 2003 Resource Kit Tools (which include ntrights.exe) first:

     

    http://www.microsoft.com/downloads/details.aspx?FamilyID=9d467a69-57ff-4ae7-96ee-b18c4790cffd&DisplayLang=en

     

     

    As this issue is not related to SteadyState, this inquiry would best be posted to Windows XP public newsgroup:

     

    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx?dg=microsoft.public.windowsxp.general

     

    The reason why we recommend posting appropriately is that you will get the most qualified pool of respondents, and other customers who read the newsgroups regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding.

     

    Best Regards,

    Friday, August 24, 2007 6:20 AM
  • Hi all,

    It looks like SteadyState requires you to deselect the Remove Control Panel icon checkbox in the Start Menu Restrictions area of the Windows Restrictions tab for this to work. If this checkbox is selected you will not have access to the Date and Time Properties control panel.

    We are deploying an application into a medical environment w/o a domain in which the time setting of the PC's is critical. As there is no time server, we need to give users the ability to reset the clock when the system time drifts.

    Thanks,

    Bob
    Friday, August 24, 2007 8:31 PM
  • Thank you for Bob’s input.

     

    If a user account is not an administrator or related privilege has been removed, the following message will be displayed when trying to change the System Time:

     

    “You do not have the proper privilege level to change the System Time”

     

    However, if the issue is caused by SteadyState’s “Remove the Control Panel icon” restriction, the following error message will be encountered:

     

    “This operation has been cancelled due to restrictions in effect on this computer. Please contact your system administrator”

     

    Regards,

    Tuesday, August 28, 2007 9:18 AM
  • As the title states, I can not change the system time logged on as admin.  I get an error about how my account does not have the proper privilege to do so.  I am an admin and so is my account, lol.


    Maybe im to late answering but i think the reason is :
    -U have installed Faronics Deep Freeze.(UNINSTALL IT)
     -U didnt tried GPedit.msc - windows settings - security settings - local policies - user rights asignment - change the system time(right click properties) (TRY IT)
     
    Saturday, July 25, 2009 7:52 AM
  • As the title states, I can not change the system time logged on as admin.  I get an error about how my account does not have the proper privilege to do so.  I am an admin and so is my account, lol.


    Maybe im to late answering but i think the reason is :
    -U have installed Faronics Deep Freeze.(UNINSTALL IT)
     -U didnt tried GPedit.msc - windows settings - security settings - local policies - user rights asignment - change the system time(right click properties) (TRY IT)
     

    I know this is posted AUGUST 22 2007 , but this could help others who have the same problem
    Saturday, July 25, 2009 7:55 AM