none
Access Service Problem

    Question

  • Hi all ;

    I configured SharePoint 2013 Access Service but when I trying to make a custom web app from Access desktop application , got an error " https://ibb.co/cKBFd5 " and when I checked inside of my test site , I found this Error " there was a problem accessing app's database - accessing denied to secure store service  " . 

    My SharePoint working on Multi-Tenant mode .

    please let me know your Idea 

    very thanks 


    Saeid.ADZ

    Tuesday, April 18, 2017 9:14 AM

All replies

  • Hi Saeid.ADZ,

    Please run the PowerShell command below to check if the farm account is added as the secure store system account.

    Get-SPSecureStoreSystemAccount


    If the farm account is not a secure store system account, add the farm account to the SystemAccountName list with the following PowerShell command.

    Add-SPSecureStoreSystemAccount –AccountName <account>


    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, April 19, 2017 7:11 AM
    Moderator
  • Dear Linda ; 

    thank you 

    If I understand your means is an account that I configured Access service .. Yes . I configured access service with a managed account " Access_AC " and this account is exist in SPSecureStoreSystemAccount now .


    Saeid.ADZ

    Wednesday, April 19, 2017 7:58 AM
  • Linda 

    Can I using separate Secure store that configured in unpartitioned mode ?  

    Is that have reflect to my Tenant farms ?


    Saeid.ADZ

    Wednesday, April 19, 2017 8:46 AM
  • Hi Saeid.ADZ,

    The farm account is used as the application pool identity for Central Administration and as the process account for the SharePoint Timer service.

    Read the following article to learn more about the farm account.

    https://technet.microsoft.com/en-us/library/cc678863.aspx#Section2

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, April 26, 2017 3:11 AM
    Moderator
  • Thanks Linda :)

    I want know how can I use target application ID for access service that configure in Tenant admin environment 


    Saeid.ADZ

    Wednesday, April 26, 2017 11:42 AM
  • Hi Saeid.ADZ,

    We need to use separate Secure store in partitioned mode for multi-tenant.

    Understanding multi-tenancy in SharePoint Server 2013:

    https://technet.microsoft.com/en-us/library/dn659286.aspx?f=255&MSPPError=-2147217396

    We cannot use target application ID for Access Service. Access Services cannot be partitioned.

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, April 28, 2017 1:44 AM
    Moderator