locked
Trying set up a TS specifically for wiping a disk. RRS feed

  • Question

  • Hello everyone! So I will try to keep it simple.

    So we have been using MDT 2013 to deploy machines in our environment with good success so far. One of the things that I wanted to do was make it easier for techs to use MDT as a "toolkit" of sorts. I wanted to create a task sequence that would allow them to simply click on it, and run our "approved" wiper, Symantec's gdisk32 for 32 bit machines and gdisk64 for 64 bit machines.

    Now, I started off with a TS with a single step in it, a run command step with the value:

    cmd.exe /c start /wait gdisk32.exe 1 /diskwipe /custom:3 /Y

    This runs without issue. A cmd prompt pops up behind the progress window and I can watch the .exe's output as it goes. It's a bit janky, but I called it that way because I want to see the progress of the wipe. These machines take a good 5 hours on a three pass, and for some machines, we run a 7. I can't just have it running in the background with no progress indication.

    However, I noticed something really irritating. When I run that TS and it completes, the monitoring portion of MDT simply reports that the machine is "unresponsive" and the time never stops counting. It's not a huge issue, but I'd like to get a general metric on how long these are taking.

    I decided to approach the problem from another angle, and tried to just call ZTIDiskWipe.wsf in a test TS. It flies thru the TS and reports everything succeeded. I'm not quite sure what I'm doing wrong, or if this is even the best way to do it in MDT.

    While I know that MDT has the wipe built in when doing captures and USMT migrations and such, I'm trying to make a machine wipe as close to "One-Click" for everyone who would need to use it.

    Any advice?

    Friday, April 14, 2017 11:21 PM

All replies

  • Two notes:

    1. <rant> https://en.wikipedia.org/wiki/Data_erasure#Number_of_overwrites_needed

    2. If you are worried about the timeout, you could write an occasional message to MDT service as a keep alive ping.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Tuesday, April 18, 2017 12:35 AM
  • I'm actually TRYING to get the cmd prompt to pop up so I can see the progress on GDISK but it's not working. It runs but invisibly which I don't like. Do you have GDISK embedded in your WIM or are you calling it in the task sequence from the deployment share?
    • Edited by rza49311 Tuesday, July 11, 2017 12:12 PM
    Tuesday, July 11, 2017 12:12 PM