none
Project Online - Project Site Creation Failed RRS feed

  • Question

  • I'm seeing that my project site template is now failing with an error saying a feature needs to be installed.

    site name=Roland Test orig temp. Microsoft.SharePoint.SPException: The site template requires that the Feature {d70044a4-9f71-4a3f-9998-e7238c11ce1a} be installed in the farm or site collection.   at Microsoft.SharePoint.Utilities.SPUtility.ThrowSPExceptionWithTraceTag(UInt32 tagId, ULSCat traceCategory, String resourceId, Object[] resourceArgs)   at Microsoft.SharePoint.SPWebTemplateElement.VerifyFeatures(XmlNodeList xmlNodeFeatures, SPWeb applyTemplateToThisWeb, SPFeatureScope featureScope, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, List`1& featureDependencyErrors)   at Microsoft.SharePoint.SPWebTemplateElement.VerifyWebFeatures(XmlNode xmlNodeConfiguration, SPWeb applyTemplateToThisWeb, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, List`1& featureDependencyErrors)   at

    I checked everywhere and can't find this Feature Guid. Has anyone run into this issue before? I tried the OOB project site template and that works with our EPT. I also compared the site features between the OOB project site template and my custom site template. There were no differences in the features.

    Anyone have any ideas? Thanks!

    Wednesday, November 19, 2014 4:59 AM

All replies

  • Hello. What have you changed on the custom template? I take it from your query this did work fine previously? Paul

    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP

    Wednesday, November 19, 2014 6:42 AM
    Moderator
  • Remove below feature from ONET.XML

    <!--AddAlchemyApp Feature-->
                    <Feature ID="{d70044a4-9f71-4a3f-9998-e7238c11ce1a}" Name="FeatureDefinition/15/d70044a4-9f71-4a3f-9998-e7238c11ce1a" SourceVersion="1.0.0.0" />

    BHARAT SUKWAL

    Wednesday, November 19, 2014 8:32 AM
  • Hi Paul,

    From the previous version of the template? I simply updated a file in a document library. Previous versions of my custom template worked, but now even the original version of my template doesn't work... I can't pinpoint what the issue is so my next step is to re-build a new template and use that one. Any other ideas?

    Thanks,

    Roland

    Wednesday, November 19, 2014 2:13 PM
  • There isn't a custom site def deployed. I created a custom site template from a subsite that I saved as a site template.

    What's the AddAlchemyApp feature?

    Wednesday, November 19, 2014 2:15 PM
  • Hi Roland,

    Did you find a resolution to this issue? 

    We experienced the same Project Site Template / missing Feature issue last week after installing and uninstalling PowerPivot.  I know what would Power Pivot have to with creating Project Sites.  Very strange. 

    Anyway after the PowerPivot install/uninstall/reinstall it seems that Project Server can no longer create Project Sites using our Project Site Template. We can still create sites in SharePoint directly. 

    Note we have used this Project Site template without issue for the last 3 years.

    Hopefully you have found a solution you might be willing to share.

    Thanks,

    David

    Thursday, June 11, 2015 5:43 PM