none
Unattend answer file for pass [oobe system] . The answer file is invalid

    Question

  • This is done through a virtual machine and from the threads that i have read; I will need to check on  Setupact.log to see why it failed.

    Unfortunately when i click OK on this, the following error occurs and loops back to the top

    Is there a way for me to go into the virtual harddisk and pull out the log to check ? The sysprep which i am using is a Dell Sysprep and not the sysprep available in system32.

    Friday, August 10, 2018 6:03 AM

All replies

  • Hi,

    Can you Please Check the Unattended.xml File & Validate the same!

    Friday, August 10, 2018 10:26 AM
  • I think at this stage, when you get the first error, you should be able to press Shift + F10 and get a command window open.  Then you should be able to open notepad and view the files.  Or you can plug in a USB drive and copy the files over and read them on another computer.

    LawsonT

    Friday, August 10, 2018 3:45 PM
  • Turn off the VM and then mount the VHDx file in Windows Explorer. You should be able to access Windows setup logs which in turn will help you narrow down the issue.

    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Monday, August 13, 2018 12:09 PM
  • i'm using Anton's idea of mounting the VHDx file which works but I am unable to check the Unattended.xml  file as suggested by JiteshKumar as i get an Access Denied error.

    btw Anton, where is the Windows setup logs ?

    Tuesday, August 14, 2018 1:31 AM
  • I described the process of troubleshooting the specialize phase in a blog post a while ago: https://vacuumbreather.com/index.php/blog/item/62-the-case-of-just-a-moment Btw, you could also post your unattend.xml here and we could try working out the underlying cause

    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Tuesday, August 14, 2018 5:15 AM
  • Hi Anton,

    hope the information below helps.

    --------------

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="generalize">
            <component name="Microsoft-Windows-Security-SPP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SkipRearm>1</SkipRearm>
            </component>
            <component name="Microsoft-Windows-PnpSysprep" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <PersistAllDeviceInstalls>true</PersistAllDeviceInstalls>
    <DoNotCleanUpNonPresentDevices>false</DoNotCleanUpNonPresentDevices>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <RunSynchronous>
                    <RunSynchronousCommand wcm:action="add">
                        <Order>1</Order>
                        <Path>net user administrator /active:No</Path>
    <WillReboot>Never</WillReboot>
                    </RunSynchronousCommand>
                </RunSynchronous>
            </component>
            <component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SkipAutoActivation>true</SkipAutoActivation>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <ComputerName>*</ComputerName>
    <CopyProfile>true</CopyProfile>
                <TimeZone>TIMEZONE</TimeZone>
            </component>
            <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Identification>
                    <Credentials>
                        <Domain>DOMAIN_FQDN</Domain>
                        <Password>PASSWORD_ADMIN</Password>
                        <Username>SAMACCOUNTNAMEADMIN</Username>
                    </Credentials>
                    <JoinDomain>DOMAIN_FQDN</JoinDomain>
    <MachineObjectOU>OU_INTEGRATION</MachineObjectOU>
                    <JoinWorkgroup></JoinWorkgroup>
                </Identification>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>KEYBOARD_LAYOUT</InputLocale>
                <SystemLocale>DEFAULT_SYSTEM_LAYOUT</SystemLocale>
                <UILanguage>en-US</UILanguage>
                <UILanguageFallback>en-US</UILanguageFallback>
                <UserLocale>USER_LOCALISATION</UserLocale>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <AutoLogon>
                    <Password>
                        <Value>PASSWORD_LOCAL_ADMINISTRATOR</Value>
                        <PlainText>true</PlainText>
                    </Password>
                    <LogonCount>2</LogonCount>
                    <Enabled>true</Enabled>
                    <Username>LOGIN_LOCAL_ADMINISTRATOR</Username>
                </AutoLogon>
                <FirstLogonCommands>
                    <SynchronousCommand wcm:action="add">
                        <CommandLine>cscript c:\windows\system32\slmgr.vbs /ipk BHXQD-CNMKV-VMWBT-2YM2B-HT9R4</CommandLine>
                        <Description>Windows License Key</Description>
                        <Order>1</Order>
                        <RequiresUserInput>false</RequiresUserInput>
                    </SynchronousCommand>
                    <SynchronousCommand wcm:action="add">
                        <RequiresUserInput>false</RequiresUserInput>
                        <Order>2</Order>
                        <Description>Active Windows</Description>
                        <CommandLine>cscript c:\windows\system32\slmgr.vbs /ato</CommandLine>
                    </SynchronousCommand>
    <SynchronousCommand wcm:action="add">
                        <CommandLine></CommandLine>
                        <Description>Disable UAC</Description>
                        <Order>3</Order>
                        <RequiresUserInput>false</RequiresUserInput>
                    </SynchronousCommand>
                </FirstLogonCommands>
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                    <NetworkLocation>Work</NetworkLocation>
                    <ProtectYourPC>3</ProtectYourPC>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                    <HideLocalAccountScreen>true</HideLocalAccountScreen>
                </OOBE>
                <UserAccounts>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>PASSWORD_LOCAL_ADMINISTRATOR</Value>
                                <PlainText>true</PlainText>
                            </Password>
                            <Description>Local Administrator</Description>
                            <DisplayName>LOGIN_LOCAL_ADMINISTRATOR</DisplayName>
                            <Group>Administrators</Group>
                            <Name>LOGIN_LOCAL_ADMINISTRATOR</Name>
                        </LocalAccount>
                    </LocalAccounts>
    <DomainAccounts>
    <DomainAccountList wcm:action="add">
    <DomainAccount wcm:action="add">
    <Group>Administrators</Group>
    <Name>USERNAME</Name>
    </DomainAccount>
    <Domain>DOMAIN_FQDN</Domain>
    </DomainAccountList>
    </DomainAccounts>
                </UserAccounts>
                <RegisteredOrganization>InfoVista SAS</RegisteredOrganization>
                <RegisteredOwner>InfoVista SAS</RegisteredOwner>
            </component>
        </settings>
    </unattend>

    ----------------------------

    setuperr

    2018-08-08 01:38:33, Error                 TOOL   BCD: BiUpdateEfiEntry failed c000000d
    2018-08-08 01:38:33, Error                 TOOL   BCD: BiExportBcdObjects failed c000000d
    2018-08-08 01:38:33, Error                 TOOL   BCD: BiExportStoreAlterationsToEfi failed c000000d
    2018-08-08 01:38:33, Error                 TOOL   BCD: Failed to export alterations to firmware. Status: c000000d
    2018-08-08 01:38:35, Error                 SYSPRP ClipCleanUpState resetting WNF_OLIC_OS_LICENSE_TERMS_ACCEPTED failed with NTSTATUS=c0000022[gle=0x00000002]

    -----------------------------

    Tuesday, August 14, 2018 5:49 AM
  • Is this standard unattend.xml generated by MDT? From the first glance it appears to be incomplete.

    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Tuesday, August 14, 2018 6:27 AM
  • i believe it is.

    though i cannot say for certain. 

    what other information can i provide ?

    Tuesday, August 14, 2018 6:41 AM
  • I am assuming you pulled the unattend.xml from a failing machine? Could you grab the unattend.xml from your TS folder and post it here?

    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Tuesday, August 14, 2018 6:43 AM
  • that is correct. i pulled the unattend.xml from the failing machine.

    TS Folder ? 

    Tuesday, August 14, 2018 6:46 AM
  • That would be the Task sequence Folder. You will find it in <path to your deployment share>\Control\<TaskSequenceID> subfolder

    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Tuesday, August 14, 2018 6:47 AM
  • i believe that this is the file.

    Anyway, i use a sysprep program called KACE K2000 , which when run correctly will ask for an unattend.xml 

    ----------------------------------------------------------

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="generalize">
            <component name="Microsoft-Windows-Security-SPP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SkipRearm>1</SkipRearm>
            </component>
            <component name="Microsoft-Windows-PnpSysprep" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <PersistAllDeviceInstalls>true</PersistAllDeviceInstalls>
    <DoNotCleanUpNonPresentDevices>false</DoNotCleanUpNonPresentDevices>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <RunSynchronous>
                    <RunSynchronousCommand wcm:action="add">
                        <Order>1</Order>
                        <Path>net user administrator /active:No</Path>
    <WillReboot>Never</WillReboot>
                    </RunSynchronousCommand>
                </RunSynchronous>
            </component>
            <component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SkipAutoActivation>true</SkipAutoActivation>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <ComputerName>*</ComputerName>
    <CopyProfile>true</CopyProfile>
                <TimeZone>TIMEZONE</TimeZone>
            </component>
            <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Identification>
                    <Credentials>
                        <Domain>DOMAIN_FQDN</Domain>
                        <Password>PASSWORD_ADMIN</Password>
                        <Username>SAMACCOUNTNAMEADMIN</Username>
                    </Credentials>
                    <JoinDomain>DOMAIN_FQDN</JoinDomain>
    <MachineObjectOU>OU_INTEGRATION</MachineObjectOU>
                    <JoinWorkgroup></JoinWorkgroup>
                </Identification>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>KEYBOARD_LAYOUT</InputLocale>
                <SystemLocale>DEFAULT_SYSTEM_LAYOUT</SystemLocale>
                <UILanguage>en-US</UILanguage>
                <UILanguageFallback>en-US</UILanguageFallback>
                <UserLocale>USER_LOCALISATION</UserLocale>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <AutoLogon>
                    <Password>
                        <Value>PASSWORD_LOCAL_ADMINISTRATOR</Value>
                        <PlainText>true</PlainText>
                    </Password>
                    <LogonCount>2</LogonCount>
                    <Enabled>true</Enabled>
                    <Username>LOGIN_LOCAL_ADMINISTRATOR</Username>
                </AutoLogon>
                <FirstLogonCommands>
                    <SynchronousCommand wcm:action="add">
                        <CommandLine>cscript c:\windows\system32\slmgr.vbs /ipk BHXQD-CNMKV-VMWBT-2YM2B-HT9R4</CommandLine>
                        <Description>Windows License Key</Description>
                        <Order>1</Order>
                        <RequiresUserInput>false</RequiresUserInput>
                    </SynchronousCommand>
                    <SynchronousCommand wcm:action="add">
                        <RequiresUserInput>false</RequiresUserInput>
                        <Order>2</Order>
                        <Description>Active Windows</Description>
                        <CommandLine>cscript c:\windows\system32\slmgr.vbs /ato</CommandLine>
                    </SynchronousCommand>
    <SynchronousCommand wcm:action="add">
                        <CommandLine></CommandLine>
                        <Description>Disable UAC</Description>
                        <Order>3</Order>
                        <RequiresUserInput>false</RequiresUserInput>
                    </SynchronousCommand>
                </FirstLogonCommands>
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                    <NetworkLocation>Work</NetworkLocation>
                    <ProtectYourPC>3</ProtectYourPC>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                    <HideLocalAccountScreen>true</HideLocalAccountScreen>
                </OOBE>
                <UserAccounts>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>PASSWORD_LOCAL_ADMINISTRATOR</Value>
                                <PlainText>true</PlainText>
                            </Password>
                            <Description>Local Administrator</Description>
                            <DisplayName>LOGIN_LOCAL_ADMINISTRATOR</DisplayName>
                            <Group>Administrators</Group>
                            <Name>LOGIN_LOCAL_ADMINISTRATOR</Name>
                        </LocalAccount>
                    </LocalAccounts>
    <DomainAccounts>
    <DomainAccountList wcm:action="add">
    <DomainAccount wcm:action="add">
    <Group>Administrators</Group>
    <Name>USERNAME</Name>
    </DomainAccount>
    <Domain>DOMAIN_FQDN</Domain>
    </DomainAccountList>
    </DomainAccounts>
                </UserAccounts>
                <RegisteredOrganization>InfoVista SAS</RegisteredOrganization>
                <RegisteredOwner>InfoVista SAS</RegisteredOwner>
            </component>
        </settings>
    </unattend>

    Tuesday, August 14, 2018 6:59 AM
  • Just to clarify: you are not using Microsoft Deployment Toolkit for capture and subsequent deployment?

    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Tuesday, August 14, 2018 7:16 AM
  • no i am not.

    i use the KACE sysprep executor not the Microsoft Deployment Toolkit as i require the image to be uploaded to the KACE library for future deployments.

    Tuesday, August 14, 2018 7:47 AM
  • There is a dedicated Windows 10 Deployment Forum for issues not related to MDT. Regardless, I would start by validating the unattend.xml file using System Image Manager. 

    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Tuesday, August 14, 2018 8:05 AM
  • hi.

    many thanks. i will post this at that particular forum

    17 hours 20 minutes ago