locked
GFXUI.exe - .Net Framework Initialization Error RRS feed

  • Question

  • "unable to find a version of the runtime to run this application.

     

    We recently purchased 2 Dell E6430 laptops with a Intel HD Graphics 4000. When we attempt to go into the properties of the graphics software we get the abovementioned error. The laptops are imaged with Windows 7 -64 Bit. If we confgiure them with Vista they are okay. Have downloaded the latest driver from intel with no luck. Have tried l,ogging on with various accounts, inlcuding local admin, and the error still appears.

    Any assistance would be greatly appreciated.

    Thanks and regards.

    Bryan

    • Edited by Wotty04 Thursday, November 29, 2012 3:34 AM
    Thursday, November 29, 2012 3:33 AM

Answers

All replies

  • Hi,

    Please install the following package for a test:

    Microsoft .NET Framework 4 (Standalone Installer)

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    If you have any feedback on our support, please click here


    Alex Zhao
    TechNet Community Support

    • Marked as answer by Cloud_TS Tuesday, December 11, 2012 8:31 AM
    Friday, November 30, 2012 6:47 AM
  • Hi,

    Do you have any update?

    If you have any feedback on our support, please click here


    Alex Zhao
    TechNet Community Support

    Thursday, December 6, 2012 2:22 AM
  • Hi Alex,

    Unfortunately it didn't fix my problem. Also completed the following all to no avail:

    -Updates Bios

    -Disabled and re-enabled .Net 351

    -Installed .Net 4 and 4.5

    -Installed the latest video drivers from both Intel and Dell

    Thanks and regards.

    
    
    
    
    
    
    
    Monday, January 7, 2013 9:19 PM
  • Hi,

    I know this is a old post, but if it can help someone.

    The rights on machine.conf is the problem, I had the problem on many brand name computers.

    Just go to C:\Windows\Microsoft.NET\Framework\v0.0.0\config\ and change permissions for "Users" to Read & Execute.

    Hope this helps

    Thursday, June 27, 2013 7:35 PM
  • I had this problem on a number of different Dell models running Windows 7 x64 bit, with Intel Graphics HD cards. I had researched this for ages and done all of the suggested things...reinstalling .net 3.5, 4, 4.5, modifying permissions on the .Net folders, etc etc etc, with no luck.

    Turns out in my corporate image, .Net Framework 64bit was disabled (unknown how it happened), anyhow enabling it fixed the problem for me.

    Check the value of the HKLM\Software\Microsoft\.NETFramework\Enable64Bit key. Mine was set to 0 (which is disabled). Changing the value to 1 and rebooting fixed the problem.

    As a side note you can also run the following command line: "C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Ldr64.exe set64", this enables it and does not require a reboot.

    Hope this helps someone out..

    • Proposed as answer by MarkJF Wednesday, December 18, 2013 1:09 AM
    Wednesday, December 18, 2013 1:08 AM
  • Thank you Mark!  Bailed me out in a tough spot.

    I can confirm that the registry key does require a reboot where the command does not.

    Friday, April 18, 2014 4:37 PM